View Issue Details

IDProjectCategoryView StatusLast Update
12867Bug reports[All Projects] Survey takingpublic2017-11-29 17:27
Reporterdrogu02Assigned To 
PrioritynoneSeverityblock 
Status newResolutionopen 
Product Version2.7x.x 
Target VersionFixed in Version 
Summary12867: Lost question text after save and back to survey without saving
DescriptionQuestion and anwser don't appear after I go back to survey without saving it
Steps To ReproduceStart the survey (multi-page survey - One question per page)
Answer a question and click next
Answer another question and click next
Click Back to go back to the previous question
Click on the button Save survey
Click on the link Back to survey without save the survey

When I arrive to the survey, some times, the question and the anwsers don't appear
TagsNo tags attached.
Complete LimeSurvey version number (& build)2.72.3+171020
I will donate to the project if issue is resolvedNo
BrowserIE and Firefox and Chrome
Database & DB-Version10.0.28-MariaDB (same problem with mysql 5.0.8)
Operating System (Server)Linux
Webserver software & versionSLE 12 SP1 package
PHP Version7.0.7 (Same problem on php 5.3)

Activities

drogu02

drogu02

2017-11-03 20:37

reporter  

Step1.png (29,318 bytes)
Step1.png (29,318 bytes)
Step2.png (28,004 bytes)
Step2.png (28,004 bytes)
drogu02

drogu02

2017-11-03 20:41

reporter   ~44969

When the problem occurs, I do not seem to come back to the right question when I return to the questionnaire
DenisChenu

DenisChenu

2017-11-04 11:26

developer   ~44972

Can you trye with:
1. Close totally browser before click on reload link
2. Leave browser open (just close survey window, but have a second window)
3. Leave browser with same survey open.

And tell us the difference (i try to find the «survey, some times, the » part …)
drogu02

drogu02

2017-11-06 14:49

reporter   ~44982

The problem isn't with the reload.

When I am in the survey and I click on save, without saving the survey. The problem happen when I click the link «Return to survey» in the save page.
DenisChenu

DenisChenu

2017-11-06 15:07

developer   ~44983

OK :). Great , but i can not confirm.

1. goes to https://limesurvey.sondages.pro/363919
2. enter anything in the 1st input
3. Click Resume later
4. Click Return to survey
5. See the input filled.


Maybe something related to your survey, send the lss. Maybe with condition on group for example.
drogu02

drogu02

2017-11-08 18:23

reporter   ~45005

Here the lss

limesurvey_survey_785112.lss (458,313 bytes)
drogu02

drogu02

2017-11-08 18:24

reporter   ~45006

My survey doesn't have condition
drogu02

drogu02

2017-11-08 18:30

reporter   ~45007

I tried my survey with the default template and I have the same problem.
drogu02

drogu02

2017-11-29 14:42

reporter   ~45195

So, you tried with my lss?
DenisChenu

DenisChenu

2017-11-29 15:14

developer   ~45199

I don't test a such long survey … you must find the way for reproducing with a little survey.

Else : did you test an demo.limesurvey.org ?
drogu02

drogu02

2017-11-29 16:20

reporter   ~45201

For a test, you juste have to go for example at the third page, click previous, save and return to survey. You don't have to awnser all the questions.

We will debug that on our side, we will say you after what we did to resolve the problem.
robma13

robma13

2017-11-29 17:27

reporter   ~45204

Hello,

I was just checking on it and there may be something with the variable QUESTION_ID, which is generated in a div tag when we do the inspection on Google Chrome, for example. The steps are repeated here with the addition of the question id.

1) Start the survey (multi-page survey - One question per page) (id="question814")
2) Answer a question and click next (id="question841")
3) Answer another question and click next (id="question842")
4) Click Back to go back to the previous question (id="question841")
5) Click on the button Save Survey
6) Click on the link Back to survey without save the Survey (id="question842")

Why the redirection to question id we have been the latest instead of the question where we were when we clicked Save? Idk if there is something to do with the QUESTION_ID variable on LimeSurvey or something else in the source code, but at least, something have been tracked.

That's all I have to say right now.

Issue History

Date Modified Username Field Change
2017-11-03 20:37 drogu02 New Issue
2017-11-03 20:37 drogu02 File Added: Step1.png
2017-11-03 20:37 drogu02 File Added: Step2.png
2017-11-03 20:37 drogu02 File Added: Step3_After_Back_to_survey.png
2017-11-03 20:41 drogu02 Note Added: 44969
2017-11-04 11:26 DenisChenu Note Added: 44972
2017-11-06 14:49 drogu02 Note Added: 44982
2017-11-06 15:07 DenisChenu Note Added: 44983
2017-11-08 18:23 drogu02 File Added: limesurvey_survey_785112.lss
2017-11-08 18:23 drogu02 Note Added: 45005
2017-11-08 18:24 drogu02 Note Added: 45006
2017-11-08 18:30 drogu02 Note Added: 45007
2017-11-29 14:42 drogu02 Note Added: 45195
2017-11-29 15:14 DenisChenu Note Added: 45199
2017-11-29 16:20 drogu02 Note Added: 45201
2017-11-29 17:27 robma13 Note Added: 45204