View Issue Details

IDProjectCategoryView StatusLast Update
14204Bug reports[All Projects] Survey takingpublic2019-04-30 09:10
Reporteraellison9 Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.15.x 
Summary14204: Panel Integrations and lastpage set to -1
Description

We are currently running the current version of LS.
$config = '3.14.11';
$config = 355;
$config = '180926';
$config = true;
$config = '30059';

We have a survey which utilizes the Panel Integration capabilities to capture variables passed in via the query string. In our case, the parameter is named "segment" and it is mapped to a hidden question.

I've attached screenshots as well as sample surveys which should allow for reproduction of the issue. 648628 utilizes the normal welcome page and 639921 attempts to shift the Welcome message to a text block within a Question Group.

The issue seems to reside with the DB record written to store the Panel Integration variable which notes the "lastpage" with a value of -1. Based upon the PHP and progress_bar.twig debugging performed, the -1 causes issues with the progress calculation and the rendering of the "first page".

With debug=1, there is a PHP warning displayed but it seems to occur upstream of the actual issue. Screenshots attached just in case.

The issue we are encountering is the Welcome Page is not displayed correctly in situations where a participant clicks the survey link, lands on the Welcome Page, chooses not to take the survey at this time, and clicks the link later to return to complete the survey.

We believe the issue is related to a record being written to the "survey_####### " table to store the query string parameter and setting the "lastpage" equal to -1.

When the participant returns later, they receive a window with a negative (-200%) progress number and no welcome text. We tried dropping the Welcome Page and using text on a survey page but still continue to encounter the issue.

Steps To Reproduce

Steps to reproduce:
1) setup survey
2) create dummy tokens and activate survey
3) construct survey URL which includes segment and token query string variables
http://localhost:8080/index.php?r=survey/index&sid=648628&lang=en&segment=0&token=LFHiCzwkJr9LojB
4) open constructed link in Incognito window
5) Land on first page but take no further action
6) Close Incognito window
7) Open new Incognito Window with same constructed URL

You should see a screen similar to the screenshot labeled "no welcome message" which is attached.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.11 build 180926
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionPostgres 10.3 Limesurvey db version 355
Server OS (if known)Linux
Webserver software & version (if known)Nginx and FPM
PHP Version7.x

Activities

aellison9

aellison9

2018-11-01 20:21

reporter  

PHP_warning_2.png (272,978 bytes)
PHP_warning_1.png (272,498 bytes)
Broken_Welcome_page.png (38,320 bytes)
Broken_Welcome_page.png (38,320 bytes)
db_record.png (128,332 bytes)
Expected_Welcome_page.png (49,638 bytes)
Expected_Welcome_page.png (49,638 bytes)
limesurvey_survey_639921.lss (18,605 bytes)
limesurvey_survey_648628.lss (18,081 bytes)
DenisChenu

DenisChenu

2018-11-02 01:20

developer   ~49508

Last edited: 2018-11-02 01:21

View 2 revisions

Forum post : https://www.limesurvey.org/forum/design-issues/116843-panel-integrations-and-lastpage-set-to-1#176238 @tparner reproduce

PS : in my opinion : really good bug report here !

DenisChenu

DenisChenu

2019-01-18 18:11

developer   ~50279

@aellison9 : i can‘t reproduce on 3.15.6 : can you update and test again ?

aellison9

aellison9

2019-01-19 15:14

reporter   ~50284

@DenisChenu : thanks for the update. I cannot reproduce the exact issue with 3.15.6. Appreciate the fix.

Issue History

Date Modified Username Field Change
2018-11-01 20:21 aellison9 New Issue
2018-11-01 20:21 aellison9 File Added: PHP_warning_2.png
2018-11-01 20:21 aellison9 File Added: PHP_warning_1.png
2018-11-01 20:21 aellison9 File Added: Broken_Welcome_page.png
2018-11-01 20:21 aellison9 File Added: db_record.png
2018-11-01 20:21 aellison9 File Added: Expected_Welcome_page.png
2018-11-01 20:21 aellison9 File Added: limesurvey_survey_639921.lss
2018-11-01 20:21 aellison9 File Added: limesurvey_survey_648628.lss
2018-11-02 01:20 DenisChenu Note Added: 49508
2018-11-02 01:21 DenisChenu Note Edited: 49508 View Revisions
2018-11-28 09:40 DenisChenu Assigned To => DenisChenu
2018-11-28 09:40 DenisChenu Status new => assigned
2019-01-18 18:11 DenisChenu Note Added: 50279
2019-01-18 18:11 DenisChenu Status assigned => feedback
2019-01-19 15:14 aellison9 Note Added: 50284
2019-01-19 15:14 aellison9 Status feedback => assigned
2019-01-19 15:59 DenisChenu Assigned To DenisChenu =>
2019-01-19 15:59 DenisChenu Status assigned => resolved
2019-01-19 15:59 DenisChenu Resolution open => fixed
2019-01-19 15:59 DenisChenu Fixed in Version => 3.15.x
2019-04-30 09:10 c_schmitz Status resolved => closed