View Issue Details

IDProjectCategoryView StatusLast Update
12157Bug reports[All Projects] Survey takingpublic2018-06-04 15:02
Reporteruser14106Assigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version4.0.0dev 
Target VersionFixed in Version 
Summary12157: Subquestion relevance equation not working for for x-scale : Array (Numbers)
Description

Subquestion relevance equation not working for for x-scale : Array (Numbers)

Tested briefly the relevance equation for x-scale and does not seem to be working.

Using checkbox layout.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.59.1+170116
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMariaDB
Server OS (if known)Linux
Webserver software & version (if known)Apache2
PHP Version5.6

Relationships

duplicate of 12097 closeddominikvitt Relevance equation is shown for X axis in array number : it don't work 
related to 13739 closeddominikvitt Relevance equation broken for array by column 

Activities

c_schmitz

c_schmitz

2017-02-28 12:27

administrator   ~43089

Please attach a 2-question sample survey demonstrating the issue, Thank you.

DenisChenu

DenisChenu

2017-03-06 19:02

developer   ~43164

It never work, and nobody try to work on it : hiding column can not be done easily in javascript.

It's a cosmetic issue.

user14106

2017-03-06 19:14

  ~43165

I understand that it has never worked.
I noted this issue because the UI led me to believe it should work (because there were the fields).

Anyway.
Real life scenario on my table last week: I must filter by column.
Did a workaround using simply hiding nth columns based on previous answers with eg
$('#question{QID}').find('.answer td:nth-child(2),.answer th:nth-child(2)').hide();

Filtering arrays by columns is not often used but sometimes there is no way around it. I have seen commercial software do it.
I have no strong feelings about that, but I just thought maybe it was somehow intended to work (made me glad).
Would be good to have that in the long run.
If it is difficult to do now, then the fields should be hidden to avoid confusion.

user14106

2017-03-06 19:31

  ~43167

for what it's worth ...
an example survey.



limesurvey_survey_699879.lss (20,747 bytes)

user14106

2017-03-06 19:37

  ~43168

One more thing while discussing this type.
Not related to this issue, but what I noted while working on my columns last week.
if you set "mandatory" on this array. Its checked row by row. Sometimes it is more reasonable to make it mandatory by column (as was my case). Again - commercial software did it. I'll post a separate issue on that later :)

DenisChenu

DenisChenu

2017-03-07 08:39

developer   ~43173

Yes, i know you know ;)

About actual solution : more a workaround but in plugin : https://framagit.org/SondagePro-LimeSurvey-plugin/hideEmptyColumn/blob/master/README.md

orvil

orvil

2018-05-23 21:45

reporter   ~47794

It's note the only time this issue is reported. See e.g. 13441 and I remember there were some other too.
Because I would really enjoy this feature, I'm digging in the source code to find a solution. Had some progress yet, but still a lot of steps away from a final solution.

DenisChenu

DenisChenu

2018-05-26 10:54

developer   ~47861

@orvil : the issue with hiddin column against hiding line is more related to javascript :

$("tr#identity").hide() : hide line
$(col#identifty").hide() didn't hide column …

Issue History

Date Modified Username Field Change
2017-02-27 10:01 user14106 New Issue
2017-02-28 12:27 c_schmitz Assigned To => c_schmitz
2017-02-28 12:27 c_schmitz Status new => feedback
2017-02-28 12:27 c_schmitz Note Added: 43089
2017-03-06 18:41 user14106 Relationship added duplicate of 12097
2017-03-06 19:02 DenisChenu Note Added: 43164
2017-03-06 19:14 user14106 Note Added: 43165
2017-03-06 19:14 user14106 Status feedback => assigned
2017-03-06 19:31 user14106 File Added: limesurvey_survey_699879.lss
2017-03-06 19:31 user14106 Note Added: 43167
2017-03-06 19:37 user14106 Note Added: 43168
2017-03-07 08:39 DenisChenu Note Added: 43173
2017-03-07 11:26 c_schmitz Assigned To c_schmitz =>
2017-03-07 11:26 c_schmitz Status assigned => new
2018-05-23 12:20 LouisGac Product Version 2.59.x => 4.0.0dev
2018-05-23 21:45 orvil Note Added: 47794
2018-05-26 10:54 DenisChenu Note Added: 47861
2018-06-02 14:10 DenisChenu Assigned To => dominikvitt
2018-06-02 14:10 DenisChenu Status new => closed
2018-06-02 14:10 DenisChenu Resolution open => duplicate
2018-06-04 15:02 DenisChenu Relationship added related to 13739