View Issue Details

IDProjectCategoryView StatusLast Update
13739Bug reports[All Projects] Survey takingpublic2019-05-29 16:39
Reporterollehar Assigned Todominikvitt  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.8.x 
Target VersionFixed in Version3.17.x 
Summary13739: Relevance equation broken for array by column
Description

Title. See attached survey (using relevance equation with mandatory).

Steps To Reproduce
  1. Import survey
  2. Preview survey
  3. Subquestions are visible when they should be hidden
  4. Mandatory does not take into account subquestion relevance equation.
TagsNo tags attached.
Complete LimeSurvey version number (& build)latest master
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Relationships

related to 12157 closeddominikvitt Subquestion relevance equation not working for for x-scale : Array (Numbers) 
related to 13441 assignedDenisChenu Colums (still) can't be hidden in Array (numbers) questions 
has duplicate 14842 closedc_schmitz Array by column - relevance and validation fields are missing 

Activities

ollehar

ollehar

2018-06-04 14:30

administrator  

limesurvey_survey_444246.lss (21,116 bytes)
ollehar

ollehar

2018-06-04 14:43

administrator   ~47966

This is broken for ALL versions of LS.

ollehar

ollehar

2018-06-04 14:46

administrator   ~47967

Should either be fixed for real, OR disable rel eq in admin interface for this question type.

dominikvitt

dominikvitt

2018-06-11 11:26

developer   ~48041

confirmed in versions 2.73.0 and 3.9.0

guest

guest

2018-06-12 14:50

viewer   ~48066

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27383

dominikvitt

dominikvitt

2018-06-12 14:52

developer   ~48067

Relevance equation input for array by column question type is hidden to prevent future misunderstandings.

c_schmitz

c_schmitz

2018-06-15 15:43

administrator   ~48169

Version 3.12.1 Build 180616 released

c_schmitz

c_schmitz

2019-05-03 16:16

administrator   ~51760

This patch hides the relevance equation for the whole question.
The problem was with subquestion relevance only.
Please fix this properly.

dominikvitt

dominikvitt

2019-05-06 17:22

developer   ~51786

https://github.com/LimeSurvey/LimeSurvey/commit/7938bac95c6aafe0a176da7c6d6066ff74dbaeb9

c_schmitz

c_schmitz

2019-05-29 16:12

administrator   ~52194

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28922

c_schmitz

c_schmitz

2019-05-29 16:39

administrator   ~52208

Version 3.17.4+190529 released

Related Changesets

LimeSurvey: master 132db02e

2018-06-12 14:49:38

Dominik Vitt

Details Diff
Fixed issue 13739: Relevance equation broken for array by column Affected Issues
13739
mod - application/views/admin/survey/Question/editQuestion_view.php Diff File
mod - assets/scripts/admin/questions.js Diff File

LimeSurvey: master 7938bac9

2019-05-06 17:19:50

Dominik Vitt

Details Diff
Fixed issue 13739: Relevance equation broken for array by column Affected Issues
13739
mod - application/views/survey/questions/answer/arrays/column/answer.twig Diff File
mod - assets/packages/template-core/template-core.js Diff File
mod - assets/scripts/admin/questions.js Diff File

Issue History

Date Modified Username Field Change
2018-06-04 14:30 ollehar New Issue
2018-06-04 14:30 ollehar File Added: limesurvey_survey_444246.lss
2018-06-04 14:43 ollehar Note Added: 47966
2018-06-04 14:46 ollehar Note Added: 47967
2018-06-04 15:02 DenisChenu Relationship added related to 12157
2018-06-04 15:02 DenisChenu Relationship added related to 13441
2018-06-11 10:30 LouisGac Assigned To => dominikvitt
2018-06-11 10:30 LouisGac Status new => assigned
2018-06-11 11:26 dominikvitt Status assigned => confirmed
2018-06-11 11:26 dominikvitt Note Added: 48041
2018-06-12 14:50 Changeset attached => LimeSurvey master 132db02e
2018-06-12 14:50 guest Note Added: 48066
2018-06-12 14:50 guest Resolution open => fixed
2018-06-12 14:52 dominikvitt Status confirmed => resolved
2018-06-12 14:52 dominikvitt Fixed in Version => 3.10.x
2018-06-12 14:52 dominikvitt Note Added: 48067
2018-06-15 15:43 c_schmitz Note Added: 48169
2018-06-15 15:43 c_schmitz Status resolved => closed
2019-05-03 16:13 c_schmitz Relationship added related to 14842
2019-05-03 16:16 c_schmitz Status closed => feedback
2019-05-03 16:16 c_schmitz Resolution fixed => reopened
2019-05-03 16:16 c_schmitz Note Added: 51760
2019-05-03 16:16 c_schmitz Relationship deleted related to 14842
2019-05-03 16:17 c_schmitz Relationship added has duplicate 14842
2019-05-03 16:17 c_schmitz Status feedback => assigned
2019-05-06 17:22 dominikvitt Status assigned => resolved
2019-05-06 17:22 dominikvitt Resolution reopened => fixed
2019-05-06 17:22 dominikvitt Fixed in Version 3.10.x => 3.17.x
2019-05-06 17:22 dominikvitt Note Added: 51786
2019-05-29 16:12 Changeset attached => LimeSurvey master 7938bac9
2019-05-29 16:12 c_schmitz Note Added: 52194
2019-05-29 16:39 c_schmitz Note Added: 52208
2019-05-29 16:39 c_schmitz Status resolved => closed