View Issue Details

IDProjectCategoryView StatusLast Update
09769Bug reportsOtherpublic2015-07-24 11:44
ReporterBigred Assigned ToDenisChenu  
PrioritylowSeverityminor 
Status closedResolutionfixed 
Fixed in Version2.06+ 
Summary09769: Manually changing language in preview url then previewing group breaks logic on questions
DescriptionThis could very well be the most irrelevant bug posted on here but im not sure if it has any further implications so im posting it anyways.

This survey is in english (primary) and french.

Lime Version 2.05+ Build 141020

I have a question group with 15 questions in it. The first question is a text display that shows the question text, the next 14 are multiple choice questions half showing to one group of people, the other half showing to the other.

When previewing the group all i see is the text display question, which makes sense. The other 14 questions have logic on them connected to tokens so they shouldn't show.

After manually adding /lang/fr to the preview url, page load with just the text display showing in french which makes sense. After forcing the language change, the next time I click preview group, all questions in group show regardless of what logic is on them.
TagsNo tags attached.
Complete LimeSurvey version number (& build)
I will donate to the project if issue is resolved
Browser
Database & DB-Version
Server OS (if known)
Webserver software & version (if known)
PHP Version

Activities

DenisChenu

DenisChenu

2015-07-15 23:53

developer   ~32703

Last edited: 2015-07-15 23:53

View 2 revisions

Can not reproduce with included test survey (fr/en/de , Condition and scenario group).

Maybe only with token ? Can you upload a little lsa file (Survey archive with token) to try to reproduce ?

ANd try with last 2.06 version.

Bigred

Bigred

2015-07-17 00:12

reporter  

Bigred

Bigred

2015-07-17 00:15

reporter   ~32708

I have attached a test survey.

If you go to test2 group and preview english, you will see the text display question only because every other question in the group has skip logic on it.

In the url, add /lang/fr to the end and press enter. Once the page loads in french, close the tab then preview the group again. All questions will now be showing regardless of their skip logic.

PS - Subquestion Relevance... Very Cool. (my first look at 2.06)
DenisChenu

DenisChenu

2015-07-17 08:46

developer   ~32709

Oh no, have this :
- Import
- Go to group 2
- Preview (default) : see all question ....
- Reload : see only first question
- Add lang/fr : see only first question
- Close tab
- Preview (default) : see all question ....

confirmed, but this one seems very hard to track down
DenisChenu

DenisChenu

2015-07-19 14:09

developer   ~32721

Condition :
- Web site default language is set to secondary language of survey

Problem :
- SetSurveyLanguage is call 2 times with a different way to set language. Then 1st path : FR, second path : EN

Problem 2 :
- Even in this condition, this must don't break EM ...
DenisChenu

DenisChenu

2015-07-20 14:43

developer   ~32725

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=15579
c_schmitz

c_schmitz

2015-07-24 11:44

administrator   ~32782

Version 2.06 Build 150723 released

Related Changesets

LimeSurvey: master ea7bf968

2015-07-20 12:32:15

DenisChenu

Details Diff
Fixed issue 09769: Preview url can breaks logic on questions
Dev: EM is set to global default language
Dev: buildsurveysession update language but don't set EM partially to this language
Dev: Equation are not set for new language
Affected Issues
09769
mod - application/controllers/survey/index.php Diff File
mod - application/helpers/frontend_helper.php Diff File

Issue History

Date Modified Username Field Change
2015-07-09 20:22 Bigred New Issue
2015-07-11 18:22 DenisChenu Project Feature requests => Bug reports
2015-07-15 23:51 DenisChenu Priority normal => low
2015-07-15 23:51 DenisChenu Severity feature => minor
2015-07-15 23:53 DenisChenu Note Added: 32703
2015-07-15 23:53 DenisChenu Assigned To => DenisChenu
2015-07-15 23:53 DenisChenu Status new => feedback
2015-07-15 23:53 DenisChenu Note Edited: 32703 View Revisions
2015-07-17 00:12 Bigred File Added: limesurvey_survey_696698.lss
2015-07-17 00:15 Bigred Note Added: 32708
2015-07-17 00:15 Bigred Status feedback => assigned
2015-07-17 08:46 DenisChenu Note Added: 32709
2015-07-17 08:46 DenisChenu Status assigned => confirmed
2015-07-19 14:09 DenisChenu Note Added: 32721
2015-07-20 14:43 DenisChenu Changeset attached => LimeSurvey master ea7bf968
2015-07-20 14:43 DenisChenu Note Added: 32725
2015-07-20 14:43 DenisChenu Resolution open => fixed
2015-07-20 15:42 DenisChenu Status confirmed => resolved
2015-07-20 15:42 DenisChenu Fixed in Version => 2.06+
2015-07-24 11:44 c_schmitz Note Added: 32782
2015-07-24 11:44 c_schmitz Status resolved => closed