View Issue Details

IDProjectCategoryView StatusLast Update
09443Feature requestsTranslationpublic2021-02-17 15:56
Reportervbraque Assigned ToDenisChenu  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Fixed in Version3.0 
Summary09443: Some "Logic" attributes of a question are not internationalized (advanced settings)
DescriptionThe following attributes: "Question validation tip" and "Sub-question validation tip", on the "Logic" section of a question (advanced settings) are not internationalized.
You can compare with other similar attributes correctly internationalized, for example, "Answer prefix (language)" or "Answer suffix (language)", on the "Display" section of a question (advanced settings). In these cases, one text box is shown for every language defined in the survey.
Steps To ReproduceAccess to "edit question", section "Logic", atrributes "Question validation tip" and "Sub-question validation tip" and verify it's only a text box for each other, instead of a text box for every language defined in the survey.
Additional InformationThere's no necessity to attach a survey design for this issue as it describes a generic missing of functionality.
TagsNo tags attached.

Activities

vbraque

vbraque

2015-01-15 10:12

reporter   ~31465

Suggestion: An approach similar to "Answer prefix (language)" or "Answer suffix (language)" attributes, on the "Display" section of a question (advanced settings) would be enough to get this functionality.
In my experience (multilingual surveys) some simple survey designs are not possible due to this functionality missing cause the text attached to the "Question validation tip" and "Sub-question validation tip" atrributes only appear in the survey's base language.
vbraque

vbraque

2015-09-04 09:49

reporter   ~33059

Hi... I'd like to know if this bug will be implemented someday or has been discarded definitely. Tks.
DenisChenu

DenisChenu

2016-02-05 08:37

developer   ~34612

You put this in Developpement .... more a featuire request here ..

Use the good place please
vbraque

vbraque

2016-02-05 10:47

reporter   ~34621

Well, I did it this way cause I thought this feature already exists but may be you'll consider to improve it. If you consider this as a new feature, must I re-create this bug on the corresponding category? or... could you move it?
jcarberry

jcarberry

2021-01-26 16:25

reporter   ~61687

I don't see any place to vote for proposed enhancements. So I note here that this feature request would have a very high priority for me.
DenisChenu

DenisChenu

2021-01-26 16:34

developer   ~61688

> The following attributes: "Question validation tip" and "Sub-question validation tip", on the "Logic" section of a question (advanced settings) are not internationalized.

Question validation **tip** and Sub-question validation **tip** are internationalized in 3.LTS and in 4.4 (but i don't really like the new way)
DenisChenu

DenisChenu

2021-01-26 16:47

developer   ~61689

Seems fixed

Issue History

Date Modified Username Field Change
2015-01-08 09:50 vbraque New Issue
2015-01-15 10:12 vbraque Note Added: 31465
2015-09-04 09:49 vbraque Note Added: 33059
2016-02-05 08:37 DenisChenu Project Development => Feature requests
2016-02-05 08:37 DenisChenu Category Survey Design => Other issues
2016-02-05 08:37 DenisChenu Note Added: 34612
2016-02-05 08:38 DenisChenu Severity @50@ => feature
2016-02-05 08:38 DenisChenu Category Other issues => Accessibility
2016-02-05 10:47 vbraque Note Added: 34621
2016-04-30 19:56 DenisChenu Category Accessibility => Translation
2021-01-26 16:25 jcarberry Note Added: 61687
2021-01-26 16:34 DenisChenu Note Added: 61688
2021-01-26 16:47 DenisChenu Assigned To => DenisChenu
2021-01-26 16:47 DenisChenu Status new => feedback
2021-01-26 16:47 DenisChenu Note Added: 61689
2021-02-17 15:56 DenisChenu Status feedback => closed
2021-02-17 15:56 DenisChenu Resolution open => fixed
2021-02-17 15:56 DenisChenu Fixed in Version => 3.0