View Issue Details

IDProjectCategoryView StatusLast Update
09134Bug reports[All Projects] Otherpublic2014-07-23 17:25
ReporteraestebanAssigned ToDenisChenu 
PrioritynormalSeveritymajor 
Status closedResolutionfixed 
Product Version2.05+ 
Target VersionFixed in Version2.05+ 
Summary09134: Database error when trying to reload survey data
DescriptionDatabase error when trying to reload survey data. This limesurvey instance has just been upgraded from version 2.00+ to 2.05+
Steps To Reproduce1.- Fill out partially a survey
2.- Save reponse to continue later (choose name, password and email)
3.- Close your browser and open it again
4.- Try to reload saved response by entering name and password. You will get the following error:

Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'alfredo2'' AND lime_saved_control.access_code = '88cbfa79e05f3e1345d949c3cf91e66' at line 4

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.
Additional InformationIMPORTANT: This limesurvey instance has just been upgraded from version 2.00+ to 2.05+. SQL structure upgrade was successfully executed after first login.
TagsNo tags attached.
Complete LimeSurvey version number (& build)140703
I will donate to the project if issue is resolvedNo
BrowserChromium
Database & DB-VersionMysql 5.1
Operating System (Server)RHEL 6.5
Webserver software & versionApache 2.2.15
PHP Versionphp 5.3.3

Relationships

has duplicate 09144 closedDenisChenu Loading unfinished survey is not possible 

Activities

aesteban

aesteban

2014-07-07 11:34

developer  

survey_archive_961684.lsa (4,318 bytes)
DenisChenu

DenisChenu

2014-07-09 17:18

developer   ~30282

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14323
DenisChenu

DenisChenu

2014-07-09 17:18

developer   ~30283

@Carsten : can you test with mssql ? Without CAST if possible.
MOQ

MOQ

2014-07-15 08:50

reporter   ~30296

Hey DenisChenu. I am facing a similar issue to this.

I get the same error except for the last line - I get:

AND lime_saved_control.access_code = 'b1f4f9a523e36fd969f4573e25af4540'' at line 5

I am using Lime Survey Version 2.05+ Build 140703
MySQL version 5.0.95
PHP 5.3.3
CentOS release 5.10 (Final)
Apache 2.2.3

From the Issue History it looks like the issue is fixed in 2.05+. Is it a case of waiting for 2.06 or it should be in 2.05 and I have something else a miss.

Thank you heaps in advance.

Dean
DenisChenu

DenisChenu

2014-07-15 13:45

developer   ~30297

Hi,

resolved : fixed in GIT version, but last release don't have the fix. Then you can : apply same fix in the actual release or download the last GIT version and update all files.
To have the fix in the build : it's closed.

user34462

2014-07-17 14:19

  ~30313

Hi,

!!! After the update (I downloaded and copyed both files) it's impossible to pass to the second page of the survey.
After clicking the next button it appears a blank page.

^_^ Solved overwriting the original files with the GitHub Files.


!!! After the second update the program doesn't load partyally answered pages.
For Example, we are trying to retrieve the second page that we saved with only 2 answers out of 15 answered.
However it loaded the first page that was completed.

I'm using limesurvey 2.05+ build 140703
on WAMP server
on Windows 7

Thank you in advance.

Antonio.
c_schmitz

c_schmitz

2014-07-23 17:25

administrator   ~30324

2.05+ Build 140717 released

Related Changesets

LimeSurvey: master e86b028c

2014-07-09 15:17:54

DenisChenu

Details Diff
Fixed issue 09134: Database error when trying to reload survey data
Dev: just using Yii
Dev: Think mssql with Yii don't need CAST
mod - application/controllers/survey/index.php Diff File
mod - application/helpers/frontend_helper.php Diff File

Issue History

Date Modified Username Field Change
2014-07-07 11:34 aesteban New Issue
2014-07-07 11:34 aesteban File Added: survey_archive_961684.lsa
2014-07-07 19:05 DenisChenu Assigned To => DenisChenu
2014-07-07 19:05 DenisChenu Status new => assigned
2014-07-09 17:18 DenisChenu Changeset attached => LimeSurvey master e86b028c
2014-07-09 17:18 DenisChenu Note Added: 30282
2014-07-09 17:18 DenisChenu Resolution open => fixed
2014-07-09 17:18 DenisChenu Status assigned => resolved
2014-07-09 17:18 DenisChenu Fixed in Version => 2.05+
2014-07-09 17:18 DenisChenu Note Added: 30283
2014-07-15 08:50 MOQ Note Added: 30296
2014-07-15 13:45 DenisChenu Note Added: 30297
2014-07-15 16:06 DenisChenu Relationship added has duplicate 09144
2014-07-17 14:19 user34462 Note Added: 30313
2014-07-23 17:25 c_schmitz Note Added: 30324
2014-07-23 17:25 c_schmitz Status resolved => closed