View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
08273Feature requestsSurvey participants (Tokens)public2021-11-04 11:44
ReporterDenisChenu Assigned Togalads  
PrioritynormalSeverity@50@ 
Status closedResolutionreopened 
Product Version2.00+ 
Fixed in Version5.x 
Summary08273: Sending invitation don't test particpant blacklist
DescriptionAny admin can add a email in token table, if this email is in blacklist of participant DB : email are send to this user without control.
Steps To ReproduceCreate a token table for any survey
Add a user in DB with a existing email, and put it in blacklist
Add same email adress to token table
Send the invitation: blaclisted email adresse receive the message.
Additional InformationThink we HAVE to allways use blacklist when sending any email :
- Token
- Inscription
- Confirmation
- Admin notification
- Admin inscription.

But token incitaion is the first one to do.

Maybe it can be done in models.
TagsNo tags attached.
Bug heat6

Relationships

related to 09629 assignedc_schmitz Global opt out link for CPDB missing 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2013-10-14 09:42

developer   ~26787

Last edited: 2013-10-14 09:42

View 2 revisions

Myabe a new featire request too (and maybe in plugin).

- In OptOut system:
Add 2 checkbox:
* one checked: remove my email adress for this survey
* one unchecked: remove my email adress for all email adress on this system

c_schmitz

c_schmitz

2013-10-14 10:18

administrator   ~26791

BLacklisting blacklists the user, not only the email. If you add the user from CPDB to the tokens it should blacklist it properly. Otherwise CPDB does not know about it.
DenisChenu

DenisChenu

2013-10-14 10:22

developer   ~26792

Yes,

But need too blaclisting email, not only user, no ?
And need a plugin for this ?

For user: it's more inscription , not blacklisting.

A lot of "mail sending" system have a global blacklist, and think it's needed by some law in some country.
c_schmitz

c_schmitz

2013-10-14 10:25

administrator   ~26793

Yes, I am not saying it is perfect, just that it is not a bug. :-)
DenisChenu

DenisChenu

2013-10-14 10:57

developer   ~26794

OK,

Then allowed to
- Test if email is not in blacklist when sending invitation/remind
- Test if emil is not in blaclist with all other email (not sure for this one)
- Add a globalsettings to deactivate this system (maybe 0: deactivate, 1 : public system (invitation/remind/inscription), 2: all). Default to 1
For 2.0 or 2.05 ?

Start a plugin to set this globalsettings in globalsettings (2.05?2.06?)
c_schmitz

c_schmitz

2013-10-14 10:58

administrator   ~26795

Both 2.05 at earliest
DenisChenu

DenisChenu

2021-11-04 08:48

developer   ~67106

We don't have a feature request about this ?
https://github.com/LimeSurvey/LimeSurvey/pull/2125
galads

galads

2021-11-04 09:08

administrator   ~67108

Oh ya, I remember Gabriel implemented a global opt-out link. I will close this
DenisChenu

DenisChenu

2021-11-04 11:43

developer   ~67111

open => closed as duplicate ;)

Issue History

Date Modified Username Field Change
2013-10-14 08:55 DenisChenu New Issue
2013-10-14 09:42 DenisChenu Note Added: 26787
2013-10-14 09:42 DenisChenu Note Edited: 26787 View Revisions
2013-10-14 10:17 c_schmitz Project Bug reports => Feature requests
2013-10-14 10:18 c_schmitz Note Added: 26791
2013-10-14 10:22 DenisChenu Note Added: 26792
2013-10-14 10:25 c_schmitz Note Added: 26793
2013-10-14 10:57 DenisChenu Note Added: 26794
2013-10-14 10:58 c_schmitz Note Added: 26795
2016-12-08 10:39 c_schmitz Category Tokens => Survey participants (Tokens)
2021-11-04 07:50 galads Assigned To => galads
2021-11-04 07:50 galads Status new => acknowledged
2021-11-04 08:48 DenisChenu Note Added: 67106
2021-11-04 08:48 DenisChenu Relationship added related to 09629
2021-11-04 09:08 galads Note Added: 67108
2021-11-04 09:08 galads Bug heat 4 => 6
2021-11-04 09:08 galads Status acknowledged => closed
2021-11-04 09:08 galads Resolution open => fixed
2021-11-04 11:43 DenisChenu Status closed => feedback
2021-11-04 11:43 DenisChenu Resolution fixed => reopened
2021-11-04 11:43 DenisChenu Note Added: 67111
2021-11-04 11:44 DenisChenu Status feedback => closed
2021-11-04 11:44 DenisChenu Fixed in Version => 5.x