Anonymous Login
2016-12-04 02:53 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
07661Bug reports[All Projects] Data Entry (non public)public2013-05-17 14:24
Reporteraages 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary07661: Big 'R' in title-field disappers when saving title
DescriptionA bit peculiar problem with the title field appears, when I use the letter 'R' in the title of the survey (and this happens only with big ‘R’). The ‘R’ disappears when I save the title and viewing it. But when I enter edit-mode, it is still there. And is also shown correct when using the survey. I assume this is a bug?
Additional InformationServer charset: UTF-8 Unicode (utf8)
norwegian
TagsNo tags attached.
Complete LimeSurvey version number (& build)130311
I will donate to the project if issue is resolvedNo
Browsergoogle chrome
Database & DB-VersionMySQL 5.1.68-cll
Operating System (Server)LINUX (LAMP)
Webserver software & versionLinux cpanel
PHP VersionPHP 5,4
Attached Files

-Relationships
related to 07840closedc_schmitz Short Text responses not displaying properly in .csv export 
+Relationships

-Notes

~24688

c_schmitz (administrator)

Last edited: 2013-03-13 23:29

View 2 revisions

It is not a bug but a problem with your PHP installation, to be detailed: The PCRE library behind it. It would be interesting to know what PCRE version you have installed. Can you attach your PHPInfo, please?

~24689

aages (reporter)

Yes, it is
PCRE Library Version: 6.6 06-Feb-2006

~24690

DenisChenu (developer)

Last edited: 2013-03-14 09:35

View 2 revisions

Maybe test PCRE version for ~R~u ?

Mine is 8.02 2010-03-19

aages : the cpanel is not the "real" server, maybe you can view with your hoster to update PCRE .

PHE 5.4 is young, mine is 5.3.3 and PCRE is up to date.

Denis
Maybe some idea here: http://www.bigboylemonade.com/pcre-version-problem-on-cpanel

~24691

c_schmitz (administrator)

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11889

~24692

c_schmitz (administrator)

This is the official PHP version<->PCRE version list:

http://www.php.net/manual/en/pcre.installation.php

aages, clearly your server provider has their server misconfigured. The patch has a workaround, though.

~24701

aages (reporter)

Thanks for good information!
I will contact my ISP about this.

~24714

c_schmitz (administrator)

New version released.

~24729

c_schmitz (administrator)

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11923
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2013-03-13 18:22 aages New Issue
2013-03-13 18:22 aages File Added: limesurvey_survey_43253 (1).lss
2013-03-13 23:23 c_schmitz Note Added: 24688
2013-03-13 23:23 c_schmitz Assigned To => c_schmitz
2013-03-13 23:23 c_schmitz Status new => feedback
2013-03-13 23:23 c_schmitz File Deleted: limesurvey_survey_43253 (1).lss
2013-03-13 23:29 c_schmitz Note Edited: 24688 View Revisions
2013-03-14 00:36 aages File Added: php-info.docx
2013-03-14 00:36 aages Note Added: 24689
2013-03-14 00:36 aages Status feedback => assigned
2013-03-14 09:33 DenisChenu Note Added: 24690
2013-03-14 09:35 DenisChenu Note Edited: 24690 View Revisions
2013-03-14 22:25 c_schmitz Changeset attached => LimeSurvey master 7914709b
2013-03-14 22:25 c_schmitz Note Added: 24691
2013-03-14 22:25 c_schmitz Resolution open => fixed
2013-03-14 22:29 c_schmitz Note Added: 24692
2013-03-14 22:29 c_schmitz Status assigned => resolved
2013-03-14 22:29 c_schmitz Fixed in Version => 2.00+
2013-03-15 15:23 aages Note Added: 24701
2013-03-17 12:12 c_schmitz Note Added: 24714
2013-03-17 12:12 c_schmitz Status resolved => closed
2013-03-17 15:40 c_schmitz Changeset attached => LimeSurvey 2.05 feb89902
2013-03-17 15:40 c_schmitz Note Added: 24729
2013-05-17 14:24 c_schmitz Relationship added related to 07840
+Issue History