Anonymous Login
2016-12-03 05:34 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
06878Bug reports[All Projects] Otherpublic2012-11-16 09:17
Reportersdomas 
Assigned ToDenisChenu 
PrioritynormalSeverityblock 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version 
Summary06878: general parameters
DescriptionDuring the edition(publishing) of the general parameters of a questionnaire the parameters registered(recorded) in the base(basis) are not read again by the application and not are posted(shown) in the form of edition(publishing). It is the parameters by default that are posted(shown).
Steps To Reproducehttp://www.ac-grenoble.fr/citic/colleges/test_ls/limesurvey/admin

login : admin
password : admin
Additional InformationError message :

 Undefined variable: aData

/home/www/html/citic/colleges/test_ls/limesurvey/application/controllers/admin/surveyadmin.php(181)

The command echo aData; inserted in the line 168 of application/controllers/admin/surveyadm in.php return Array
TagsNo tags attached.
Complete LimeSurvey version number (& build)121115
I will donate to the project if issue is resolvedNo
BrowserFirefox 16.02 - Ubuntu 12.04
Database & DB-VersionMysql 5.1.49-3
Operating System (Server)Debian lenny16
Webserver software & versionApache
PHP VersionPHP Version 5.2.6-1+
Attached Files
  • txt file icon limesurvey_debug.txt (7,045 bytes) 2012-11-15 14:25 -
    PHP notice
    
    Undefined variable: aData
    
    /home/www/html/citic/colleges/test_ls/limesurvey/application/controllers/admin/surveyadmin.php(181)
    
    169         $aData = array_merge($aData, $this->_generalTabEditSurvey($iSurveyID, $esrow));
    170         $aData = array_merge($aData, $this->_tabPresentationNavigation($esrow));
    171         $aData = array_merge($aData, $this->_tabPublicationAccess($esrow));
    172         $aData = array_merge($aData, $this->_tabNotificationDataManagement($esrow));
    173         $aData = array_merge($aData, $this->_tabTokens($esrow));
    174         $aData = array_merge($aData, $this->_tabPanelIntegration($esrow));
    175         $aData = array_merge($aData, $this->_tabResourceManagement($iSurveyID));
    176 
    177         $oResult = Questions::model()->getQuestionsWithSubQuestions($iSurveyID, $esrow['language'], "({{questions}}.type = 'T'  OR  {{questions}}.type = 'Q'  OR  {{questions}}.type = 'T' OR {{questions}}.type = 'S')");
    178 
    179         $aData['questions'] = $oResult;
    180         $aData['display']['menu_bars']['surveysummary'] = "editsurveysettings";
    181         $aData['data'] = $aData;
    182     
    183         $this->_renderWrappedTemplate('survey', 'editSurvey_view', $aData);
    184     }
    185 
    186     /**
    187     * Function responsible to import survey resources from a '.zip' file.
    188     *
    189     * @access public
    190     * @return void
    191     */
    192     function importsurveyresources()
    193     {
    
    Stack Trace
    #0 	
     unknown(0): SurveyAdmin->editsurveysettings("595913")
    #1 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/actions/CAction.php(107): ReflectionMethod->invokeArgs(SurveyAdmin, array("595913"))
    
    102             else if($param->isDefaultValueAvailable())
    103                 $ps[]=$param->getDefaultValue();
    104             else
    105                 return false;
    106         }
    107         $method->invokeArgs($object,$ps);
    108         return true;
    109     }
    110 }
    
    #2 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/application/core/Survey_Common_Action.php(82): CAction->runWithParamsInternal(SurveyAdmin, ReflectionMethod, array("surveyid" => "595913", "sa" => "editsurveysettings", "iSurveyId" => "595913", "iSurveyID" => "595913"))
    
    77             $oMethod = new ReflectionMethod($this, $sDefault);
    78         }
    79 
    80         // We're all good to go, let's execute it
    81         // runWithParamsInternal would automatically get the parameters of the method and populate them as required with the params
    82         return parent::runWithParamsInternal($this, $oMethod, $params);
    83     }
    84 
    85     /**
    86     * Some functions have different parameters, which are just an alias of the
    87     * usual parameters we're getting in the url. This function just populates
    
    #3 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/CController.php(309): Survey_Common_Action->runWithParams(array("surveyid" => "595913", "sa" => "editsurveysettings"))
    
    304     {
    305         $priorAction=$this->_action;
    306         $this->_action=$action;
    307         if($this->beforeAction($action))
    308         {
    309             if($action->runWithParams($this->getActionParams())===false)
    310                 $this->invalidActionParams($action);
    311             else
    312                 $this->afterAction($action);
    313         }
    314         $this->_action=$priorAction;
    
    #4 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/CController.php(287): CController->runAction(SurveyAdmin)
    
    282      * @see runAction
    283      */
    284     public function runActionWithFilters($action,$filters)
    285     {
    286         if(empty($filters))
    287             $this->runAction($action);
    288         else
    289         {
    290             $priorAction=$this->_action;
    291             $this->_action=$action;
    292             CFilterChain::create($this,$action,$filters)->run();
    
    #5 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/CController.php(266): CController->runActionWithFilters(SurveyAdmin, array())
    
    261         {
    262             if(($parent=$this->getModule())===null)
    263                 $parent=Yii::app();
    264             if($parent->beforeControllerAction($this,$action))
    265             {
    266                 $this->runActionWithFilters($action,$this->filters());
    267                 $parent->afterControllerAction($this,$action);
    268             }
    269         }
    270         else
    271             $this->missingAction($actionID);
    
    #6 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/application/controllers/AdminController.php(159): CController->run("survey")
    
    154                 Yii::app()->session['redirectopage'] = Yii::app()->request->requestUri;
    155 
    156                 $this->redirect($this->createUrl('/admin/authentication/login'));
    157             }
    158 
    159             return parent::run($action);
    160     }
    161 
    162     /**
    163     * Routes all the actions to their respective places
    164     *
    
    #7 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/CWebApplication.php(276): AdminController->run("survey")
    
    271         {
    272             list($controller,$actionID)=$ca;
    273             $oldController=$this->_controller;
    274             $this->_controller=$controller;
    275             $controller->init();
    276             $controller->run($actionID);
    277             $this->_controller=$oldController;
    278         }
    279         else
    280             throw new CHttpException(404,Yii::t('yii','Unable to resolve the request "{route}".',
    281                 array('{route}'=>$route===''?$this->defaultController:$route)));
    
    #8 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/web/CWebApplication.php(135): CWebApplication->runController("admin/survey/sa/editsurveysettings")
    
    130             foreach(array_splice($this->catchAllRequest,1) as $name=>$value)
    131                 $_GET[$name]=$value;
    132         }
    133         else
    134             $route=$this->getUrlManager()->parseUrl($this->getRequest());
    135         $this->runController($route);
    136     }
    137 
    138     /**
    139      * Registers the core application components.
    140      * This method overrides the parent implementation by registering additional core components.
    
    #9 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/framework/base/CApplication.php(162): CWebApplication->processRequest()
    
    157      */
    158     public function run()
    159     {
    160         if($this->hasEventHandler('onBeginRequest'))
    161             $this->onBeginRequest(new CEvent($this));
    162         $this->processRequest();
    163         if($this->hasEventHandler('onEndRequest'))
    164             $this->onEndRequest(new CEvent($this));
    165     }
    166 
    167     /**
    
    #10 	
    –
     /home/www/html/citic/colleges/test_ls/limesurvey/index.php(178): CApplication->run()
    
    173  *
    174  */
    175 require_once BASEPATH . 'yii' . EXT;
    176 require_once APPPATH . 'core/LSYii_Application' . EXT;
    177 
    178 Yii::createApplication('LSYii_Application', APPPATH . 'config/config' . EXT)->run();
    179 
    180 /* End of file index.php */
    181 /* Location: ./index.php */
    
    
    txt file icon limesurvey_debug.txt (7,045 bytes) 2012-11-15 14:25 +

-Relationships
+Relationships

-Notes

~22184

c_schmitz (administrator)

I am sorry but I cannot reproduce this here.

If you look into the source then you can see that the error message must be bogus because $aData is set in the previous line ( $aData['display']['menu_bars']['surveysummary'] = "editsurveysettings"; )

I suspect a bug in your PHP version or some server misconfiguration. Try to find another server to install it on or update your PHP.

Anyway, I am sorry, but it is not a LimeSurvey bug.

~22226

DenisChenu (developer)

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10320

~22227

DenisChenu (developer)

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10321
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2012-11-15 14:25 sdomas New Issue
2012-11-15 14:25 sdomas File Added: limesurvey_debug.txt
2012-11-15 15:02 c_schmitz Note Added: 22184
2012-11-15 15:02 c_schmitz Status new => closed
2012-11-15 15:02 c_schmitz Assigned To => c_schmitz
2012-11-15 15:02 c_schmitz Resolution open => unable to reproduce
2012-11-16 09:16 DenisChenu Changeset attached => LimeSurvey master b84efed7
2012-11-16 09:16 DenisChenu Note Added: 22226
2012-11-16 09:16 DenisChenu Assigned To c_schmitz => DenisChenu
2012-11-16 09:16 DenisChenu Resolution unable to reproduce => fixed
2012-11-16 09:17 DenisChenu Changeset attached => LimeSurvey 2.1 ed5acb05
2012-11-16 09:17 DenisChenu Note Added: 22227
+Issue History