View Issue Details

IDProjectCategoryView StatusLast Update
06647Bug reportsInstallationpublic2012-10-05 16:05
Reporterneilk Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionunable to reproduce 
Product Version1.92+ 
Summary06647: LS 1.92 to 2.0 install fails because of missing mysql file
Description

I received the following error message updating LS from 1.92 to 2.0:

Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'limesurvey.lime_survey_links' doesn't exist

The LS installation runs on a hosted vps in a standard LAMP environment, MySQL version 5.5. Before updating I confirmed that LS worked and made a backup of the database using phpMyAdmin. Looking at the backup I did not see the missing file. I didn't see it in the database either.

I've been using LS for about 8 months and done a fair number of updates without a problem, including another successful 1.92 -> 2.0 update for another LS installation. I'm not a database professional (I'm a market researcher) and am at a loss about how to proceed.

I've moved this issue from the forums to the bug tracker. Thanks for any help.

TagsNo tags attached.
Complete LimeSurvey version number (& build)120530
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-VersionMySQL 5.5.20
Server OS (if known)CentOS 6.2
Webserver software & version (if known)Apache/2.2.15 (Unix)
PHP Version5.3.9

Activities

c_schmitz

c_schmitz

2012-10-05 09:14

administrator   ~21048

I can't reproduce. Which 2.00+ build did you try to install?

neilk

neilk

2012-10-05 12:37

reporter   ~21060

It was build 121002.

c_schmitz

c_schmitz

2012-10-05 12:42

administrator   ~21061

Ok, the problem is that this table does not exist in your database where it should. If you install a clean 1.92+ this table will be created.
I suggest you do this and copy that table to your production database. While at it check if other tables are missing.
Then try the update again and report back.

neilk

neilk

2012-10-05 16:04

reporter   ~21093

That solved the problem. LS 2.0 is successfully installed. Thanks very much.

Issue History

Date Modified Username Field Change
2012-10-04 18:09 neilk New Issue
2012-10-05 09:14 c_schmitz Note Added: 21048
2012-10-05 09:14 c_schmitz Assigned To => c_schmitz
2012-10-05 09:14 c_schmitz Status new => feedback
2012-10-05 12:37 neilk Note Added: 21060
2012-10-05 12:37 neilk Status feedback => assigned
2012-10-05 12:42 c_schmitz Note Added: 21061
2012-10-05 12:42 c_schmitz Status assigned => feedback
2012-10-05 16:04 neilk Note Added: 21093
2012-10-05 16:04 neilk Status feedback => assigned
2012-10-05 16:05 c_schmitz Status assigned => closed
2012-10-05 16:05 c_schmitz Resolution open => unable to reproduce