View Issue Details

IDProjectCategoryView StatusLast Update
06623Bug reports[All Projects] Import/Exportpublic2012-10-05 15:26
ReporterTMSWhiteAssigned ToTMSWhite 
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version 
Summary06623: imported tab delimited surveys are not visible
DescriptionLS 2.0 says that the file loads correctly, but when you try to go to the survey (or list it), it is not found.

When you run the Check Data Integrity function, you see that there are questions, attributes, groups, and language settings that can be deleted because there is no matching surveyid - where the missing surveyid is the one listed in the URL immediately after importing the survey.

So, it appears that everything loads correctly, but the new survey id is not written to the database.
Steps To ReproduceImport attached survey
TagsNo tags attached.
Complete LimeSurvey version number (& build)120931
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMysql 5.3
Operating System (Server)Windows XP
Webserver software & versionXAMPP
PHP Version5.3

Activities

TMSWhite

TMSWhite

2012-10-01 19:09

reporter  

Survey_debug_test2 (1).txt (27,232 bytes)
��class	type/scale	name	relevance	text	help	language	validation	mandatory	other	default	same_default	allowed_filetypes	alphasort	answer_width	array_filter	array_filter_exclude	assessment_value	category_separator	display_columns	display_rows	dropdown_dates_year_min	dropdown_dates	dropdown_dates_year_max	dropdown_prefix	dropdown_prepostfix	dropdown_separators	dropdown_size	dualscale_headerA	dualscale_headerB	em_validation_q_tip	em_validation_q	em_validation_sq	em_validation_sq_tip	equals_num_value	exclude_all_others	exclude_all_others_auto	hidden	hide_tip	input_boxes	location_city	location_country	location_defaultcoordinates	location_mapheight	location_mapservice	location_mapwidth	location_mapzoom	location_nodefaultfromip	location_postal	location_state	max_answers	max_filesize	max_num_of_files	max_num_value	max_num_value_n	maximum_chars	min_answers	min_num_of_files	min_num_value	min_num_value_n	multiflexible_checkbox	multiflexible_max	multiflexible_min	multiflexible_step	num_value_int_only	numbers_only	other_comment_mandatory	other_numbers_only	other_replace_text	page_break	prefix	public_statistics	random_group	random_order	reverse	scale_export	show_comment	show_grand_total	show_title	show_totals	slider_accuracy	slider_default	slider_layout	slider_max	slider_middlestart	slider_min	slider_rating	slider_separator	slider_showminmax	suffix	text_input_width	time_limit_action	time_limit_countdown_message	time_limit_disable_next	time_limit_disable_prev	time_limit_message	time_limit_message_delay	time_limit_message_style	time_limit_timer_style	time_limit_warning_2_display_time	time_limit_warning_2_message	time_limit_warning_2_style	time_limit_warning_2	time_limit_warning	time_limit	time_limit_warning_display_time	time_limit_warning_message	time_limit_warning_style	use_dropdown

S		sid		868933																																																																																																								

S		owner_id		1																																																																																																								

S		admin		Oliver Bown																																																																																																								

S		active		N																																																																																																								

S		adminemail		ollie@icarus.nu																																																																																																								

S		anonymized		N																																																																																																								

S		format		G																																																																																																								

S		savetimings		N																																																																																																								

S		template		default																																																																																																								

S		language		en																																																																																																								

S		datestamp		N																																																																																																								

S		usecookie		N																																																																																																								

S		allowregister		N																																																																																																								

S		allowsave		Y																																																																																																								

S		autonumber_start		0																																																																																																								

S		autoredirect		N																																																																																																								

S		allowprev		N																																																																																																								

S		printanswers		N																																																																																																								

S		ipaddr		N																																																																																																								

S		refurl		N																																																																																																								

S		datecreated		25/09/2012																																																																																																								

S		publicstatistics		N																																																																																																								

S		publicgraphs		N																																																																																																								

S		listpublic		N																																																																																																								

S		htmlemail		Y																																																																																																								

S		sendconfirmation		Y																																																																																																								

S		tokenanswerspersistence		N																																																																																																								

S		assessments		N																																																																																																								

S		usecaptcha		D																																																																																																								

S		usetokens		N																																																																																																								

S		bounce_email		ollie@icarus.nu																																																																																																								

S		attributedescriptions		a:0:{}																																																																																																								

S		tokenlength		15																																																																																																								

S		showxquestions		Y																																																																																																								

S		showgroupinfo		B																																																																																																								

S		shownoanswer		Y																																																																																																								

S		showqnumcode		X																																																																																																								

S		bounceprocessing		N																																																																																																								

S		showwelcome		Y																																																																																																								

S		showprogress		Y																																																																																																								

S		allowjumps		N																																																																																																								

S		navigationdelay		0																																																																																																								

S		nokeyboard		N																																																																																																								

S		alloweditaftercompletion		N																																																																																																								

SL		surveyls_title		A Survey		en																																																																																																						

SL		surveyls_description		Description		en																																																																																																						

SL		surveyls_welcometext		Welcome		en																																																																																																						

SL		surveyls_email_invite_subj		Invitation to participate in a survey		en																																																																																																						

SL		surveyls_email_invite		"Dear {FIRSTNAME},  you have been invited to participate in a survey.  The survey is titled: ""{SURVEYNAME}""  ""{SURVEYDESCRIPTION}""  To participate, please click on the link below.  Sincerely,  {ADMINNAME} ({ADMINEMAIL})  ---------------------------------------------- Click here to do the survey: {SURVEYURL}  If you do not want to participate in this survey and don't want to receive any more invitations please click the following link: {OPTOUTURL}  If you are blacklisted but want to participate in this survey and want to receive invitations please click the following link: {OPTINURL}"		en																																																																																																						

SL		surveyls_email_remind_subj		Reminder to participate in a survey		en																																																																																																						

SL		surveyls_email_remind		"Dear {FIRSTNAME},  Recently we invited you to participate in a survey.  We note that you have not yet completed the survey, and wish to remind you that the survey is still available should you wish to take part.  The survey is titled: ""{SURVEYNAME}""  ""{SURVEYDESCRIPTION}""  To participate, please click on the link below.  Sincerely,  {ADMINNAME} ({ADMINEMAIL})  ---------------------------------------------- Click here to do the survey: {SURVEYURL}  If you do not want to participate in this survey and don't want to receive any more invitations please click the following link: {OPTOUTURL}"		en																																																																																																						

SL		surveyls_email_register_subj		Survey registration confirmation		en																																																																																																						

SL		surveyls_email_register		"Dear {FIRSTNAME},  You, or someone using your email address, have registered to participate in an online survey titled {SURVEYNAME}.  To complete this survey, click on the following URL:  {SURVEYURL}  If you have any questions about this survey, or if you did not register to participate and believe this email is in error, please contact {ADMINNAME} at {ADMINEMAIL}."		en																																																																																																						

SL		surveyls_email_confirm_subj		Confirmation of your participation in our survey		en																																																																																																						

SL		surveyls_email_confirm		"Dear {FIRSTNAME},  this email is to confirm that you have completed the survey titled {SURVEYNAME} and your response has been saved. Thank you for participating.  If you have any further questions about this email, please contact {ADMINNAME} on {ADMINEMAIL}.  Sincerely,  {ADMINNAME}"		en																																																																																																						

SL		surveyls_dateformat		1		en																																																																																																						

SL		surveyls_attributecaptions		a:0:{}		en																																																																																																						

SL		email_admin_notification_subj		Response submission for survey {SURVEYNAME}		en																																																																																																						

SL		email_admin_notification		"Hello,  A new response was submitted for your survey '{SURVEYNAME}'.  Click the following link to reload the survey: {RELOADURL}  Click the following link to see the individual response: {VIEWRESPONSEURL}  Click the following link to edit the individual response: {EDITRESPONSEURL}  View statistics by clicking here: {STATISTICSURL}"		en																																																																																																						

SL		email_admin_responses_subj		Response submission for survey {SURVEYNAME} with results		en																																																																																																						

SL		email_admin_responses		"Hello,  A new response was submitted for your survey '{SURVEYNAME}'.  Click the following link to reload the survey: {RELOADURL}  Click the following link to see the individual response: {VIEWRESPONSEURL}  Click the following link to edit the individual response: {EDITRESPONSEURL}  View statistics by clicking here: {STATISTICSURL}   The following answers were given by the participant: {ANSWERTABLE}"		en																																																																																																						

SL		surveyls_numberformat		0		en																																																																																																						

G		MY QUESTION GROUP	1			en																																																																																																						

Q	5	q1	1	q1		en			N		1																																																																																																	

Q	5	q2	1	q2		en			N		1																																																																																																	

Q	5	q3	1	q3		en			N		1																																																																																																	

Q	5	q4	1	q4		en			N		1																																																																																																	

Q	5	q5	1	q5		en			N		1																																																																																																	

Q	5	q6	1	q6		en			N		1																																																																																																	

Q	T	q7	1	Additional comments.		en			N		1																																																																																1																	
c_schmitz

c_schmitz

2012-10-02 09:30

administrator   ~20968

There are several issues showing here:

*The Datecreated field in the TSV contains an invalid date format
*Datecreated should not be imported at all but ignored
*The import routine does little to no error reporting if the import fails.
TMSWhite

TMSWhite

2012-10-03 00:46

reporter   ~20997

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9622
TMSWhite

TMSWhite

2012-10-03 00:48

reporter   ~20998

The patch fixes the most pressing problem. Better validation is desirable, and although it could be implemented now, it may make sense to wait for 2.1 since the Question Objects code contains all of the needed validation tables/arrays.
c_schmitz

c_schmitz

2012-10-05 15:26

administrator   ~21086

New version 2.00+ build 121005 released.

Related Changesets

LimeSurvey: master 49da6fb4

2012-10-02 15:45:40

TMSWhite

Details Diff
Fixed issue 06623: imported tab delimited surveys are not visible
mod - application/helpers/admin/import_helper.php Diff File

Issue History

Date Modified Username Field Change
2012-10-01 19:09 TMSWhite New Issue
2012-10-01 19:09 TMSWhite File Added: Survey_debug_test2 (1).txt
2012-10-02 09:28 c_schmitz Assigned To => c_schmitz
2012-10-02 09:28 c_schmitz Status new => assigned
2012-10-02 09:30 c_schmitz Note Added: 20968
2012-10-03 00:46 TMSWhite Changeset attached => LimeSurvey master 49da6fb4
2012-10-03 00:46 TMSWhite Note Added: 20997
2012-10-03 00:46 TMSWhite Assigned To c_schmitz => TMSWhite
2012-10-03 00:46 TMSWhite Resolution open => fixed
2012-10-03 00:48 TMSWhite Note Added: 20998
2012-10-03 00:48 TMSWhite Status assigned => resolved
2012-10-05 15:26 c_schmitz Note Added: 21086
2012-10-05 15:26 c_schmitz Status resolved => closed