View Issue Details

IDProjectCategoryView StatusLast Update
06426Bug reports[All Projects] Import/Exportpublic2012-10-07 13:34
Reporterabita1 Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionunable to reproduce 
Product Version1.92+ 
Target VersionFixed in Version 
Summary06426: following Excel import - "Invalid group number for this survey:" error , cured by QA
Description

Following an excel import of a survey, I go to the survey, and then to the last group [I happened to be testing, there].

I execute a preview of the Group, and after some thinking, receive the error: "Invalid group number for this survey: 318"

If, instead, I first do a QA, or an edit, FIRST, the error does not appear.

If, following the error, I do a QA or an edit, the error disappears, thereafter, with a subsequent preview of that group.

I suspect that a variant of this error is known already to Tom W etal...though I thought this but report might narrow down it ultimate correction path.

Additional Information

I am using Tom Whites 192 w/ the excel import code - his master of 7-26, coded 0720

I notice that, at line +- 1944, [sorry, it's not exact, as I've made some changes, already, to the code] there is a commented out insertdata of the "qid",

[code]
// $insertdata['qid'] = $sqid; // this was causing key duplications - removing it seems to have fixed that
[/code]

which is where my instinct says the error comes from. I assume that executing QA or other code resets an index or something, curing the bug/error, which appears to be otherwise non-fatal.


I also noticed this quirk, not related, discovered on trying to track down the error source: that there are two full sweeps of the excel file, on import, first to search for S/SLs, and then to search for the balance of class codes -- A quick start to that import coding, I suspect..

I am working on an amendment that modifies that, and creates an import/export schema. The coding for it would allow for backwards compatibility, and forward looking to additional improvements: I plan to add a "XX" class as the first line that would have a second column 'blank', if original schema, or a number for the following on schema. This will allow for additional improvements without crashing earlier saves. I'll share it here, as another bug/improvement, when done, so I can ask someone to review and pull if it meets guidelines.


Unrelated: Can someone clue me in on which files have the code/codeChain is that pulls in the fieldmapping when a subquestion is rendered on survey execution? Thanks !

TagsNo tags attached.
Complete LimeSurvey version number (& build)120721
I will donate to the project if issue is resolvedNo
BrowserFireFox 14
Database & DB-VersionMySQL
Server OS (if known)Win
Webserver software & version (if known)XAMPP
PHP Version5.4?

Relationships

related to 06502 closedmfaber Development  Unable to import exported multi lang survey 

Activities

TMSWhite

TMSWhite

2012-08-05 04:32

reporter   ~20192

abita-

If you do make changes, please also fix the Yii branch, and submit pull requests to the Yii branch. The Excel import/export feature is not going to be added to the 1.92 branch.

abita1

abita1

2012-08-05 05:16

reporter   ~20193

Will do, Tom -- I had already recalled your letting me know about your side improvement, and I was assuming that the excel import/export coding, at 200 and 192 are aligned. I'm smiling, too, since I hoped the bug report might rattle some thoughts on why the indexing error occurs...

Regards,

John


Any hints on the field map trail, Tom? Learning the code is slow, as commenting is...restrained.... I'm still using spare time to leap frog through the directories, hunting down and orienting myself to the code path.

TMSWhite

TMSWhite

2012-08-18 13:37

reporter   ~20510

Is this still a problem in 2.0?

c_schmitz

c_schmitz

2012-10-02 15:00

administrator   ~20982

Feedback please?

c_schmitz

c_schmitz

2012-10-07 13:34

administrator   ~21106

Closed due to missing feedback.

Issue History

Date Modified Username Field Change
2012-08-05 01:34 abita1 New Issue
2012-08-05 04:32 TMSWhite Note Added: 20192
2012-08-05 04:32 TMSWhite Status new => feedback
2012-08-05 05:16 abita1 Note Added: 20193
2012-08-05 05:16 abita1 Status feedback => new
2012-08-05 17:52 c_schmitz Assigned To => TMSWhite
2012-08-05 17:52 c_schmitz Status new => assigned
2012-08-18 13:37 TMSWhite Note Added: 20510
2012-08-18 13:37 TMSWhite Assigned To TMSWhite =>
2012-08-18 13:37 TMSWhite Status assigned => feedback
2012-08-19 09:42 DenisChenu Relationship added related to 06502
2012-09-13 14:48 c_schmitz Relationship added has duplicate 06531
2012-09-13 14:48 c_schmitz Relationship deleted has duplicate 06531
2012-10-02 14:59 c_schmitz Assigned To => c_schmitz
2012-10-02 15:00 c_schmitz Note Added: 20982
2012-10-07 13:34 c_schmitz Note Added: 21106
2012-10-07 13:34 c_schmitz Status feedback => closed
2012-10-07 13:34 c_schmitz Resolution open => unable to reproduce