View Issue Details

IDProjectCategoryView StatusLast Update
06211Bug reportsOtherpublic2012-06-20 14:08
Reporteruser19905Assigned ToTMSWhite  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version1.92+ 
Fixed in Version1.92+ 
Summary06211: Problems with two "file upload" question types in the same question group
DescriptionSuppose you have two file upload question types in the same question group.
The two file upload question types have different settings.
For example:
- the first file upload has maximum file size allowed 2048 KB and allowed file types: png
- the second file upload has maximum file size allowed 1024 KB and allowed file types: pdf

Click on the first "Upload files" link, you can view the "upload your files" window, then close it by close button in upper right corner. Now, if you click on the second "Upload files" link, you can view the settings of the first question type (2048 KB and png file).

Expected behavior: when I click on the second Upload files link, I expected the settings of the SECOND file upload question type.
TagsNo tags attached.
Complete LimeSurvey version number (& build)120530
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySql 5.0
Server OS (if known)Linux Centos
Webserver software & version (if known)Apache 2
PHP Version5.3

Relationships

related to 06154 closedTMSWhite File upload questions not mandatory anymore 

Activities

TMSWhite

TMSWhite

2012-06-13 15:24

reporter   ~19236

Please download version 1.92+ release 120613 and re-test. The test case you describe works fine for me on that version, and we did make several other fixes to file upload between 120530 which may have fixed you issue you describe.
TMSWhite

TMSWhite

2012-06-13 15:37

reporter  

TMSWhite

TMSWhite

2012-06-13 15:38

reporter   ~19238

The attached survey shows the desired behavior

user19905

2012-06-14 10:47

  ~19249

Last edited: 2012-06-14 11:03

View 3 revisions

Hi TMSWhite,
I've downloaded the release 120613 and re-tested, but the problem is still there.
My steps using your attached survey:
- I open the window "upload your files" from the first question type
- I don't make anything: only I close the window by CLOSE ICON in upper right corner (and NOT by "Return to survey" button)
- Now, I open the window "upload your files" from the second question type

I can see the first question type settings ("You can upload png, gif, jpg, jpeg under 1024 KB each") and NOT the settings I expected ("You can upload pdf under 2048 KB each").

Thanks a lot. Bye,
Cosimo

TMSWhite

TMSWhite

2012-06-14 13:39

reporter   ~19252

So, it works properly when you click the "Return to survey" button, but not if you click the "X" to close the pop-up window. LS needs to call checkconditions() after "Return to survey" is pressed. I'm not sure if there is an easy way to do the same if the window is closed via the "X".

One option is to change the CSS for the pop-up window to hide the "X". Another is to fix the behavior. Both are beyond my capabilities at the moment, so hopefully someone else will address this issue.
TMSWhite

TMSWhite

2012-06-19 03:48

reporter   ~19331

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8772
TMSWhite

TMSWhite

2012-06-19 03:49

reporter   ~19332

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8773
c_schmitz

c_schmitz

2012-06-20 14:08

administrator   ~19386

New 1.92+ version released.

Related Changesets

LimeSurvey: master 6180af85

2012-06-18 18:47:23

TMSWhite

Details Diff
Fixed issue 06211: Problems with two "file upload" question types in the same question group Affected Issues
06211
mod - scripts/modaldialog.js Diff File

LimeSurvey: Yii 9007728e

2012-06-18 18:49:06

TMSWhite

Details Diff
Fixed issue 06211: Problems with two "file upload" question types in the same question group Affected Issues
06211
mod - scripts/modaldialog.js Diff File

Issue History

Date Modified Username Field Change
2012-06-13 14:07 user19905 New Issue
2012-06-13 15:24 TMSWhite Note Added: 19236
2012-06-13 15:24 TMSWhite Status new => feedback
2012-06-13 15:37 TMSWhite File Added: limesurvey_survey_16115 (2).lss
2012-06-13 15:38 TMSWhite Note Added: 19238
2012-06-14 10:47 user19905 Note Added: 19249
2012-06-14 10:47 user19905 Status feedback => new
2012-06-14 11:03 user19905 Note Edited: 19249 View Revisions
2012-06-14 11:03 user19905 Note Edited: 19249 View Revisions
2012-06-14 13:39 TMSWhite Note Added: 19252
2012-06-18 17:49 TMSWhite Relationship added related to 06154
2012-06-18 18:00 TMSWhite Changeset attached => LimeSurvey Yii 80f6915d
2012-06-18 18:00 TMSWhite Assigned To => TMSWhite
2012-06-18 18:00 TMSWhite Resolution open => fixed
2012-06-18 18:00 TMSWhite Changeset attached => LimeSurvey master 9e80a506
2012-06-18 18:00 TMSWhite Status new => resolved
2012-06-18 18:00 TMSWhite Fixed in Version => 1.92+
2012-06-18 18:02 TMSWhite Assigned To TMSWhite =>
2012-06-18 18:02 TMSWhite Status resolved => new
2012-06-18 18:03 TMSWhite Changeset removed LimeSurvey Yii 80f6915d =>
2012-06-18 18:04 TMSWhite Changeset removed LimeSurvey master 9e80a506 =>
2012-06-19 03:48 TMSWhite Changeset attached => LimeSurvey master 6180af85
2012-06-19 03:48 TMSWhite Note Added: 19331
2012-06-19 03:49 TMSWhite Changeset attached => LimeSurvey Yii 9007728e
2012-06-19 03:49 TMSWhite Note Added: 19332
2012-06-19 03:49 TMSWhite Status new => resolved
2012-06-19 03:49 TMSWhite Assigned To => TMSWhite
2012-06-20 14:08 c_schmitz Note Added: 19386
2012-06-20 14:08 c_schmitz Status resolved => closed