View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
19254Bug reportsSurvey editingpublic2023-12-06 08:47
Reportertibor.pacalat Assigned Tomfavetti  
PrioritynoneSeveritycrash 
Status ready for testingResolutionreopened 
Product Version6.4.0-dev 
Fixed in Version6.4.0-dev 
Summary19254: With debug=2 going to Email Templates from Survey gives me 500 error
Description

<h1>PHP Error [500]</h1>
<p>unserialize(): Passing null to parameter #1 ($data) of type string is deprecated (/var/www/ls-ce-6x/public/application/controllers/admin/EmailTemplates.php:69)</p>
<pre>#0 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/base/CErrorHandler.php(133): CErrorHandler->handleError()
#1 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/base/CApplication.php(832): CErrorHandler->handle()
#2 unknown(0): LSYii_Application->handleError()
#3 /var/www/ls-ce-6x/public/application/controllers/admin/EmailTemplates.php(69): unserialize()
#4 unknown(0): EmailTemplates->index()
#5 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/actions/CAction.php(115): ReflectionMethod->invokeArgs()
#6 /var/www/ls-ce-6x/public/application/core/SurveyCommonAction.php(83): EmailTemplates->runWithParamsInternal()
#7 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/CController.php(308): EmailTemplates->runWithParams()
#8 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/CController.php(286): AdminController->runAction()
#9 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/CController.php(265): AdminController->runActionWithFilters()
#10 /var/www/ls-ce-6x/public/application/controllers/AdminController.php(202): AdminController->run()
#11 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/CWebApplication.php(282): AdminController->run()
#12 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/web/CWebApplication.php(141): LSYii_Application->runController()
#13 /var/www/ls-ce-6x/public/vendor/yiisoft/yii/framework/base/CApplication.php(185): LSYii_Application->processRequest()
#14 /var/www/ls-ce-6x/public/index.php(161): LSYii_Application->run()
</pre>

Steps To Reproduce

Steps to reproduce

  1. Go to Survey side menu -> Email templates with debug=2 in config.php
  2. results in 500 and error above

Expected result

(Write here what you expected to happen)

Actual result

(Write here what happened instead)

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)6.4.0-dev
I will donate to the project if issue is resolvedNo
Browser
Database type & version.
Server OS (if known)
Webserver software & version (if known)
PHP Version8.1.4

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

twilllig

twilllig

2023-11-20 16:03

developer   ~78543

I did fix a separate bug which also caused a crash in the same place. The particular error which Tibor reported here, is related to PHP8.1

DenisChenu

DenisChenu

2023-11-20 16:54

developer   ~78551

The particular error which Tibor reported here, is related to PHP8.1

We have a lot of micro issue with PHP8.1 and debug > 1 …

And we don't start to move to 8.2 :crying:

mfavetti

mfavetti

2023-11-21 09:48

developer   ~78558

Last edited: 2023-11-21 09:49

added

pr affects master and develop branches... should I make pr for develop also? or does it get pulled in from master?

DenisChenu

DenisChenu

2023-11-21 15:23

developer   ~78594

master was merged to develop after.

Only master since 5.X must only be 8.0 compatible

tibor.pacalat

tibor.pacalat

2023-11-21 19:43

administrator   ~78613

Last edited: 2023-11-21 19:44

@mfavetti bug fixes always go to master. Master gets merged into develop after release if no one does this sooner. So, your master PR is enough. Thank you :)

tibor.pacalat

tibor.pacalat

2023-11-23 16:40

administrator   ~78690

@mfavetti there are some comments on your PR, can you please take a look at those https://github.com/LimeSurvey/LimeSurvey/pull/3630 ?

mfavetti

mfavetti

2023-12-06 07:43

developer   ~78883

@tibor.pacalat followed up on the code review finally, sorry it took so long!

DenisChenu

DenisChenu

2023-12-06 08:47

developer   ~78885

@tibor.pacalat ready to test :)

Issue History

Date Modified Username Field Change
2023-11-20 14:48 tibor.pacalat New Issue
2023-11-20 15:12 twilllig Assigned To => twilllig
2023-11-20 15:12 twilllig Status new => assigned
2023-11-20 15:19 twilllig Status assigned => resolved
2023-11-20 15:19 twilllig Resolution open => fixed
2023-11-20 15:19 twilllig Fixed in Version => 6.4.0-dev
2023-11-20 15:55 tibor.pacalat Status resolved => new
2023-11-20 15:55 tibor.pacalat Resolution fixed => reopened
2023-11-20 16:02 tibor.pacalat Assigned To twilllig =>
2023-11-20 16:03 twilllig Note Added: 78543
2023-11-20 16:03 twilllig Bug heat 0 => 2
2023-11-20 16:54 DenisChenu Note Added: 78551
2023-11-20 16:54 DenisChenu Bug heat 2 => 4
2023-11-21 09:44 mfavetti Assigned To => mfavetti
2023-11-21 09:44 mfavetti Status new => assigned
2023-11-21 09:48 mfavetti Note Added: 78558
2023-11-21 09:48 mfavetti Bug heat 4 => 6
2023-11-21 09:48 mfavetti Assigned To mfavetti => DenisChenu
2023-11-21 09:48 mfavetti Status assigned => ready for code review
2023-11-21 09:49 mfavetti Note Edited: 78558
2023-11-21 09:49 mfavetti Note Edited: 78558
2023-11-21 15:23 DenisChenu Assigned To DenisChenu => mfavetti
2023-11-21 15:23 DenisChenu Status ready for code review => in code review
2023-11-21 15:23 DenisChenu Note Added: 78594
2023-11-21 19:43 tibor.pacalat Note Added: 78613
2023-11-21 19:43 tibor.pacalat Bug heat 6 => 8
2023-11-21 19:44 tibor.pacalat Note Edited: 78613
2023-11-23 16:40 tibor.pacalat Note Added: 78690
2023-12-06 07:43 mfavetti Note Added: 78883
2023-12-06 08:47 DenisChenu Status in code review => ready for testing
2023-12-06 08:47 DenisChenu Note Added: 78885