View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
19010Bug reportsTranslationpublic2023-10-23 20:38
Reporternonformality Assigned Togabrieljenik  
PrioritynoneSeveritypartial_block 
Status closedResolutionno change required 
Product Version6.2.0-dev 
Summary19010: Quick translation tool does not save subquestions
Description

While adding late translations to a non-active survey, I realised that the quick translation tool does not save changes to subquestions. It worked fine for question groups, and I haven't tried any of the other sections (welcome and and end texts, questions, and so on). The translations are picked up just fine when going through structure » question group » question, so I have a (more tedious) work around for now.

First screenshot, having entered the French translations of subquestions, just before saving; second screenshot, after saving, with subquestions back to a potpourri of different languages.

Steps To Reproduce

Steps to reproduce

Use quick translation tool to translate subquestions

Expected result

When saving, the translated subquestions are saved

Actual result

When saving, the translated subquestions are not saved, and instead a cacophony of existing subquestions from other languages are shown

Tagsquick translation tool, translation
Bug heat8
Complete LimeSurvey version number (& build)6.2.0+230732
I will donate to the project if issue is resolvedNo
Browser
Database type & version10.5.19-MariaDB-0+deb11u2 with mysqlnd 8.1.21
Server OS (if known)Debian 11
Webserver software & version (if known)Apache/2.4.56 (Debian)
PHP Version8.1.21

Relationships

related to 19150 acknowledged Avoid going over the max_input_vars limits without noticing. 

Users monitoring this issue

User List nonformality

Activities

nonformality

nonformality

2023-08-04 11:16

reporter  

nonformality

nonformality

2023-08-04 12:49

reporter   ~76425

Update: saving works for Questions, so the problem seems to be specific to subquestions

gabrieljenik

gabrieljenik

2023-08-09 20:51

manager   ~76528

Coudn't reprodice it so far. Can you please attach an LSS?

gabrieljenik

gabrieljenik

2023-08-09 20:53

manager   ~76529

First screenshot, having entered the French translations of subquestions, just before saving; second screenshot, after saving, with subquestions back to a potpourri of different languages.

The problem is

  • when saving through quick translation? Saves wrong language?
    Or
  • when loading on the quick translation? loads from wrong languages?
nonformality

nonformality

2023-08-11 11:51

reporter   ~76539

Hiya @gabrieljenik – the first, but not a wrong language: nothing get's saved when saving subquestions through the quick translation tool.

gabrieljenik

gabrieljenik

2023-08-11 21:20

manager   ~76544

Please, do you have a sample survey (LSS) so we can reproduce with the exact question type?

gabrieljenik

gabrieljenik

2023-08-14 16:47

manager   ~76577

Please, can you detail the exact steps and buttons pressed? maybe a recording?
These are very basic questions, but just to double check:

  • Are you pressing save after entering the translations?
  • Maybe you are switching to another language before pressing save?

Thanks!

nonformality

nonformality

2023-09-08 14:01

reporter   ~76919

Did a recording [https://bugs.limesurvey.org/view_user_page.php?id=25282]@gabrieljenik – parked it here: https://cecilia.youthpolicylabs.org/s/pFmH3zm7A237X55

Let me know if you still need a LSS file to reproduce.

gabrieljenik

gabrieljenik

2023-09-08 14:47

manager   ~76921

Let me know if you still need a LSS file to reproduce.

Thanks, yes, please send the LSS

Also, does it happen with a fresh new survey or only to that one?

nonformality

nonformality

2023-09-16 15:53

reporter   ~77082

Happens with any survey unfortunately. Attached a sample LSS.

limesurvey_survey_638248.lss (5,853,431 bytes)
gabrieljenik

gabrieljenik

2023-09-18 22:36

manager   ~77147

Does it happen with smaller surveys?

nonformality

nonformality

2023-09-26 18:43

reporter   ~77349

Apologies, only getting to this now @gabrieljenik. Nope, does in fact not happen with smaller surveys.

gabrieljenik

gabrieljenik

2023-09-27 14:09

manager   ~77368

Please then review the php.ini settings
post_max_size
max_input_vars

@DenisChenu maybe we could do something like a PHP checker on the POST that checks the max_input_vars and raises a warning/flash message?

nonformality

nonformality

2023-09-27 14:47

reporter   ~77376

You would think that this should do:

max_file_uploads 200
max_input_nesting_level 1280
max_input_time 600
max_input_vars 20000
memory_limit 94208M
output_buffering 8196
post_max_size 10240M

But I'll try :)

DenisChenu

DenisChenu

2023-09-27 15:14

developer   ~77379

@DenisChenu maybe we could do something like a PHP checker on the POST that checks the max_input_vars and raises a warning/flash message?

We have some for Questions for example. But Quick translations must be really rewritten in my opinion.

gabrieljenik

gabrieljenik

2023-09-28 16:48

manager   ~77410

We have some for Questions for example

A checker? I was thinking like a general purpose checker.

DenisChenu

DenisChenu

2023-09-28 16:55

developer   ~77411

Currently : there are a hidden input append at end manually.

You can not really create easily an automatic system since we don't use CHtml::endForm(); : https://www.yiiframework.com/doc/api/1.1/CHtml#endForm-detail

gabrieljenik

gabrieljenik

2023-09-28 18:02

manager   ~77422

Currently : there are a hidden input append at end manually.

We could have a precheck routine on PHP that count's the input fields, and compare to the settings.
If close to the limit, it would raise a wanring / mail.

Also, we could have something on JS that counts fields per form.
If close to the limit, it would raise a wanring.

DenisChenu

DenisChenu

2023-09-28 18:20

developer   ~77428

We could have a precheck routine on PHP that count's the input fields, and compare to the settings.

Oh ! :+1:

Same for JS : send a warning before send : can be great !

gabrieljenik

gabrieljenik

2023-10-05 00:01

manager   ~77512

Hello nonformality,
Do you have any new info / feedback?
Can you please check if this issue still exists and let us know?
Thank you!

gabrieljenik

gabrieljenik

2023-10-23 20:38

manager   ~77893

As per the comments, will be closing the ticket.
Please add any comments in case it should be reopened.
Thanks

Issue History

Date Modified Username Field Change
2023-08-04 11:16 nonformality New Issue
2023-08-04 11:16 nonformality File Added: Screenshot 2023-08-04 at 11.03.15.png
2023-08-04 11:16 nonformality File Added: Screenshot 2023-08-04 at 11.03.42.png
2023-08-04 11:42 nonformality Tag Attached: translation
2023-08-04 11:42 nonformality Tag Attached: quick translation tool
2023-08-04 12:49 nonformality Note Added: 76425
2023-08-04 12:49 nonformality Bug heat 0 => 2
2023-08-07 23:17 gabrieljenik Assigned To => gabrieljenik
2023-08-07 23:17 gabrieljenik Status new => acknowledged
2023-08-09 20:51 gabrieljenik Note Added: 76528
2023-08-09 20:51 gabrieljenik Bug heat 2 => 4
2023-08-09 20:53 gabrieljenik Note Added: 76529
2023-08-09 20:53 gabrieljenik Status acknowledged => feedback
2023-08-11 11:51 nonformality Note Added: 76539
2023-08-11 11:51 nonformality Status feedback => assigned
2023-08-11 21:20 gabrieljenik Note Added: 76544
2023-08-14 16:47 gabrieljenik Note Added: 76577
2023-08-14 16:47 gabrieljenik Status assigned => feedback
2023-09-08 14:01 nonformality Note Added: 76919
2023-09-08 14:01 nonformality Status feedback => assigned
2023-09-08 14:01 nonformality Issue Monitored: nonformality
2023-09-08 14:01 nonformality Bug heat 4 => 6
2023-09-08 14:47 gabrieljenik Note Added: 76921
2023-09-08 14:48 gabrieljenik Status assigned => feedback
2023-09-16 15:53 nonformality Note Added: 77082
2023-09-16 15:53 nonformality File Added: limesurvey_survey_638248.lss
2023-09-16 15:53 nonformality Status feedback => assigned
2023-09-18 22:36 gabrieljenik Note Added: 77147
2023-09-26 18:43 nonformality Note Added: 77349
2023-09-27 14:09 gabrieljenik Assigned To gabrieljenik =>
2023-09-27 14:09 gabrieljenik Status assigned => feedback
2023-09-27 14:09 gabrieljenik Note Added: 77368
2023-09-27 14:47 nonformality Note Added: 77376
2023-09-27 14:47 nonformality Status feedback => new
2023-09-27 15:14 DenisChenu Note Added: 77379
2023-09-27 15:14 DenisChenu Bug heat 6 => 8
2023-09-28 16:48 gabrieljenik Note Added: 77410
2023-09-28 16:55 DenisChenu Note Added: 77411
2023-09-28 18:02 gabrieljenik Note Added: 77422
2023-09-28 18:20 DenisChenu Note Added: 77428
2023-10-05 00:00 gabrieljenik Issue cloned: 19150
2023-10-05 00:00 gabrieljenik Relationship added related to 19150
2023-10-05 00:01 gabrieljenik Assigned To => gabrieljenik
2023-10-05 00:01 gabrieljenik Status new => feedback
2023-10-05 00:01 gabrieljenik Note Added: 77512
2023-10-23 20:38 gabrieljenik Status feedback => closed
2023-10-23 20:38 gabrieljenik Resolution open => no change required
2023-10-23 20:38 gabrieljenik Note Added: 77893