View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
18517Bug reportsSurvey editingpublic2023-01-16 14:34
Reportergabrieljenik Assigned Togabrieljenik  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version5.4.x 
Summary18517: Survey creation date is wrong
Description

If you copy a survey and then create others, you will see that the copy is higher up in the list. It's because the default for datecreated (in Survey::rules()) is wrong (says m instead of i).

Steps To Reproduce

Caught while reviewing 18449

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)Version 5.4.9+221101
I will donate to the project if issue is resolvedNo
BrowserVivaldi and Edge
Database type & versionMySQL
Server OS (if known)OVH Shared hosting
Webserver software & version (if known)
PHP Version8.1

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

gabrieljenik

gabrieljenik

2022-12-30 15:49

manager   ~73318

https://github.com/LimeSurvey/LimeSurvey/pull/2821

gabrieljenik

gabrieljenik

2022-12-30 15:50

manager   ~73319

The root cause of the problem and the confusion is not when you copy but when you create.
There is when the rule was getting applied.

gabrieljenik

gabrieljenik

2023-01-11 10:46

manager   ~73431

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=34214

LimeBot

LimeBot

2023-01-16 14:34

administrator   ~73473

Fixed in Release 5.6.0+230116

Related Changesets

LimeSurvey: master f88ecbd9

2023-01-11 10:46:41

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18517: Survey editing : Survey creation date is wrong (#2821)

Co-authored-by: lapiudevgit <devgit@lapiu.biz>
Affected Issues
18517
mod - application/models/Survey.php Diff File

Issue History

Date Modified Username Field Change
2022-11-28 15:16 gabrieljenik New Issue
2022-11-28 15:16 gabrieljenik Issue generated from: 18516
2022-11-28 15:17 gabrieljenik Status new => confirmed
2022-11-28 15:18 gabrieljenik Issue cloned: 18518
2022-12-19 17:07 gabrieljenik Assigned To => gabrieljenik
2022-12-19 17:07 gabrieljenik Status confirmed => assigned
2022-12-30 15:49 gabrieljenik Status assigned => ready for code review
2022-12-30 15:49 gabrieljenik Note Added: 73318
2022-12-30 15:49 gabrieljenik Bug heat 0 => 2
2022-12-30 15:50 gabrieljenik Note Added: 73319
2022-12-30 15:52 gabrieljenik Assigned To gabrieljenik => DenisChenu
2023-01-02 08:44 DenisChenu Assigned To DenisChenu =>
2023-01-02 08:44 DenisChenu Status ready for code review => ready for testing
2023-01-05 16:06 gabrieljenik Assigned To => ollehar
2023-01-05 16:06 gabrieljenik Status ready for testing => ready for merge
2023-01-11 10:46 gabrieljenik Changeset attached => LimeSurvey master f88ecbd9
2023-01-11 10:46 gabrieljenik Note Added: 73431
2023-01-11 10:46 gabrieljenik Assigned To ollehar => gabrieljenik
2023-01-11 10:46 gabrieljenik Resolution open => fixed
2023-01-16 14:34 LimeBot Note Added: 73473
2023-01-16 14:34 LimeBot Status ready for merge => closed
2023-01-16 14:34 LimeBot Bug heat 2 => 4