View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
18487Bug reportsSurvey takingpublic2022-11-17 15:58
Reportertassoman Assigned To 
PrioritynoneSeverityminor 
Status newResolutionopen 
Product Version3.28.x 
Summary18487: apikey needed for cyclemap and traffic map
Description

While having a «short text» longitude/latitude geo localization map question, inside Leaflet widget, there are layers who need an APIKEY.
Inside Administration area, General tab, there isn't any field where to put this keys.

PROPOSAL:
Remove cyclemap and traffic map layers from Leaflet widget. Or, make layers customizable by admin interface.

Steps To Reproduce

Steps to reproduce

  • Install LS
  • Create a survey
  • Create a short text question
  • add mapping attribute latitude/longitude
  • preview question
  • click "layers" icon on upper-right corner of the map
  • click radio button: "cyclemap" or "traffic map"
  • see: "Api Key Required" in the map

Expected result

(Write here what you expected to happen)

Actual result

(Write here what happened instead)

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)Version 3.28.29+220920
I will donate to the project if issue is resolvedNo
Browserany
Database type & versionMysql
Server OS (if known)
Webserver software & version (if known)
PHP VersionPHP-7.4.x

Users monitoring this issue

User List DenisChenu, tassoman

Issue History

Date Modified Username Field Change
2022-11-15 11:38 tassoman New Issue
2022-11-15 11:38 tassoman File Added: Screenshot 2022-11-15 at 11-38-28 Censimento partecipato delle sorgenti naturali dell’Emilia-Romagna.png
2022-11-15 12:26 DenisChenu Issue Monitored: DenisChenu
2022-11-15 12:26 DenisChenu Bug heat 0 => 2
2022-11-17 15:58 tassoman Issue Monitored: tassoman
2022-11-17 15:58 tassoman Bug heat 2 => 4