View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18250Bug reportsErgonomypublic2022-12-19 11:00
ReporterDenisChenu Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18250: admin css hide logic file part
Description

There are hidden part by admin css : not shown by default, need to hack css …

Steps To Reproduce

Steps to reproduce

Import https://github.com/LimeSurvey/LimeSurvey/blob/master/docs/demosurveys/ls205_EM_question_attributes.lss
Check survey logic file
Max with of you windows to 1920

Expected result

Can check error on the right of the windows : have to scroll at bottom to see the scroill left-right …
No way to see whole at each line …

scroll left-right muts be always set to windows

Actual result

(Write here what happened instead)

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.3.24
I will donate to the project if issue is resolvedNo
Browserfirefox + chrome
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2022-07-11 12:49

developer  

DenisChenu

DenisChenu

2022-07-11 12:49

developer   ~70841

.main-content-container:{overflow-y:hidden} hide the content

gabrieljenik

gabrieljenik

2022-08-01 21:23

manager   ~71283

Last edited: 2022-08-01 21:26

@DenisChenu What do you think would be a suitable solution?
We could create a div a round the table and have the div with scrollbars.
Still, hard to find the way to set height of the div as to cover the available screen according to the screen size.

Thinking of JS but wouldn't that be an overkill and too much effort?
We could apply the same approach to the "browse responses" screen and to adopt it as a generic solution

DenisChenu

DenisChenu

2022-08-02 11:56

developer   ~71293

@gabrieljenik : no adding div is bad too .

See 2.6lts issue about browse response : windows overflow must work directly. I mean : the overflow-x: hidden must be avoid always. Og div { overflow-x: show}
This disable usage of windows overflow.

See phpMyadmin too for example : the overflow is on windows, not in a div.

(PS : since answer and subquestion edit are in overflow-y forced … i really think it's really bad too ! Unsure usuability is really tested currently)

gabrieljenik

gabrieljenik

2022-08-02 15:45

manager   ~71298

Added this rules and worked better:

.main-content-container {
        overflow-x: visible;
}
.table-responsive {
    overflow-x: visible;
}

Still, sidebar is not working as expected.
Will keep on reviewing a bit more.

DenisChenu

DenisChenu

2022-08-02 16:46

developer   ~71301

Think we can not really fix without review whole admin GUI
But if it's better : go go

And remind : https://www.sondages.pro/availability/availability.html

gabrieljenik

gabrieljenik

2022-08-03 15:09

manager   ~71308

@ollehar is it ok to remove the sidebar for the logic file screen?
Eventually we can make it open on a new tab/window without any toolbar as to mimic a document.

DenisChenu

DenisChenu

2022-09-28 15:46

developer   ~72007

is it ok to remove the sidebar for the logic file screen?

For me : yes ;)

gabrieljenik

gabrieljenik

2022-10-11 23:03

manager   ~72206

https://github.com/LimeSurvey/LimeSurvey/pull/2657

gabrieljenik

gabrieljenik

2022-12-01 10:02

manager   ~72955

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=34064

gabrieljenik

gabrieljenik

2022-12-02 20:07

manager   ~72986

Reopened https://github.com/LimeSurvey/LimeSurvey/pull/2657#discussion_r1038024385

PR Master: https://github.com/LimeSurvey/LimeSurvey/pull/2761

LimeBot

LimeBot

2022-12-05 10:35

administrator   ~72995

Fixed in Release 5.4.14+221205

LimeBot

LimeBot

2022-12-19 11:00

administrator   ~73180

Fixed in Release 5.5.0+221219

Related Changesets

LimeSurvey: master a03a9586

2022-12-01 10:02:10

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18250: admin css hide logic file part (#2657)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
18250
mod - application/views/admin/expressions/test/survey_logic_file.php Diff File

Issue History

Date Modified Username Field Change
2022-07-11 12:49 DenisChenu New Issue
2022-07-11 12:49 DenisChenu File Added: Capture d’écran du 2022-07-11 12-34-29.png
2022-07-11 12:49 DenisChenu File Added: Capture d’écran du 2022-07-11 12-37-40.png
2022-07-11 12:49 DenisChenu Note Added: 70841
2022-07-11 12:49 DenisChenu Bug heat 0 => 2
2022-07-13 14:21 gabrieljenik Status new => acknowledged
2022-07-25 17:08 gabrieljenik Assigned To => gabrieljenik
2022-07-25 17:08 gabrieljenik Status acknowledged => assigned
2022-08-01 21:23 gabrieljenik Note Added: 71283
2022-08-01 21:23 gabrieljenik Bug heat 2 => 4
2022-08-01 21:26 gabrieljenik Note Edited: 71283
2022-08-02 11:56 DenisChenu Note Added: 71293
2022-08-02 11:56 DenisChenu File Added: Capture d’écran du 2022-08-02 11-52-05.png
2022-08-02 15:45 gabrieljenik Note Added: 71298
2022-08-02 16:46 DenisChenu Note Added: 71301
2022-08-03 15:09 gabrieljenik Note Added: 71308
2022-09-28 15:20 gabrieljenik Status assigned => feedback
2022-09-28 15:46 DenisChenu Note Added: 72007
2022-09-28 15:46 DenisChenu Status feedback => assigned
2022-10-11 23:03 gabrieljenik Status assigned => ready for code review
2022-10-11 23:03 gabrieljenik Note Added: 72206
2022-10-12 10:07 DenisChenu Status ready for code review => in code review
2022-11-25 17:17 gabrieljenik Assigned To gabrieljenik => ollehar
2022-11-25 17:17 gabrieljenik Status in code review => ready for merge
2022-12-01 10:02 gabrieljenik Changeset attached => LimeSurvey master a03a9586
2022-12-01 10:02 gabrieljenik Note Added: 72955
2022-12-01 10:02 gabrieljenik Assigned To ollehar => gabrieljenik
2022-12-01 10:02 gabrieljenik Resolution open => fixed
2022-12-02 16:02 DenisChenu Status ready for merge => resolved
2022-12-02 20:07 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-12-02 20:07 gabrieljenik Status resolved => ready for code review
2022-12-02 20:07 gabrieljenik Note Added: 72986
2022-12-05 08:04 DenisChenu Assigned To DenisChenu =>
2022-12-05 08:04 DenisChenu Status ready for code review => ready for testing
2022-12-05 10:35 LimeBot Note Added: 72995
2022-12-05 10:35 LimeBot Status ready for testing => closed
2022-12-05 10:35 LimeBot Bug heat 4 => 6
2022-12-05 13:33 gabrieljenik Assigned To => gabrieljenik
2022-12-05 13:33 gabrieljenik Status closed => ready for testing
2022-12-05 13:46 gabrieljenik Assigned To gabrieljenik => ollehar
2022-12-05 13:46 gabrieljenik Status ready for testing => ready for merge
2022-12-19 11:00 LimeBot Note Added: 73180
2022-12-19 11:00 LimeBot Status ready for merge => closed