View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
18093Bug reportsSurvey editingpublic2022-05-09 19:52
Reporterduvemyster Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionno change required 
Product Version5.3.x 
Summary18093: Hide tip concern on surveys upgraded over time
Description

When editing questions on surveys that have been upgraded over time, the 'Hide tip' display setting is defaulting to 'On' where it has never been intentionally set to 'On'. The issue is that when a question is edited and saved, 'Hide-tip' is then set to "On".

At present the 'Hide-tip'='On' setting also does not seem to be respected, at least not in the bootstrap theme. But once it does become respected, then questions I have edited that have tips will be caught short. It is time to review all survey logic files for hide_tip=1 and set each back to 0 before 'Hide-tip'='On' starts taking effect!

Steps To Reproduce

Steps to reproduce

  1. Start from a survey from before the "hide tip" feature was added to the admin interface (when was that?).
  2. Upgrade to Version 5.3.12+220502 (may happen in other versions as well)
  3. Edit to a question without touching the Display section and then Save. No need to make change. Just Edit then Save.
  4. Note that hide_tip=1

Expected result

Hide Tip should not be set to 'on' unless a survey admin intentionally sets it to 'on'.

Actual result

Hide Tip was set to 'on'.

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)Version 5.3.12+220502
I will donate to the project if issue is resolvedNo
BrowserAny
Database type & versionMySQL
Server OS (if known)linux - debian
Webserver software & version (if known)Apache2
PHP Version7.4.13

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

duvemyster

duvemyster

2022-05-07 18:17

reporter   ~69503

Please delete or otherwise ignore this ticket! I was completely confusing "tip" with "help". They are not exact synonyms in this case. Hide/show Tip is working correctly, and has been all along! 'Tip' is the automated messages like "Check all that apply".

There is no issue here whatsoever. Apologies for the false alarm!!!!!!

DenisChenu

DenisChenu

2022-05-09 19:52

developer   ~69530

:D

Issue History

Date Modified Username Field Change
2022-05-07 18:02 duvemyster New Issue
2022-05-07 18:17 duvemyster Note Added: 69503
2022-05-07 18:17 duvemyster Bug heat 0 => 2
2022-05-09 19:52 DenisChenu Status new => closed
2022-05-09 19:52 DenisChenu Resolution open => no change required
2022-05-09 19:52 DenisChenu Note Added: 69530
2022-05-09 19:52 DenisChenu Bug heat 2 => 4