View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18089Bug reportsImport/Exportpublic2022-05-12 18:47
Reportertassoman Assigned Togabrieljenik  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version3.28.x 
Summary18089: error 400 before import question form rendering while editing survey in structure mode
Description

You can't import questions inside LS 3.x branch installation because survey administration frontend sometimes breaks sending a 400 status code http error.

Steps To Reproduce

Steps to reproduce

0.1 create a default survey with two groups with two questions
0.2 export one question

  1. open structure view
  2. click on group #2
  3. click new question
  4. click import
  5. import works correctly
  6. question pops at the end of group
  7. drag question at previous position
  8. click group N.2
  9. click add question (again)
  10. click import question - and then broke (status 400)

There's a point between first import successiful and before click second time, where you lose "/gid/319" parameter.
if you force LS by appending that parameter "/gid/319" in the url, when you land at the import controller, gid become groupid:
admin/questions/sa/importview/groupid/319/surveyid/151891

Expected result

In my opinion gid/319 should be set always and get rid of groupid breaking things

Actual result

When you lose gid/319 parameter and try to import a question. LS throws status 400 and dies because don't knows in wich group you want to import the question

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3.28.x
I will donate to the project if issue is resolvedNo
Browserany
Database type & versionany
Server OS (if known)any
Webserver software & version (if known)apache 2.4
PHP Version7.4

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

tassoman

tassoman

2022-05-06 11:33

reporter   ~69466

probably related to 17991

DenisChenu

DenisChenu

2022-05-06 11:35

developer   ~69468

Oups … bad read :) deleted previous note

tassoman

tassoman

2022-05-06 11:40

reporter   ~69470

I claim my "contributor" badge! � https://github.com/LimeSurvey/LimeSurvey/pulls?q=is%3Apr+is%3Aclosed+author%3Atassoman
btw. thank you team! �

gabrieljenik

gabrieljenik

2022-05-10 21:17

manager   ~69557

haha ! Nice

gabrieljenik

gabrieljenik

2022-05-11 15:39

manager   ~69581

HI @Tassoman

Can I please ask you to review the steps?
I couldn't reproduce it.

Screen recordign would be too much?

Thanks!

tassoman

tassoman

2022-05-12 18:06

reporter   ~69611

I wanted to record a video but I can't reproduce inside my DEV environment, I've checkedout branch 3.x-DEV from github. (Version 3.28.10 )

LimeSurvey Community Edition Version 3.27.34+220132 still affected. this is the sequence:

  1. click structure
  2. select a question
  3. click export button
  4. click add question (inside left pane - structure)
  5. click import question (inside main right pane)

Then broke with CHTTPException 403

In my opinion solution of bug 17991 it's also a solution here.

gabrieljenik

gabrieljenik

2022-05-12 18:46

manager   ~69614

Hello tassoman,
As you have checked this with the latest version and could not reproduce, this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

gabrieljenik

Issue History

Date Modified Username Field Change
2022-05-06 11:33 tassoman New Issue
2022-05-06 11:33 tassoman Note Added: 69466
2022-05-06 11:33 tassoman Bug heat 0 => 2
2022-05-06 11:35 DenisChenu Bug heat 2 => 4
2022-05-06 11:35 DenisChenu Bug heat 4 => 2
2022-05-06 11:35 DenisChenu Note Added: 69468
2022-05-06 11:35 DenisChenu Bug heat 2 => 4
2022-05-06 11:40 tassoman Note Added: 69470
2022-05-09 17:18 gabrieljenik Assigned To => gabrieljenik
2022-05-09 17:18 gabrieljenik Status new => assigned
2022-05-10 21:17 gabrieljenik Note Added: 69557
2022-05-10 21:17 gabrieljenik Bug heat 4 => 6
2022-05-11 15:39 gabrieljenik Note Added: 69581
2022-05-11 15:39 gabrieljenik Status assigned => feedback
2022-05-12 18:06 tassoman Note Added: 69611
2022-05-12 18:06 tassoman Status feedback => assigned
2022-05-12 18:46 gabrieljenik Status assigned => testing
2022-05-12 18:46 gabrieljenik Note Added: 69614
2022-05-12 18:47 gabrieljenik Status testing => closed
2022-05-12 18:47 gabrieljenik Resolution open => fixed