View Issue Details

This bug affects 2 person(s).
 14
IDProjectCategoryView StatusLast Update
18088Bug reportsSurvey takingpublic2022-05-16 15:30
ReporterMazi Assigned Togabrieljenik  
PrioritynoneSeverityblock 
Status closedResolutionunable to reproduce 
Product Version5.3.x 
Summary18088: File upload broken between v5.3.11 and new 5.3.12
Description

File upload work fine at 5.3.11: https://demo511.offlinesurveys.com/index.php/592755?newtest=Y&lang=en

At the newer 5.3.12 version I can select and upload a file but it does not show up at the list and I can not proceed if the upload question is mandatory.
Test link: https://demo5.offlinesurveys.com/index.php/592755?newtest=Y&lang=en

Looks like some JS issue during upload.

Steps To Reproduce

Steps to reproduce

Import the attached survey at 5.3.12, run it and upload a file.

Expected result

File should show up at the list after upload.

Actual result

File does not get listed.

TagsNo tags attached.
Bug heat14
Complete LimeSurvey version number (& build)5.3.12
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionmysqlnd 7.4.29
Server OS (if known)Ubuntu
Webserver software & version (if known)Apache 2.0
PHP Version7.4.29

Users monitoring this issue

User List duvemyster

Activities

Mazi

Mazi

2022-05-06 10:09

updater  

Mazi

Mazi

2022-05-06 16:20

updater   ~69485

@DenisChenu, you menioned acin some JS issues ae he laes updae as well. Could his one e elaed?

DenisChenu

DenisChenu

2022-05-06 17:50

developer   ~69493

Sorry …

Else issue #1 Twig broken :
https://github.com/LimeSurvey/LimeSurvey/blob/8d8420a4efcf8e71c4fccbb6708648ace263ca80/application/views/survey/questions/answer/file_upload/answer.twig#L107

Fixed by

                title : {{showTitle ? '$("#' ~ fileid ~ '_title_"+i).val()' : '""' }},
                comment: {{showComment ? '$("#' ~ fileid ~ '_comment_"+i).val()' : '""'}},

But after i have another issue when "submit"

DenisChenu

DenisChenu

2022-05-07 16:56

developer   ~69501

(why expression happen here ???,i think we don't set expression to answers.twig now)

Issue in getStatInSurvey …

DenisChenu

DenisChenu

2022-05-07 17:00

developer   ~69502

Last edited: 2022-05-07 17:04

Deactivate getStatInSurvey : it work : https://master.sondages.pro/774991
getStatInSurvey must be replaced by https://github.com/LimeSurvey/LimeSurvey/tree/master/application/core/plugins/statFunctions

@Mazi : any plugins activated ?

Why your Please upload at most one file is red …

Mazi

Mazi

2022-05-09 09:31

updater   ~69506

@DenisChenu, yes, there are 2-3 of our plugins activated at the 5.3.12 system.

I think the red warning is shown because the upload question is mandatory so at least one file has to be uploaded.

DenisChenu

DenisChenu

2022-05-09 09:32

developer   ~69507

yes, there are 2-3 of our plugins activated at the 5.3.12 system.

You must check without :)

I think the red warning is shown because the upload question is mandatory so at least one file has to be uploaded.

Can not reproduce on https://master.sondages.pro/774991

Mazi

Mazi

2022-05-09 09:43

updater   ~69508

@DeniChenu, I have now deactivated our 2 plugins which exist at the 5.3.12 system but there still seems to be the same issue.

image.png (105,886 bytes)
DenisChenu

DenisChenu

2022-05-09 18:15

developer   ~69527

@gabrieljenik : you reproduce ?

gabrieljenik

gabrieljenik

2022-05-09 18:27

manager   ~69528

Have it on my list to try.
I did reproduce it on the test link

DenisChenu

DenisChenu

2022-05-09 19:22

developer   ~69529

Yep, it's broken on https://demo5.offlinesurveys.com/index.php/592755?newtest=Y&lang=en but not when import ////

gabrieljenik

gabrieljenik

2022-05-09 20:26

manager   ~69531

From the two links uploaded...

At https://demo511.offlinesurveys.com/index.php/592755?newtest=Y&lang=en I couldn't reproduce the error. (image 1).
At https://demo5.offlinesurveys.com/index.php/592755?newtest=Y&lang=en I was able to reproduce the error (image2).

Testing on my own instance, I couldn't reproduce the error. (image3) using Version 5.3.13 of LimeSurvey.

image-2.png (72,240 bytes)   
image-2.png (72,240 bytes)   
image-3.png (59,398 bytes)   
image-3.png (59,398 bytes)   
DenisChenu

DenisChenu

2022-05-10 08:17

developer   ~69533

Same result  …

Mazi

Mazi

2022-05-10 09:02

updater   ~69535

@gabrieljenik, we can meet on Skype tomorrow or Thursday so we can look into that exact system together. Just ping me.

gabrieljenik

gabrieljenik

2022-05-13 16:12

manager   ~69630

@Mazi will update the system and be back.

Mazi

Mazi

2022-05-16 14:57

updater   ~69667

@gabrieljenik: As discussed we had set up a new system and there it works fine. We can close this ticket.

Issue History

Date Modified Username Field Change
2022-05-06 10:09 Mazi New Issue
2022-05-06 10:09 Mazi File Added: survey_archive_592755-FU Test.lsa
2022-05-06 16:20 Mazi Note Added: 69485
2022-05-06 16:20 Mazi Bug heat 0 => 2
2022-05-06 17:05 DenisChenu Bug heat 2 => 4
2022-05-06 17:25 DenisChenu Assigned To => DenisChenu
2022-05-06 17:25 DenisChenu Status new => assigned
2022-05-06 17:50 DenisChenu Assigned To DenisChenu =>
2022-05-06 17:50 DenisChenu Status assigned => new
2022-05-06 17:50 DenisChenu Note Added: 69493
2022-05-07 15:58 guest Bug heat 4 => 10
2022-05-07 16:56 DenisChenu Note Added: 69501
2022-05-07 17:00 DenisChenu Note Added: 69502
2022-05-07 17:00 DenisChenu Assigned To => DenisChenu
2022-05-07 17:00 DenisChenu Status new => feedback
2022-05-07 17:01 DenisChenu Assigned To DenisChenu =>
2022-05-07 17:01 DenisChenu Status feedback => new
2022-05-07 17:04 DenisChenu Note Edited: 69502
2022-05-07 17:18 duvemyster Issue Monitored: duvemyster
2022-05-07 17:18 duvemyster Bug heat 10 => 12
2022-05-09 09:31 Mazi Note Added: 69506
2022-05-09 09:32 DenisChenu Note Added: 69507
2022-05-09 09:43 Mazi Note Added: 69508
2022-05-09 09:43 Mazi File Added: image.png
2022-05-09 17:08 gabrieljenik Assigned To => gabrieljenik
2022-05-09 17:08 gabrieljenik Status new => assigned
2022-05-09 17:09 gabrieljenik Status assigned => new
2022-05-09 18:15 DenisChenu Note Added: 69527
2022-05-09 18:27 gabrieljenik Note Added: 69528
2022-05-09 18:27 gabrieljenik Bug heat 12 => 14
2022-05-09 19:22 DenisChenu Note Added: 69529
2022-05-09 20:26 gabrieljenik Note Added: 69531
2022-05-09 20:26 gabrieljenik File Added: image-2.png
2022-05-09 20:26 gabrieljenik File Added: image-3.png
2022-05-10 08:17 DenisChenu Note Added: 69533
2022-05-10 09:02 Mazi Note Added: 69535
2022-05-13 16:12 gabrieljenik Status new => feedback
2022-05-13 16:12 gabrieljenik Note Added: 69630
2022-05-16 14:57 Mazi Note Added: 69667
2022-05-16 14:57 Mazi Status feedback => assigned
2022-05-16 15:30 gabrieljenik Status assigned => closed
2022-05-16 15:30 gabrieljenik Resolution open => unable to reproduce