View Issue Details

This bug affects 2 person(s).
 20
IDProjectCategoryView StatusLast Update
17645Bug reportsMenu systempublic2022-03-14 08:03
ReporterEinkauf.ZIT Assigned Togalads  
PriorityhighSeverityblock 
Status closedResolutionno change required 
Product Version5.x 
Summary17645: Cannot open "List Groups" & reset menu is not working
Description

Hello!
I cannot open the "List Groups" page.

Checkout the screenshot.

Kind regards

Steps To Reproduce

Nothing special, just cannot open the page when clicking on the navigation link

TagsNo tags attached.
Bug heat20
Complete LimeSurvey version number (& build)5.1.14+210927
I will donate to the project if issue is resolvedNo
BrowserEvery browser
Database type & versionMysql
Server OS (if known)Windows Server 2012 R2 Standard Edition
Webserver software & version (if known)IIS 8.5
PHP Version7.3.20

Users monitoring this issue

User List pixel.2920

Activities

Einkauf.ZIT

Einkauf.ZIT

2021-10-01 16:01

reporter  

list groups error.PNG (203,848 bytes)
ollehar

ollehar

2021-10-01 16:03

administrator   ~66728

If you updated this installation, you might need to reset menu and menu entries (global config menu).

galads

galads

2021-10-01 16:10

reporter   ~66729

Last edited: 2022-03-08 14:45

Reset menu and menu entries from configuration>Settings>Survey Menu.

Einkauf.ZIT

Einkauf.ZIT

2021-10-01 16:27

reporter   ~66731

Last edited: 2022-03-08 14:45

Hello!

How long will the reset run, because my reset is running since a few minutes and doesn’t end.

Kind regards,

          Klaus
galads

galads

2021-10-04 08:12

reporter   ~66735

Last edited: 2022-03-08 14:45

@Einkauf.ZIT reset works immediately and restores your menu to default. You should reload the page after reset.

Einkauf.ZIT

Einkauf.ZIT

2021-10-04 09:39

reporter   ~66737

Last edited: 2022-03-08 14:45

It is running until I click somewhere in the browser...

running running running.PNG (16,934 bytes)   
running running running.PNG (16,934 bytes)   
xyzabc

xyzabc

2021-10-04 10:04

reporter   ~66738

Last edited: 2022-03-08 14:45

Hello,

I have the same problem. I'm using Version 5.1.13+210923 and Firefox. When I click on the button "reset" in the survey list, nothing happens. What can I do?

Thanks in advance.

galads

galads

2021-10-05 17:22

reporter   ~66751

Last edited: 2022-03-08 14:45

I just did a fresh install and I cannot reproduce this issue. The "reset loop" is a known issue and there is a bug report for this if I am not mistaken. Please let me know if this issue is resolved after resetting the menu?

Einkauf.ZIT

Einkauf.ZIT

2021-10-11 10:37

reporter   ~66821

Last edited: 2022-03-08 14:45

Any news about this issue?

xyzabc

xyzabc

2021-10-11 10:41

reporter   ~66822

Last edited: 2022-03-08 14:45

Hello Einkauf.ZIT,

thanks for your message. Unfortunately, not.

I reported the bug, that I cannot reset the survey list. I updated LimeSurvey to version 5.1.14+210927, however I still cannot reset the suvey list and therfore the bug with the question list is still not solved.

Einkauf.ZIT

Einkauf.ZIT

2021-10-11 11:45

reporter   ~66823

Last edited: 2022-03-08 14:45

Hello xyzabc!

The same with my installation...

Thx

ollehar

ollehar

2021-10-11 13:48

administrator   ~66827

Last edited: 2022-03-08 14:45

@xyzabc You're not supposed to reset the survey list, but the menu list.

Details here:

Please go to "Configuration" --> "Menu configuration" and click the reset button. Then, go to "Configuration" --> "Menu entries configuration" and click the reset button. After, try again to enter the page that failed. Let us know if the issue persists. Thank you.

xyzabc

xyzabc

2021-10-17 15:56

reporter   ~66859

Last edited: 2022-03-08 14:45

@ollehar,

the reset is unfornuately not possible because it's loading all the time.

Reset_bug_loading.png (58,754 bytes)   
Reset_bug_loading.png (58,754 bytes)   
ollehar

ollehar

2021-10-20 10:55

administrator   ~66878

Last edited: 2022-03-08 14:45

Ah, not good. Can you click F12 in the browser and check the console error log in the window that pops up, please?

galads

galads

2021-10-21 13:20

reporter   ~66888

Last edited: 2022-03-08 14:45

The menu system is broken. I cannot add a new menu also. I thought this was fixed aready

Einkauf.ZIT

Einkauf.ZIT

2021-11-02 09:17

reporter   ~67038

Last edited: 2022-03-08 14:45

I updated to Version 5.1.18+211101 right now, but I cannot reset the menu...
It is running without an end...

Einkauf.ZIT

Einkauf.ZIT

2021-11-02 09:44

reporter   ~67040

Last edited: 2022-03-08 14:45

Is there any other way to reset the menu or what can I check?

Einkauf.ZIT

Einkauf.ZIT

2021-11-02 09:46

reporter   ~67042

Last edited: 2022-03-08 14:45

I cannot let the users work in Lime Survey without access to the groups list...

galads

galads

2021-11-02 09:49

reporter   ~67043

Last edited: 2022-03-08 14:45

I have assigned this issue to be worked on.

Einkauf.ZIT

Einkauf.ZIT

2021-11-02 09:51

reporter   ~67044

Last edited: 2022-03-08 14:45

Thank you!

Einkauf.ZIT

Einkauf.ZIT

2021-11-11 09:52

reporter   ~67242

Last edited: 2022-03-08 14:45

Still not working with Version 5.2.0+211110

galads

galads

2021-11-11 09:58

reporter   ~67243

Last edited: 2022-03-08 14:45

We are yet to push the fix for the menu system. I guess if you cannot reset the menu, then it will still not work for you.

Einkauf.ZIT

Einkauf.ZIT

2021-11-11 10:05

reporter   ~67244

Last edited: 2022-03-08 14:45

Thank you!

pixel.2920

pixel.2920

2021-11-14 00:31

reporter   ~67283

Last edited: 2022-03-08 14:45

I can confirm all behaviors above in 5.2.1+211111. I am not able to access any Question Group lists nor reset the menus. Is there a direct URL we can use to get to these groups in the meantime?

Einkauf.ZIT

Einkauf.ZIT

2021-11-16 09:44

reporter   ~67338

Last edited: 2022-03-08 14:45

Hello!
With Version 5.2.2+211115 I could reset the menus, but the navigation looks like it lost some menu points and if I click on "Allgemeine Einstellungen", it is the same like with "Group list" before, but now on a more (most) important menu point.
There is a correction update needed immediately!
Kind regards,
Klaus

galads

galads

2021-11-16 10:26

reporter   ~67339

Last edited: 2022-03-08 14:45

Hello Klaus, do you mean the "general settings", is also not working for you? Can you send a screenshot?

After "menu reset", can you now click on the "list group"?

Einkauf.ZIT

Einkauf.ZIT

2021-11-16 10:36

reporter   ~67340

Last edited: 2022-03-08 14:45

Hello!
Yes, "General Settings", when I click on that, it doesn't open.

Here are screenshots, what I see after the "menu reset".

survey-menue after reset.PNG (30,459 bytes)   
survey-menue after reset.PNG (30,459 bytes)   
menus.PNG (20,180 bytes)   
menus.PNG (20,180 bytes)   
Einkauf.ZIT

Einkauf.ZIT

2021-11-16 14:21

reporter   ~67341

Last edited: 2022-03-08 14:45

Ok, what I see is, that a lot of menu points, like "Groups list", fell out of the "Survey Menu" and if I add them again (edit with "menu entries"), there is still the problem, that i won't open. But the menu point is back.

pixel.2920

pixel.2920

2021-12-31 19:23

reporter   ~67893

Last edited: 2022-03-08 14:45

Still not resolved as of Version 5.2.7+211221. Is there an alternate workaround or other debug info you need?

In Chrome console, when clicking on Groups list, the error message is:

https://limesurvey.example.com/index.php/admin/survey/sa/listquestiongroups/surveyid/000000?1640974979082
404 not found

gabrieljenik

gabrieljenik

2022-03-08 14:45

manager   ~68589

Last edited: 2022-03-08 14:45

Have been playing around with this on Demo.
Haven't spotted problems. Can you please try to reproduce it again no latest version?

Thanks!

galads

galads

2022-03-09 15:02

reporter   ~68607

Hello Einkauf.ZIT,
This should already be fixed in recent versions.
Can you please check if this issue still exists in the latest version of LimeSurvey and let us know?
Thank you!

pixel.2920

pixel.2920

2022-03-12 19:19

reporter   ~68642

It is still happening in 5.3.4+220309.

pixel.2920

pixel.2920

2022-03-12 19:49

reporter   ~68643

I have replaced all the files with a fresh install of 5.3.4 and it is still giving me the error message below when clicking Groups List.

404: Not Found
The system is unable to find the requested action "survey".
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact System Administrator.

pixel.2920

pixel.2920

2022-03-12 19:54

reporter   ~68644

Very interesting.

My LS installation - Group List URL is: https://coredata.example.com/index.php/admin/survey/sa/listquestiongroups/surveyid/173941

DEMO LS installation - Group List URL is https://demo.limesurvey.org/index.php?r=questionGroupsAdministration/listquestiongroups&surveyid=619922

Is there something in the SQL DB that needs to change?

pixel.2920

pixel.2920

2022-03-12 19:58

reporter   ~68645

My LS installation -

If you go to https://limesurvey.example.com/index.php/admin/survey/sa/listquestiongroups/surveyid/173941

it will go to the LS public non-admin home page.

pixel.2920

pixel.2920

2022-03-12 20:04

reporter   ~68646

OK, I think I fixed the issue. You need to reset BOTH Survey menus AND Survey menu entries under Configuration > Survey menus

galads

galads

2022-03-14 08:03

reporter   ~68650

Thank you for confirming that resetting the menu entry solved the issue. I will now close the bug report.

Issue History

Date Modified Username Field Change
2021-10-01 16:01 Einkauf.ZIT New Issue
2021-10-01 16:01 Einkauf.ZIT File Added: list groups error.PNG
2021-10-01 16:03 ollehar Note Added: 66728
2021-10-01 16:03 ollehar Bug heat 0 => 2
2021-10-01 16:10 galads Note Added: 66729
2021-10-01 16:10 galads Bug heat 2 => 4
2021-10-01 16:11 galads Assigned To => galads
2021-10-01 16:11 galads Status new => feedback
2021-10-01 16:27 Einkauf.ZIT Note Added: 66731
2021-10-01 16:27 Einkauf.ZIT Bug heat 4 => 6
2021-10-01 16:27 Einkauf.ZIT Status feedback => assigned
2021-10-04 08:12 galads Note Added: 66735
2021-10-04 09:39 Einkauf.ZIT Note Added: 66737
2021-10-04 09:39 Einkauf.ZIT File Added: running running running.PNG
2021-10-04 10:04 xyzabc Note Added: 66738
2021-10-04 10:04 xyzabc Bug heat 6 => 8
2021-10-05 17:22 galads Note Added: 66751
2021-10-05 17:22 galads Status assigned => feedback
2021-10-11 10:37 Einkauf.ZIT Note Added: 66821
2021-10-11 10:37 Einkauf.ZIT Status feedback => assigned
2021-10-11 10:41 xyzabc Note Added: 66822
2021-10-11 11:45 Einkauf.ZIT Note Added: 66823
2021-10-11 13:47 ollehar Priority none => high
2021-10-11 13:47 ollehar Description Updated
2021-10-11 13:48 ollehar Note Added: 66827
2021-10-14 10:50 galads Status assigned => feedback
2021-10-17 15:56 xyzabc Note Added: 66859
2021-10-17 15:56 xyzabc File Added: Reset_bug_loading.png
2021-10-20 10:55 ollehar Note Added: 66878
2021-10-21 13:20 galads Note Added: 66888
2021-11-02 09:17 Einkauf.ZIT Note Added: 67038
2021-11-02 09:17 Einkauf.ZIT Status feedback => assigned
2021-11-02 09:42 galads Summary Cannot open "List Groups" => Cannot open "List Groups" & reset menu is not working
2021-11-02 09:42 galads Zoho Project Synchronization => |Yes|
2021-11-02 09:44 Einkauf.ZIT Note Added: 67040
2021-11-02 09:46 Einkauf.ZIT Note Added: 67042
2021-11-02 09:49 galads Note Added: 67043
2021-11-02 09:51 Einkauf.ZIT Note Added: 67044
2021-11-11 09:52 Einkauf.ZIT Note Added: 67242
2021-11-11 09:58 galads Note Added: 67243
2021-11-11 10:05 Einkauf.ZIT Note Added: 67244
2021-11-14 00:31 pixel.2920 Note Added: 67283
2021-11-14 00:31 pixel.2920 Bug heat 8 => 10
2021-11-14 00:31 pixel.2920 Issue Monitored: pixel.2920
2021-11-14 00:31 pixel.2920 Bug heat 10 => 12
2021-11-16 09:44 Einkauf.ZIT Note Added: 67338
2021-11-16 10:26 galads Note Added: 67339
2021-11-16 10:36 Einkauf.ZIT Note Added: 67340
2021-11-16 10:36 Einkauf.ZIT File Added: survey-menue after reset.PNG
2021-11-16 10:36 Einkauf.ZIT File Added: menus.PNG
2021-11-16 14:21 Einkauf.ZIT Note Added: 67341
2021-12-31 19:22 guest Bug heat 12 => 18
2021-12-31 19:23 pixel.2920 Note Added: 67893
2022-03-08 14:45 gabrieljenik Note Added: 68589
2022-03-08 14:45 gabrieljenik Bug heat 18 => 20
2022-03-08 14:45 gabrieljenik Status assigned => feedback
2022-03-09 15:02 galads Note Added: 68607
2022-03-12 19:19 pixel.2920 Note Added: 68642
2022-03-12 19:49 pixel.2920 Note Added: 68643
2022-03-12 19:54 pixel.2920 Note Added: 68644
2022-03-12 19:58 pixel.2920 Note Added: 68645
2022-03-12 20:04 pixel.2920 Note Added: 68646
2022-03-14 08:03 galads Note Added: 68650
2022-03-14 08:03 galads Status feedback => closed
2022-03-14 08:03 galads Resolution open => no change required