View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17587Bug reportsStatisticspublic2022-08-29 14:35
Reporter2BITS_PL Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.25.19 
Summary17587: Invalid type in userstatistics_helper.php [2444] - php7.4
Description

Applies to the public statistics page with debugging enabled.

In some cases, $aattr returns a boolean value, which causes references to array parameters to generate errors.

Additional Information

The bug was found in version 3.25.19, also confirmed in version 3.27.17 (latest).

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)v3.27.17+210911
I will donate to the project if issue is resolvedNo
Browser
Database type & versionSQL Server 2019
Server OS (if known)
Webserver software & version (if known)
PHP Versionv7.4.15 NTS x64

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

gabrieljenik

gabrieljenik

2022-07-14 00:44

manager   ~70918

Hello 2BITS_PL,
This ticket has been open for quite some time.
Do you have any new info / feedback?
Can you please check if this issue still exists in the latest version of LimeSurvey and let us know?
Thank you!

2BITS_PL

2BITS_PL

2022-08-04 09:18

reporter   ~71317

We currently have an older version so I cannot verify this. As soon as the project is updated, I will post a feedback.

2BITS_PL

2BITS_PL

2022-08-29 12:47

reporter   ~71550

I couldn't reproduce the bug in version 3.28.24.

However, in the QuestionAttribute class, the getQuestionAttributes method can still return Boolean (false) in the event that $oQuestion is empty. For that to happen, $iQuestionID (parent of qid) would have to be 0. Could that be? I don't know right now - I couldn't simulate it.

gabrieljenik

gabrieljenik

2022-08-29 14:31

manager   ~71553

For that to happen, $iQuestionID (parent of qid) would have to be 0

Actually it will return false if the question is not foundby the given $iQuestionID.

As per the comments and that can't be reproduced, will be closing the ticket.
Please add any comments in case it should be reopened.
Thanks

Issue History

Date Modified Username Field Change
2021-09-10 11:25 2BITS_PL New Issue
2022-07-14 00:44 gabrieljenik Assigned To => gabrieljenik
2022-07-14 00:44 gabrieljenik Status new => feedback
2022-07-14 00:44 gabrieljenik Note Added: 70918
2022-07-14 00:44 gabrieljenik Bug heat 0 => 2
2022-08-04 09:18 2BITS_PL Note Added: 71317
2022-08-04 09:18 2BITS_PL Bug heat 2 => 4
2022-08-04 09:18 2BITS_PL Status feedback => assigned
2022-08-04 15:17 gabrieljenik Assigned To gabrieljenik =>
2022-08-04 15:17 gabrieljenik Status assigned => feedback
2022-08-29 12:47 2BITS_PL Note Added: 71550
2022-08-29 12:47 2BITS_PL Status feedback => new
2022-08-29 14:31 gabrieljenik Note Added: 71553
2022-08-29 14:35 gabrieljenik Assigned To => gabrieljenik
2022-08-29 14:35 gabrieljenik Status new => closed
2022-08-29 14:35 gabrieljenik Resolution open => unable to reproduce