View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17566Bug reportsPluginspublic2021-09-20 15:51
ReporterDennis1993 Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version5.x 
Summary17566: Use LDAP authentication" setting disappears
DescriptionHi there,

we have been using LimeSurvey for about 2 months and are very satisfied. First of all, thank you very much!

We use the system in connection with our ActiveDirectory for the login.
We had to find out almost every week (now again) that the point "Use LDAP authentication" disappears again and again in all groups and nobody (except the local admin) can log in. At first I thought it was related to an update, but today it occurs again and no update was performed. The login was fine yesterday and now the option is gone again.

Can someone tell me what this is related to? Why does this setting disappear over and over again in all user roles at once? Do I have to pay attention to something that I have overlooked or is it just a bug?

Thanks very much!
Tagsldap
Bug heat4
Complete LimeSurvey version number (& build)Version 5.1.4+210824
I will donate to the project if issue is resolvedNo
BrowserMicrosoft Edge
Database type & versionMariaDB 10.3.x
Server OS (if known)Ubuntu 20.04
Webserver software & version (if known)Apache 2.4
PHP VersionPHP 8.0.10

Relationships

related to 17590 closedgabrieljenik Role reseted after checkintegrity 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Dennis1993

Dennis1993

2021-09-03 08:03

reporter  

image.png (64,128 bytes)   
image.png (64,128 bytes)   
c_schmitz

c_schmitz

2021-09-06 10:10

administrator   ~66335

I cannot see any reason why this should happen out of the blue.

The only time this setting could get removed if the LDAP plugin is disabled and the permission of a particular user are saved, and then it would happen only for that one user.
There is no function in LimeSurvey to reset this on several users.

Are you maybe using RemoteControl API or something to modify user permissions? Or maybe someone with direct MySQL access?


Dennis1993

Dennis1993

2021-09-20 09:43

reporter   ~66527

Hey,

today the settings are invoked again. I use version 5.1.10 and today a new version is reported (in the top bar). Maybe is that the problem? That is the only change from last week to today.
Database connection is only for me possible. No other user has permission or a user account to the database.

The column "Changed" is set to 13.09.2021 but the setting is gone since today. Last week (Saturday) the login worked. Today, the login is not possible...
How is that possible? The setting was set to login with LDAP last saturday and now the setting is gone again but the last change is from 13.09.2021. That not logical.

The settings in this group is only LDAP permission (see screenshot, please).

Thanks in advance.
image-2.png (6,438 bytes)   
image-2.png (6,438 bytes)   
image-3.png (21,504 bytes)   
image-3.png (21,504 bytes)   
c_schmitz

c_schmitz

2021-09-20 15:19

administrator   ~66530

Last edited: 2021-09-20 15:19

View 2 revisions

I was not aware that you were using roles. I only saw it by sour screenhot. This might be related to 17590.

Can you check if 'Integrity check' is maybe causing this?
Dennis1993

Dennis1993

2021-09-20 15:46

reporter   ~66536

Yes, thats the problem. If I click on "integrity check" my settings are lost. :D
I opened the page and the checkbox is not checked after that and the login is not possible anymore.

In which version is that problem fixed?
THANK YOU!
Dennis1993

Dennis1993

2021-09-20 15:51

reporter   ~66538

I updated to 5.1.11 and the problem is solved I think. I cant reproduce it if I open the integrity check.

Thank you! :)

Issue History

Date Modified Username Field Change
2021-09-03 08:03 Dennis1993 New Issue
2021-09-03 08:03 Dennis1993 File Added: image.png
2021-09-03 08:56 Dennis1993 Tag Attached: ldap
2021-09-03 12:16 ollehar Bug heat 0 => 2
2021-09-03 12:16 ollehar Assigned To => ollehar
2021-09-03 12:16 ollehar Status new => feedback
2021-09-03 12:59 Dennis1993 Bug heat 2 => 4
2021-09-03 12:59 Dennis1993 Status feedback => assigned
2021-09-06 09:30 c_schmitz Description Updated View Revisions
2021-09-06 09:30 c_schmitz Bug heat 4 => 2
2021-09-06 09:30 c_schmitz Bug heat 2 => 0
2021-09-06 09:31 c_schmitz Summary Einstellung "Verwende LDAP-Authentifizierung" verchwindet => Use LDAP authentication" setting disappears
2021-09-06 10:10 c_schmitz Assigned To ollehar => c_schmitz
2021-09-06 10:10 c_schmitz Status assigned => feedback
2021-09-06 10:10 c_schmitz Note Added: 66335
2021-09-06 10:10 c_schmitz Bug heat 0 => 2
2021-09-20 09:43 Dennis1993 Note Added: 66527
2021-09-20 09:43 Dennis1993 File Added: image-2.png
2021-09-20 09:43 Dennis1993 File Added: image-3.png
2021-09-20 09:43 Dennis1993 Bug heat 2 => 4
2021-09-20 09:43 Dennis1993 Status feedback => assigned
2021-09-20 15:18 c_schmitz Relationship added related to 17590
2021-09-20 15:19 c_schmitz Note Added: 66530
2021-09-20 15:19 c_schmitz Status assigned => feedback
2021-09-20 15:19 c_schmitz Note Edited: 66530 View Revisions
2021-09-20 15:46 Dennis1993 Note Added: 66536
2021-09-20 15:46 Dennis1993 Status feedback => assigned
2021-09-20 15:51 Dennis1993 Note Added: 66538