View Issue Details

This bug affects 2 person(s).
IDProjectCategoryView StatusLast Update
17524Bug reports_ Unknownpublic2021-09-17 13:59
Reportergsoto Assigned Togalads  
Status acknowledgedResolutionopen 
Product Version3.25.20 
Summary17524: when using survey navigation, the survey jumps back
DescriptionWhen using the "Next" button in a survey, the survey jumps back by one or two pages or even back to page 1. A browser popup can also occur, saying not to use the browser navigation – even when only using the LimeSurvey navigation button "Next" (screenshot attached). The issue occurs consistently with Safari in macOS Big Sur, but was also encountered in Chrome.
Steps To ReproduceStart a survey, click "Next" until one of 2 things occur:
- the survey jumps back
- a browser popup opens, saying not to use browser navigation buttons
TagsNo tags attached.
Bug heat14
Complete LimeSurvey version number (& build)Version 3.27.10+210803
I will donate to the project if issue is resolvedYes
BrowserSafari Version 14.1.1 (16611.
Database type & versionMySQL: 10.3-MariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version8.0.9 / 7.4.22 / 7.3.29 / 7.2.34

Users monitoring this issue

User List There are no users monitoring this issue.




2021-08-18 15:53




2021-08-18 16:53

administrator   ~66054

For us to be able to investigate this issue please attach a 2 question sample survey demonstrating the issue, either as .lss file (survey structure) or (even better) as .lsa file (survey archive).

Just attach it to this issue and we will have a look.
Thank you!


2021-08-18 17:04

partner   ~66055

Please also try updating to the latest version 3.27.12+210816.


2021-08-19 08:28

administrator   ~66063

Could be an issue with Mac (safari), I will try to reproduce this.


2021-08-19 10:16

reporter   ~66065

Unfortunately, I am not able to produce a sample survey where the issue occurs consistently. A sample survey with 4 groups with and 4 questions did produce the issue at first, now it no longer occurs, even with 6 groups and 6 questions. Can I confidentially share an existing survey where the issue occurs consistently? Does the "private" option ensure that? I do not want the survey to be shared publicly.


2021-08-19 11:31

administrator   ~66067

I cannot reproduce this issue on Safari (version 14.1.2). I also tried on chrome with no luck. You can share a file and mark it as private and only admins and developers can see it.


2021-08-20 10:34

reporter   ~66091

Updating to Version 3.27.12 did not resolve the issue. I have moved the survey to an older LimeSurvey installation on a different server. This server is running Version 3.25.20. The issue does not occur here. So the problem was introduced somewhere between Version 3.25.20 and Version 3.27.10.


2021-08-20 11:41

administrator   ~66092

Thank you for the information. I am using version 3.27.10 to test. This might take some time to reproduce since it happens randomly.


2021-08-20 12:30

reporter   ~66093

We are using table based session files. I'm not sure if this is relevant.


2021-08-24 23:26

partner   ~66118

@gsoto, feel free to attach the template used if your guess is that this casues the problem (I have my doubts).

@galads / @ollehar, please mark the ticket "private" if the theme is uploaded.
This issue really becomes a show stopper for this customer and I have no real clue what may cause this. We have not received any similar problem reports from other customers.


2021-08-25 09:56

administrator   ~66120

I will test with the theme you uploaded. I could not find any issue with the core themes on safari


2021-08-25 11:16

administrator   ~66123

If it can't be reproduced with the standard survey themes, I can only assume it's faulty HTML or JS in the custom theme.


2021-09-14 16:47

reporter   ~66479

In the meantime, a user has reported an instance of the issue occurring on our version 3.25.20. We have now set up a separate LimeSurvey instance of an even older version (3.23.1). So far, we have not encountered the issue in this version. But obviously, going back further in time cannot be the solution.


2021-09-15 12:03

partner   ~66487

@ollehar, the adjustments we made only included .twig or .css file adjutsments. We have taken all other core files form the vanilla theme.

@gsoto, if I remember correctly, the issue were also showing up a few times using the shipped vanilla theme?


2021-09-15 12:06

administrator   ~66488

@Mazi You should try the forum for help with debugging the custom theme.

@gsoto We only support bug fixes for the latest LS versions. For LS3, it's 3.27.17.


2021-09-15 12:57

reporter   ~66491

@Mazi Yes, the issue has occurred a few times using the shipped vanilla theme. With the custom theme, we have encountered the issue a lot more cosnistently. It is impossible for us to determine what factors precisely cause the issue.

@ollehar Yes, I understand that you won't debug old versions. The issue does not (or hardly) occur in the old version. This suggests that a bug was introduced since that version and is present in the latest version.


2021-09-15 13:05

partner   ~66492

@ollehar, I am sorry, but I am working with this software for more than 14 years and have dealt with > 1000 Limesurvey projects. I don't think there is someone else with more experience at the forums.
Furthemore, the customer reports that the problem also shows up with the vanilla theme so it is not related to any edits we made to the templates.

@gsoto: I think what we need is a link to a test survey at the latest 3.x version and then some detailled instructions on how we can safely reproduce this. That would be the starting point to track it down.


2021-09-15 13:21

administrator   ~66493

OK, well, then as usual it's the problem of being able to reproduce. :) Any type of more info is welcome.


2021-09-16 14:14

reporter   ~66498

I have 3 weeks ago privately shared a link to a survey where the issue occurs for us consistently. @galads, is there any progress on reproducing the issue? With the latest update to 3.27.17, it still occurs.


2021-09-17 13:59

administrator   ~66516

I have tried several times on safari to reproduce this issue but I cannot.

Issue History

Date Modified Username Field Change
2021-08-18 15:53 gsoto New Issue
2021-08-18 15:53 gsoto File Added: Bildschirmfoto 2021-08-18 um 15.45.21.png
2021-08-18 16:53 galads Assigned To => galads
2021-08-18 16:53 galads Status new => acknowledged
2021-08-18 16:53 galads Note Added: 66054
2021-08-18 16:53 galads Bug heat 0 => 2
2021-08-18 16:59 guest Bug heat 2 => 8
2021-08-18 17:04 Mazi Note Added: 66055
2021-08-18 17:04 Mazi Bug heat 8 => 10
2021-08-18 17:46 ollehar Product Version => 3.25.20
2021-08-18 17:46 ollehar Steps to Reproduce Updated View Revisions
2021-08-19 08:28 galads Note Added: 66063
2021-08-19 10:16 gsoto Note Added: 66065
2021-08-19 10:16 gsoto Bug heat 10 => 12
2021-08-19 11:31 galads Note Added: 66067
2021-08-20 10:34 gsoto Note Added: 66091
2021-08-20 11:41 galads Note Added: 66092
2021-08-20 12:30 gsoto Note Added: 66093
2021-08-24 23:26 Mazi Note Added: 66118
2021-08-25 09:56 galads Note Added: 66120
2021-08-25 11:16 ollehar Note Added: 66123
2021-08-25 11:16 ollehar Bug heat 12 => 14
2021-09-14 16:47 gsoto Note Added: 66479
2021-09-15 12:03 Mazi Note Added: 66487
2021-09-15 12:06 ollehar Note Added: 66488
2021-09-15 12:57 gsoto Note Added: 66491
2021-09-15 13:05 Mazi Note Added: 66492
2021-09-15 13:21 ollehar Note Added: 66493
2021-09-16 14:14 gsoto Note Added: 66498
2021-09-17 13:59 galads Note Added: 66516