View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
17485Bug reportsOtherpublic2022-08-17 15:17
Reporteralorenc Assigned Toollehar  
PrioritynoneSeveritytrivial 
Status ready for mergeResolutionreopened 
Product Version3.25.19 
Summary17485: The getAnswerQuery method cannot be used in the Answers model.
Description

The method is not used in the project, so probably nobody noticed this bug before (also occurs in version 3.27.9).

model Answer, method getAnswerQuery, lines 218-219, contains 'bindParams' and should be 'bindParam' (without letter 's')

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)v3.28.23
I will donate to the project if issue is resolvedNo
Browser
Database type & versionSQL Server 2019
Server OS (if known)
Webserver software & version (if known)
PHP Versionv7.4.15 NTS x64

Users monitoring this issue

User List 2BITS_PL

Activities

gabrieljenik

gabrieljenik

2022-08-04 21:13

manager   ~71332

Hello alorenc,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

gabrieljenik

alorenc

alorenc

2022-08-11 15:51

reporter   ~71409

The bug has not been fixed. Answers model, lines 218 and 219.

https://github.com/LimeSurvey/LimeSurvey/blob/9ed303397f083aad90fec5264525b4e1f95b01de/application/models/Answer.php#L218

gabrieljenik

gabrieljenik

2022-08-11 16:38

manager   ~71411

That method is not used in the code.

alorenc

alorenc

2022-08-11 18:13

reporter   ~71412

Yes, I confirm that it is not used. But if someone wants to access this method (public) from within a plugin, they will return an error.
Perhaps it should be marked as deprecated or you just need to fix the reported bug.

gabrieljenik

gabrieljenik

2022-08-11 19:56

manager   ~71414

The method is not longer available on master.
I will mark it as deprecated just in case.

gabrieljenik

gabrieljenik

2022-08-12 23:11

manager   ~71436

PR: https://github.com/LimeSurvey/LimeSurvey/pull/2569

DenisChenu

DenisChenu

2022-08-17 11:38

developer   ~71459

@alorenc : can you test ?

alorenc

alorenc

2022-08-17 11:52

reporter   ~71461

Confirm, the fix works.

Issue History

Date Modified Username Field Change
2021-07-29 16:05 alorenc New Issue
2022-08-04 21:13 gabrieljenik Assigned To => gabrieljenik
2022-08-04 21:13 gabrieljenik Status new => closed
2022-08-04 21:13 gabrieljenik Resolution open => unable to reproduce
2022-08-04 21:13 gabrieljenik Note Added: 71332
2022-08-04 21:13 gabrieljenik Bug heat 0 => 2
2022-08-11 15:51 alorenc Status closed => feedback
2022-08-11 15:51 alorenc Resolution unable to reproduce => reopened
2022-08-11 15:51 alorenc Complete LimeSurvey version number (& build) v3.25.19+210323 => v3.28.23
2022-08-11 15:51 alorenc Note Added: 71409
2022-08-11 15:51 alorenc Bug heat 2 => 4
2022-08-11 15:51 2BITS_PL Issue Monitored: 2BITS_PL
2022-08-11 15:51 2BITS_PL Bug heat 4 => 6
2022-08-11 16:38 gabrieljenik Note Added: 71411
2022-08-11 18:13 alorenc Note Added: 71412
2022-08-11 18:13 alorenc Status feedback => assigned
2022-08-11 19:56 gabrieljenik Note Added: 71414
2022-08-12 23:11 gabrieljenik Status assigned => ready for code review
2022-08-12 23:11 gabrieljenik Note Added: 71436
2022-08-12 23:11 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-08-17 11:38 DenisChenu Assigned To DenisChenu =>
2022-08-17 11:38 DenisChenu Status ready for code review => ready for testing
2022-08-17 11:38 DenisChenu Note Added: 71459
2022-08-17 11:38 DenisChenu Bug heat 6 => 8
2022-08-17 11:52 alorenc Note Added: 71461
2022-08-17 15:17 gabrieljenik Assigned To => ollehar
2022-08-17 15:17 gabrieljenik Status ready for testing => ready for merge