View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
17452Bug reportsComfortUpdatepublic2021-09-10 12:24
Reporteralorenc Assigned Toc_schmitz  
PriorityurgentSeverityblock 
Status feedbackResolutionreopened 
Product Version3.25.19 
Summary17452: Error when trying to update ComfortUpdate key
DescriptionThe problem is described here 14214:65469.

I added an error description there because I thought the ticket would automatically change its status to active, but it didn't and I don't want to duplicate the content.
Additional InformationCopied from https://bugs.limesurvey.org/view.php?id=14214#c65469

Hi, I'm using version 3.25.19 and I'm having the same bug.
Works in a test environment (local Windows IIS, MSSQL v15, PHP 7.4).
Before, I used a code that was free (monthly). Now I wanted to update the project to the new code purchased (on an account set up specifically for the client).

I go to the place where the object "$updateKeyInfos" is created, that is "\application\controllers\admin\update.php" method "managekey()", dumps the object "$updateModel" below screen, as you can see the method is called twice. The first time the object is normal after the second is empty (here it returns a reference error to the parameter "validuntil" because the object "$updateKeyInfos" contains the same).

There is a problem somewhere, unfortunately I do not have time for a more detailed analysis. I deleted the old comfortUpdate code from the database, the "settubgs_global" table, the "update_key" key and that temporarily solved my problem.
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)v3.25.19+210323
I will donate to the project if issue is resolvedNo
Browser
Database type & versionMYSQL v15
Server OS (if known)Microsoft Server 2019
Webserver software & version (if known)
PHP Versionv7.4.15 NTS x64

Users monitoring this issue

User List 2BITS_PL

Activities

ollehar

ollehar

2021-07-21 14:15

administrator   ~65522

Are you sure you're having the *exact* same error as in the other ticket? Can you enable debug => 2 in application/config/config.php and give us a screenshot of the error, please?
galads

galads

2021-08-30 12:28

administrator   ~66173

Hello alorenc,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

galads

Issue History

Date Modified Username Field Change
2021-07-16 12:17 alorenc New Issue
2021-07-16 14:55 DenisChenu Additional Information Updated View Revisions
2021-07-16 15:34 galads Assigned To => c_schmitz
2021-07-16 15:34 galads Status new => assigned
2021-07-19 21:39 ollehar Priority none => urgent
2021-07-21 14:15 ollehar Note Added: 65522
2021-07-21 14:15 ollehar Status assigned => feedback
2021-08-30 12:28 galads Note Added: 66173
2021-08-30 12:28 galads Bug heat 2 => 4
2021-08-30 12:28 galads Status feedback => closed
2021-08-30 12:28 galads Resolution open => fixed
2021-09-10 12:22 alorenc Bug heat 4 => 6
2021-09-10 12:22 alorenc Status closed => feedback
2021-09-10 12:22 alorenc Resolution fixed => reopened
2021-09-10 12:24 2BITS_PL Issue Monitored: 2BITS_PL
2021-09-10 12:24 2BITS_PL Bug heat 6 => 8