View Issue Details

This bug affects 2 person(s).
IDProjectCategoryView StatusLast Update
17452Bug reportsComfortUpdatepublic2022-06-28 16:44
Reporteralorenc Assigned Toc_schmitz  
Status closedResolutionreopened 
Product Version3.25.19 
Summary17452: Error when trying to update ComfortUpdate key

The problem is described here 14214:65469.

I added an error description there because I thought the ticket would automatically change its status to active, but it didn't and I don't want to duplicate the content.

Additional Information

Copied from

Hi, I'm using version 3.25.19 and I'm having the same bug.
Works in a test environment (local Windows IIS, MSSQL v15, PHP 7.4).
Before, I used a code that was free (monthly). Now I wanted to update the project to the new code purchased (on an account set up specifically for the client).

I go to the place where the object "$updateKeyInfos" is created, that is "\application\controllers\admin\update.php" method "managekey()", dumps the object "$updateModel" below screen, as you can see the method is called twice. The first time the object is normal after the second is empty (here it returns a reference error to the parameter "validuntil" because the object "$updateKeyInfos" contains the same).

There is a problem somewhere, unfortunately I do not have time for a more detailed analysis. I deleted the old comfortUpdate code from the database, the "settubgs_global" table, the "update_key" key and that temporarily solved my problem.

TagsNo tags attached.
Bug heat20
Complete LimeSurvey version number (& build)v3.25.19+210323
I will donate to the project if issue is resolvedNo
Database type & versionMYSQL v15
Server OS (if known)Microsoft Server 2019
Webserver software & version (if known)
PHP Versionv7.4.15 NTS x64

Users monitoring this issue





2021-07-21 14:15

administrator   ~65522

Are you sure you're having the exact same error as in the other ticket? Can you enable debug => 2 in application/config/config.php and give us a screenshot of the error, please?



2021-08-30 12:28

reporter   ~66173

Hello alorenc,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,




2022-01-17 15:20

reporter   ~68032

It is enough to change the value of the "update_key" key in the database to any string and the problem appears every time.

The mechanism behaves the same as if the key value is obsolete. Path: Configuration> ComfortUpdate> click "Manage your key" and an error appears.

2022-04-26 16:35

reporter   ~69250

I'm having exactly the same error. Right now using version 5.3.4+220309, I had an expired key and when I try to click on "Enter a new key" the same error appears:

PHP notice

Undefined property: stdClass::$validuntil


29 </thead>
31 <tbody>
32 <tr>
33 <td>
34 <?php if(!App()->getConfig('hide_update_key')):?>
35 <?php echo $updateKey; ?>
36 <?php else:?>
37 <em>XXXXXXXXXXX</em>
38 <?php endif;?>
39 </td>
40 <td>
41 <?php echo convertToGlobalSettingFormat($updateKeyInfos->validuntil); ?>
42 </td>
43 <td>
44 <?php echo $updateKeyInfos->remaining_updates; ?>
45 </td>
46 <td>
47 <a data-post-url="<?php echo App()->createUrl('/admin/update/sa/deleteKey');?>" class="btn btn-default" data-toggle="modal" data-target="#confirmation-modal" data-tooltip="true" title="<?php eT("Delete");?>" >
48 <span class="fa fa-trash text-danger"></span>
49 </a>
50 </td>
51 </tr>
52 </tbody>
53 </table>

2022-04-26 17:13

reporter   ~69251

Just to add: it also happens with latest 5.3.11 (breaks if I go to Configuration -> ComfortUpdate -> Manage my key).

It's a bit weird though, because I have an almost identical server:

  • same Debian stable release, updated today
  • same PHP version (7.4.28)
  • same Apache version (2.4.53)
    with another Limesurvey installation and the ComfortUpdate works here.

There were just 2 differences:

  • session and sessionName are enabled on the broken server, I tried disabling them -> no success
  • the locale was wrong on the same server (was "C", now it's "en_US.UTF8"), I set the correct locale but still no success




2022-06-28 15:29

administrator   ~70589

Hello alorenc,
This should already be fixed in recent versions.
Can you please check if this issue still exists in the latest version of LimeSurvey and let us know?
Thank you!

2022-06-28 16:07

reporter   ~70590

Hi, I can confirm that my installation works after upgrading from 5.3.11 to 5.3.22.


Issue History

Date Modified Username Field Change
2021-07-16 12:17 alorenc New Issue
2021-07-16 14:55 DenisChenu Additional Information Updated
2021-07-16 15:34 galads Assigned To => c_schmitz
2021-07-16 15:34 galads Status new => assigned
2021-07-19 21:39 ollehar Priority none => urgent
2021-07-21 14:15 ollehar Note Added: 65522
2021-07-21 14:15 ollehar Status assigned => feedback
2021-08-30 12:28 galads Note Added: 66173
2021-08-30 12:28 galads Bug heat 2 => 4
2021-08-30 12:28 galads Status feedback => closed
2021-08-30 12:28 galads Resolution open => fixed
2021-09-10 12:22 alorenc Bug heat 4 => 6
2021-09-10 12:22 alorenc Status closed => feedback
2021-09-10 12:22 alorenc Resolution fixed => reopened
2021-09-10 12:24 2BITS_PL Issue Monitored: 2BITS_PL
2021-09-10 12:24 2BITS_PL Bug heat 6 => 8
2022-01-17 15:20 alorenc Note Added: 68032
2022-01-17 15:20 alorenc Status feedback => assigned
2022-04-26 16:33 guest Bug heat 8 => 14
2022-04-26 16:35 Note Added: 69250
2022-04-26 16:35 Bug heat 14 => 16
2022-04-26 16:35 Issue Monitored:
2022-04-26 16:35 Bug heat 16 => 18
2022-04-26 17:13 Note Added: 69251
2022-06-28 15:28 c_schmitz Priority urgent => high
2022-06-28 15:29 c_schmitz Status assigned => feedback
2022-06-28 15:29 c_schmitz Note Added: 70589
2022-06-28 15:29 c_schmitz Bug heat 18 => 20
2022-06-28 16:07 Note Added: 70590
2022-06-28 16:44 c_schmitz Status feedback => closed