View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17424Bug reportsPluginspublic2021-07-21 17:40
Reportergabrieljenik Assigned Togalads  
PrioritynoneSeverityminor 
Status closedResolutionwon't fix 
Product Version5.x 
Summary17424: When installing a plugin from LSv3, if the config.xml is not totally compatible, the plugin is not installed.
DescriptionThis may NOT sound a bug as it is OK to reject non compatible plugins.
Still, the issue is there is some code to automatically convert the config,xml to newer versions.
That piece of code is not exectued anymore, as it checks compatibiltiy first (which may be fixed later)

If not a heaviour bug, a code review should be needed.
TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)5.0
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMysql
Server OS (if known)
Webserver software & version (if known)
PHP Versionphp

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

ollehar

ollehar

2021-07-18 11:46

administrator   ~65493

> Still, the issue is there is some code to automatically convert the config,xml to newer versions.

That's only for question themes, I think? Guess it could be generalized?
ollehar

ollehar

2021-07-21 15:19

administrator   ~65526

Removing crash status, since this is by design. Unless someone can convince me otherwise. :) Adding compatibility in the config.xml file is supposed to be a guarantee that the plugin developer has tested the plugin on that version.
DenisChenu

DenisChenu

2021-07-21 17:40

developer   ~65561

> Removing crash status, since this is by design. Unless someone can convince me otherwise. :) Adding compatibility in the config.xml file is supposed to be a guarantee that the plugin developer has tested the plugin on that version.

+1
Maybe have a new feature ?
Allowing 5 and up version ?

With "state" for each version ?

    <compatibility>
        <version>5</version>
        <test>[6:*]</test>
    </compatibility>

Issue History

Date Modified Username Field Change
2021-07-08 16:14 gabrieljenik New Issue
2021-07-08 16:14 gabrieljenik Status new => assigned
2021-07-08 16:14 gabrieljenik Assigned To => galads
2021-07-08 16:14 gabrieljenik Issue generated from: 17421
2021-07-18 11:46 ollehar Note Added: 65493
2021-07-21 15:19 ollehar Severity crash => minor
2021-07-21 15:19 ollehar Sync to Zoho Project Yes => |Yes|
2021-07-21 15:19 ollehar Note Added: 65526
2021-07-21 15:20 ollehar Status assigned => closed
2021-07-21 15:20 ollehar Resolution open => won't fix
2021-07-21 17:40 DenisChenu Note Added: 65561