View Issue Details

IDProjectCategoryView StatusLast Update
17146Bug reportsFile managerpublic2021-03-02 12:26
Reportersamarta Assigned Toc_schmitz  
PrioritynoneSeveritypartial_block 
Status closedResolutionduplicate 
Product Version4.4.7 
Summary17146: In the Survey Menu the item "Resources" crashes
DescriptionHi,

In the Survey Menu the item "Resources" crashes (spinning wheel appears)

Tested in Apple Safari, Google Chrome


-- João
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.4.11+210301
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql Ver 8.0.17
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4.9

Relationships

duplicate of 17125 closedc_schmitz File manager not even found (404) 
related to 17128 closedc_schmitz Outdated menu follow to 404 : demo.limesurvey.org 

Activities

samarta

samarta

2021-03-02 10:04

reporter  

Image.png (82,708 bytes)   
Image.png (82,708 bytes)   
DenisChenu

DenisChenu

2021-03-02 10:09

developer   ~62600

Please :

1. can you right click on Resource and open in a new tab ?
2. Same but with debug set
samarta

samarta

2021-03-02 12:21

reporter   ~62603

Here is the output:
CHttpException
The system is unable to find the requested action "filemanager".

/var/www/html/limesurvey/framework/web/CController.php(486)

474 return $this->createActionFromMap($map,$actionID,$requestActionID,$config);
475 }
476
477 /**
478 * Handles the request whose action is not recognized.
479 * This method is invoked when the controller cannot find the requested action.
480 * The default implementation simply throws an exception.
481 * @param string $actionID the missing action name
482 * @throws CHttpException whenever this method is invoked
483 */
484 public function missingAction($actionID)
485 {
486 throw new CHttpException(404,Yii::t('yii','The system is unable to find the requested action "{action}".',
487 array('{action}'=>$actionID==''?$this->defaultAction:$actionID)));
488 }
489
490 /**
491 * @return CAction the action currently being executed, null if no active action.
492 */
493 public function getAction()
494 {
495 return $this->_action;
496 }
497
498 /**
Stack Trace
#0
+ /var/www/html/limesurvey/framework/web/CController.php(270): CController->missingAction()
#1
– /var/www/html/limesurvey/application/controllers/AdminController.php(202): CController->run()
197 }
198
199 $this->runModuleController($action);
200
201
202 return parent::run($action);
203 }
204
205 /**
206 * Starting with LS4, 3rd party developper can extends any of the LimeSurve controllers.
207 *
#2
+ /var/www/html/limesurvey/framework/web/CWebApplication.php(282): AdminController->run()
#3
+ /var/www/html/limesurvey/framework/web/CWebApplication.php(141): CWebApplication->runController()
#4
+ /var/www/html/limesurvey/framework/base/CApplication.php(185): CWebApplication->processRequest()
#5
– /var/www/html/limesurvey/index.php(182): CApplication->run()
177 require_once APPPATH . 'core/LSYii_Application' . EXT;
178
179 $config = require_once(APPPATH . 'config/internal' . EXT);
180
181 Yii::$enableIncludePath = false;
182 Yii::createApplication('LSYii_Application', $config)->run();
183
184 /* End of file index.php */
185 /* Location: ./index.php */
2021-03-02 11:19:08 Apache/2.4.37 (centos) OpenSSL/1.1.1c Yii Framework/1.1.22-dev

Issue History

Date Modified Username Field Change
2021-03-02 10:04 samarta New Issue
2021-03-02 10:04 samarta File Added: Image.png
2021-03-02 10:09 DenisChenu Note Added: 62600
2021-03-02 12:21 samarta Note Added: 62603
2021-03-02 12:24 DenisChenu Relationship added duplicate of 17125
2021-03-02 12:25 DenisChenu Relationship added related to 17128
2021-03-02 12:26 DenisChenu Assigned To => c_schmitz
2021-03-02 12:26 DenisChenu Status new => closed
2021-03-02 12:26 DenisChenu Resolution open => duplicate