View Issue Details

IDProjectCategoryView StatusLast Update
17112Bug reportsTranslationpublic2021-04-23 11:00
ReporterMazi Assigned Toollehar  
PrioritynormalSeverityblock 
Status resolvedResolutionfixed 
Product Version3.25.10 
Summary17112: Uploading files at quick translation feature using integrated editor fails with permission error
DescriptionUploading an image at the quick translation can fail under certain circumstances, see screenshot.
Seems to be related to cookies.
Steps To ReproduceCreate a new 1 question survey.
Add a short welcome text.
Add another language.
Go to the quick translation feature.
Using the integrated editor, try uploading a file e.g. to the welcome text using the upload feature.
When clicking "browse server" a permission error shows up.
Additional InformationUploading a file at the text elements works fine though!

Interesting side effect: After trying to upload the file at the welcome text, the upload IS actually also doable at the quick translations feature.

When deleting all cookies, then calling the quick add feature and trying to upload a file again, the permissions error shows up again.

I could also reproduce this at version Version 3.25.8+210118
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.25.11+210210
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 18
Webserver software & version (if known)Apache 2.0
PHP Version7.2.24

Activities

Mazi

Mazi

2021-02-18 18:45

partner  

image.png (118,385 bytes)
DenisChenu

DenisChenu

2021-02-19 08:53

developer   ~62385

Question : did it work if you upload an image in other way before ?
Mazi

Mazi

2021-02-19 09:21

partner   ~62387

If, at the new survey, I upload an image e.g. at the text elements screen and then switch to the quick translation, than that suddenly works fine.
DenisChenu

DenisChenu

2021-02-19 09:27

developer   ~62388

OK :) thank you
Mazi

Mazi

2021-04-19 18:14

partner   ~64008

@ollehar, this issue still shows up. Switching from PHP 7.2.x to 7.3.x doesn't make a difference. Can someone please look into this?
Thanks!
Mazi

Mazi

2021-04-19 18:16

partner   ~64009

The problem is also showing up at demo.limesurvey.org using Version 4.4.16.
ollehar

ollehar

2021-04-19 18:17

administrator   ~64010

Yikes
ollehar

ollehar

2021-04-19 18:18

administrator   ~64011

Let's see if I have time tomorrow.
ollehar

ollehar

2021-04-20 11:47

administrator   ~64039

Can't even enter page on postgres...
ollehar

ollehar

2021-04-20 12:30

administrator   ~64044

Last edited: 2021-04-20 13:38

View 2 revisions

If I first go to general settings, text elements and click "Browse server", then it also works in quick translation. Must be a session issue.
ollehar

ollehar

2021-04-20 14:00

administrator   ~64045

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31606
ollehar

ollehar

2021-04-20 14:01

administrator   ~64046

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31607
ollehar

ollehar

2021-04-20 14:02

administrator   ~64047

Pushed to both LS3 and LS4. Please pull and test.

Related Changesets

LimeSurvey: master 319edb74

2021-04-20 14:00:05

ollehar

Details Diff
Fixed issue 17112: Uploading files at quick translation feature using integrated editor fails with permission error Affected Issues
17112
mod - application/controllers/admin/translate.php Diff File

LimeSurvey: 3.x-LTS 698510f0

2021-04-20 14:00:05

ollehar

Details Diff
Fixed issue 17112: Uploading files at quick translation feature using integrated editor fails with permission error Affected Issues
17112
mod - application/controllers/admin/translate.php Diff File

Issue History

Date Modified Username Field Change
2021-02-18 18:45 Mazi New Issue
2021-02-18 18:45 Mazi File Added: image.png
2021-02-19 08:53 DenisChenu Note Added: 62385
2021-02-19 09:21 Mazi Note Added: 62387
2021-02-19 09:27 DenisChenu Note Added: 62388
2021-02-19 10:17 c_schmitz Assigned To => c_schmitz
2021-02-19 10:17 c_schmitz Status new => acknowledged
2021-02-19 10:17 c_schmitz Priority none => low
2021-02-19 10:17 c_schmitz Description Updated View Revisions
2021-02-19 10:17 c_schmitz Steps to Reproduce Updated View Revisions
2021-02-19 10:17 c_schmitz Additional Information Updated View Revisions
2021-02-19 11:59 ollehar Product Version => 3.25.10
2021-03-07 20:36 c_schmitz Assigned To c_schmitz =>
2021-04-19 18:14 Mazi Note Added: 64008
2021-04-19 18:16 Mazi Note Added: 64009
2021-04-19 18:17 ollehar Note Added: 64010
2021-04-19 18:17 ollehar Assigned To => ollehar
2021-04-19 18:17 ollehar Status acknowledged => assigned
2021-04-19 18:17 ollehar Priority low => normal
2021-04-19 18:18 ollehar Note Added: 64011
2021-04-20 11:47 ollehar Note Added: 64039
2021-04-20 12:30 ollehar Note Added: 64044
2021-04-20 13:38 ollehar Note Edited: 64044 View Revisions
2021-04-20 14:00 ollehar Changeset attached => LimeSurvey master 319edb74
2021-04-20 14:00 ollehar Note Added: 64045
2021-04-20 14:00 ollehar Resolution open => fixed
2021-04-20 14:01 ollehar Changeset attached => LimeSurvey 3.x-LTS 698510f0
2021-04-20 14:01 ollehar Note Added: 64046
2021-04-20 14:02 ollehar Status assigned => testing
2021-04-20 14:02 ollehar Note Added: 64047
2021-04-23 11:00 ollehar Status testing => resolved