View Issue Details

IDProjectCategoryView StatusLast Update
17111Bug reportsInstallationpublic2021-02-19 11:26
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeveritypartial_block 
Status closedResolutionunable to reproduce 
Product Version3.25.12 
Summary17111: publicurl didn't work
Description

Since years : you can use 'publicurl' => 'https://limesurvey.example.org', to force a specific url used in email and for all publci url.

You still use any URL for admin par (for example : http://192.168.0.201), test survey etc ? but all public link goes to https://limesurvey.example.org

Steps To Reproduce

On you local installation (localhost for example)
Set 'publicurl' => 'https://limesurvey.example.org',
Go to surveysummary

Additional Information

Seems broken in 3.25, work in 2.73, didn't know when it broke
Screenshot from 2.73

But i think it work during 3.X

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.25.14 github
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2021-02-18 16:23

developer  

DenisChenu

DenisChenu

2021-02-18 16:25

developer   ~62365

https://manual.limesurvey.org/Optional_settings#Advanced_path_settings

publicurl: This should be set to the URL location of your 'public scripts'. The public scripts are those located in the "limesurvey" folder (or whatever name you gave to the directory that all the other scripts and directories are kept in). This settings is available in config.php and it is used when LimeSurvey need an absolute url (for example when token emails are sent).

Remind : this is not the same than components.request.hostInfo : this one is always used.

c_schmitz

c_schmitz

2021-02-19 10:22

administrator   ~62393

Does anyone really use this?

DenisChenu

DenisChenu

2021-02-19 10:27

developer   ~62394

Sometimes it's needed !

Multiple server behind proxy,
Admin GUI disable by host etc …

Then : yes …

c_schmitz

c_schmitz

2021-02-19 10:27

administrator   ~62395

Works for me in Version 3.25.14

// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
// on your webspace.
// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
    'debug'=>2,
    'debugsql'=>0, // Set this to 1 to enanble sql logging, only active when debug = 2
    // Update default LimeSurvey config here
    'publicurl'=>'https://test.zoo/'
DenisChenu

DenisChenu

2021-02-19 10:29

developer   ~62396

Arg : https://discord.com/channels/757925259885412413/757925260476547195/811980157203906570

DenisChenu

DenisChenu

2021-02-19 10:30

developer   ~62397

https://discord.com/channels/757925259885412413/757925260476547195/811974258564792360

DenisChenu

DenisChenu

2021-02-19 11:01

developer   ~62398

OK,

Seems i have a plugin , checked on my 3LTSVanilla : no issue
@mfiora : please : deactivate your plugin one by one

DenisChenu

DenisChenu

2021-02-19 11:06

developer   ~62399

[shnoulle@poledra plugins]$ grep -r --exclude-dir=".git" "publicurl" *
arrayTextAdapt/arrayTextAdapt.php:            Yii::app()->getClientScript()->registerScriptFile(rtrim(Yii::app()->getConfig('publicurl'),"/")."/plugins/arrayTextAdapt/assets/public/arraytextadapt.js");
arrayTextAdapt/arrayTextAdapt.php:            Yii::app()->getClientScript()->registerScriptFile(rtrim(Yii::app()->getConfig('publicurl'),"/")."/plugins/arrayTextAdapt/assets/public/arraytextadapt.css");
arrayTextAdapt/arrayTextAdapt.php:            Yii::app()->clientScript->registerCssFile(rtrim(Yii::app()->getConfig('publicurl'),"/") . '/plugins/cpVille/assets/cpville.css');
arrayTextAdapt/arrayTextAdapt.php:            Yii::app()->clientScript->registerCssFile(rtrim(Yii::app()->getConfig('publicurl'),"/") . '/plugins/cpVille/assets/cpville.css'); // @todo : move it to asset too
HeartBeat/HeartBeat.php:        // Create the endpoint url, Using YII since API have issue with publicurl …
hideEmptyColumn/hideEmptyColumn.php:        //Yii::app()->getClientScript()->registerScriptFile(Yii::app()->getConfig('publicurl')."plugins/hideEmptyColumn/assets/hideemptycolumn.js",CClientScript::POS_END);
hideEmptyColumn/hideEmptyColumn.php:        //Yii::app()->getClientScript()->registerScriptFile(Yii::app()->getConfig('publicurl')."plugins/hideEmptyColumn/assets/hideemptycolumn.css");

Nothing in database too …

Really strange …

DenisChenu

DenisChenu

2021-02-19 11:14

developer   ~62400

Arg … i'm dumb …

        'publicurl' => 'https://demo.example.org',
        'ssl_disable_alert' => true,
        'memory_limit' => 512,
        'max_execution_time' => 120,
        'allowedresourcesuploads' => '7z,aiff,asf,avi,bmp,csv,doc,docx,fla,flv,gif,gz,gzip,ico,jpeg,jpg,mid,mov,mp3,mp4,mpc,mpeg,mpg,ods,odt,pdf,png,ppt,pxd,qt,ram,rar,rm,rmi,rmvb,rtf,sdc,sitd,swf,sxc,sxw,tar,tgz,tif,tiff,txt,vsd,wav,wma,wmv,xls,xlsx,xlsm,xml,zip,css,js',
        'publicurl' => "http://limesurvey.local/3LTS/",
        'deletenonvalues' => false,
c_schmitz

c_schmitz

2021-02-19 11:23

administrator   ~62401

No worries, just happens.

DenisChenu

DenisChenu

2021-02-19 11:26

developer   ~62402

See what @mfiora can answer on discord ;)

Issue History

Date Modified Username Field Change
2021-02-18 16:23 DenisChenu New Issue
2021-02-18 16:23 DenisChenu File Added: Capture d’écran du 2021-02-18 16-22-51.png
2021-02-18 16:25 DenisChenu Note Added: 62365
2021-02-19 10:22 c_schmitz Note Added: 62393
2021-02-19 10:27 DenisChenu Note Added: 62394
2021-02-19 10:27 c_schmitz Note Added: 62395
2021-02-19 10:27 c_schmitz File Added: Screenshot 2021-02-19 102700.png
2021-02-19 10:29 DenisChenu Note Added: 62396
2021-02-19 10:30 DenisChenu Note Added: 62397
2021-02-19 11:01 DenisChenu Note Added: 62398
2021-02-19 11:01 DenisChenu Assigned To => DenisChenu
2021-02-19 11:01 DenisChenu Status new => assigned
2021-02-19 11:06 DenisChenu Note Added: 62399
2021-02-19 11:14 DenisChenu Status assigned => closed
2021-02-19 11:14 DenisChenu Resolution open => unable to reproduce
2021-02-19 11:14 DenisChenu Note Added: 62400
2021-02-19 11:23 c_schmitz Note Added: 62401
2021-02-19 11:26 DenisChenu Note Added: 62402