View Issue Details

IDProjectCategoryView StatusLast Update
17106Bug reportsConditionspublic2021-02-19 17:33
Reporterzufolo441 Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionno change required 
Product Version4.4.7 
Summary17106: Unable to set "negative" dates
Description

Hi,
I have an archive of people starting from XV century, so with birth date negative, from point of view of database.
I was able to import birth dates from VV, but I cannot manually edit them.

Steps To Reproduce

Set a date before 1/1/1900

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.9
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
BrowserFirefox 85
Database & DB-VersionPostgreSQL 11.9
Server OS (if known)BSD 12.2
Webserver software & version (if known)Apache 2.4
PHP Version7.1.33

Activities

zufolo441

zufolo441

2021-02-17 16:28

reporter  

ollehar

ollehar

2021-02-17 17:00

administrator   ~62318

Can you manually edit the date (without using the picker popup)?

ollehar

ollehar

2021-02-17 17:21

administrator   ~62319

Cool that you're using BSD! Is this for university?

zufolo441

zufolo441

2021-02-17 18:04

reporter   ~62324

If I try to write it manually it will be replaced with today's date.

We are a public institute founded in 1419. When it's possible I prefer FreeBSD over Debian,because it's a bit faster especially with Tomcat

ollehar

ollehar

2021-02-17 18:08

administrator   ~62325

Got it! If you're using ComfortUpdate, please report this issue on our support tracker to get priority.

ollehar

ollehar

2021-02-17 18:21

administrator   ~62326

A work-around is to not use datetime question type, but short-text, and then validate the format of that text to be a date.

ollehar

ollehar

2021-02-18 11:23

administrator   ~62347

Dorin: It happens if the date selector is different than default. there is a question attribute that allows to change the date selector. If that one is selected, you can't go below 1900

c_schmitz

c_schmitz

2021-02-18 14:08

administrator   ~62354

Not a bug. You have to set a minimum date.
Have a look at https://manual.limesurvey.org/Question_type_-_Date#Minimum_date_.28date_min.29

zufolo441

zufolo441

2021-02-19 17:33

reporter   ~62424

Thanks, you solved my problem! But this behaviour is a bit counterintuitive.
If you like, you can have a look at statistics calculated directly from this survey table: https://superset.istitutodegliinnocenti.it/superset/dashboard/signum/?standalone=true

Issue History

Date Modified Username Field Change
2021-02-17 16:28 zufolo441 New Issue
2021-02-17 16:28 zufolo441 File Added: Screenshot_20210217_162502.png
2021-02-17 17:00 ollehar Note Added: 62318
2021-02-17 17:21 ollehar Note Added: 62319
2021-02-17 18:04 zufolo441 Note Added: 62324
2021-02-17 18:08 ollehar Note Added: 62325
2021-02-17 18:21 ollehar Note Added: 62326
2021-02-18 11:23 ollehar Note Added: 62347
2021-02-18 12:40 ollehar Assigned To => ollehar
2021-02-18 12:40 ollehar Status new => feedback
2021-02-18 14:08 c_schmitz Note Added: 62354
2021-02-18 14:08 c_schmitz Status feedback => closed
2021-02-18 14:08 c_schmitz Resolution open => no change required
2021-02-19 17:33 zufolo441 Note Added: 62424