View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
17095Bug reportsAuthenticationpublic2021-02-24 10:36
Reporterannaf Assigned ToDenisChenu  
PriorityhighSeverityminor 
Status closedResolutionfixed 
Product Version4.4.7 
Fixed in Version4.4.7 
Summary17095: After logout or save in the change password, result is Error of Class 'LimeSurvey\PluginManager\CHttpException' not found
DescriptionHello,
I get the error of Internal Server Error: 500 - lass 'LimeSurvey\PluginManager\CHttpException' not found,
after I try to logout from my user or after I try to save the changed password.
I upgrade today the version to 4.4.7.
I would appreciate help in this matter.
Thanks,
Anna
Steps To ReproduceClick on logout or click on save in the screen of change password.
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)Version 4.4.7+210215
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & version437
Server OS (if known)Windows Server 2008
Webserver software & version (if known)IS
PHP Version7.4.9

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2021-02-15 11:34

developer   ~62238

You have external plugin activated ?


I just check with webserver and AuthLDAP : no way to reproduce.
annaf

annaf

2021-02-15 11:50

reporter   ~62239

AuthLDAP is not activated.
Do I need to activate it?
annaf

annaf

2021-02-15 13:51

reporter   ~62244

I want to clarify this problem.
This issue only occurs to users with no admin privileges.
These users have permission to create surveys only. And I checked them at the use internal database authentication.
In the Plugin manager I activated all plugins excluding AuthLDAP.
Error500.png (48,238 bytes)   
Error500.png (48,238 bytes)   
User Permissions.png (150,726 bytes)
Plugin manager.png (48,376 bytes)   
Plugin manager.png (48,376 bytes)   
DenisChenu

DenisChenu

2021-02-15 14:40

developer   ~62251

I mean : did you have a ny plugin activated.

No need to activate AuthLDAP (or anything else)

Since the issue seems reatled to plugin : i think you can have an Auth plugin :)

can you check with debug mode activated ?
manual.limesurvey.org/Debug_mode
DenisChenu

DenisChenu

2021-02-15 15:10

developer   ~62253

Checked wit an user without rights , but have roles …

No way to reproduce … :((((
annaf

annaf

2021-02-15 15:25

reporter   ~62255

I found what is the plugin that is causing this error. This is AuditLog.
I turned it off. And that solved this problem.
Thank you.
c_schmitz

c_schmitz

2021-02-16 18:08

administrator   ~62299

Denis, this is caused by your change here: https://github.com/LimeSurvey/LimeSurvey/commit/aa287360a6f171009e0df44999a2da30eea71eb9#r47190978

I think it is unwise to check for permissions here. This causes that nobody can read plugin settings.

A plugin should check permissions by itself.
DenisChenu

DenisChenu

2021-02-16 18:20

developer   ~62300

https://bugs.limesurvey.org/view.php?id=16910

This function must be protected : all public function in plugin can be called without any control … by url directly …

> This causes that nobody can read plugin settings.

But : there are a permission setting for this …

The 2 functions must be private or protected , set it as public are a major issue

I revert the fix : https://bugs.limesurvey.org/view.php?id=16910#c60987

But … maybe we need to move this 2 fuicntion to protected in 5.0 ?
DenisChenu

DenisChenu

2021-02-16 19:00

developer   ~62301

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31105
lime_release_bot

lime_release_bot

2021-02-24 10:36

administrator   ~62481

Fixed in Release 4.4.9+210219

Related Changesets

LimeSurvey: master 9cbf24f2

2021-02-16 19:00:20

DenisChenu

Details Diff
Fixed issue 17095 : Error of Class 'LimeSurvey\PluginManager\CHttpException' not found
Dev: remove Permission check
Affected Issues
17095
mod - application/libraries/PluginManager/PluginBase.php Diff File

Issue History

Date Modified Username Field Change
2021-02-15 11:25 annaf New Issue
2021-02-15 11:34 DenisChenu Note Added: 62238
2021-02-15 11:50 annaf Note Added: 62239
2021-02-15 13:51 annaf Note Added: 62244
2021-02-15 13:51 annaf File Added: Error500.png
2021-02-15 13:51 annaf File Added: User Permissions.png
2021-02-15 13:51 annaf File Added: Plugin manager.png
2021-02-15 14:40 DenisChenu Note Added: 62251
2021-02-15 15:10 DenisChenu Note Added: 62253
2021-02-15 15:25 annaf Note Added: 62255
2021-02-16 17:58 c_schmitz Product Version 4.4.4 => 4.4.7
2021-02-16 18:05 c_schmitz Assigned To => DenisChenu
2021-02-16 18:05 c_schmitz Status new => assigned
2021-02-16 18:08 c_schmitz Note Added: 62299
2021-02-16 18:09 c_schmitz Priority none => high
2021-02-16 18:20 DenisChenu Note Added: 62300
2021-02-16 19:00 DenisChenu Changeset attached => LimeSurvey master 9cbf24f2
2021-02-16 19:00 DenisChenu Note Added: 62301
2021-02-16 19:00 DenisChenu Resolution open => fixed
2021-02-16 19:00 DenisChenu Status assigned => resolved
2021-02-16 19:00 DenisChenu Fixed in Version => 4.4.7
2021-02-24 10:36 lime_release_bot Note Added: 62481
2021-02-24 10:36 lime_release_bot Status resolved => closed