View Issue Details

IDProjectCategoryView StatusLast Update
17029Bug reportsSurvey editingpublic2021-02-19 11:28
Reporterjcarberry Assigned Topstelling  
PriorityhighSeveritypartial_block 
Status assignedResolutionopen 
Product Version4.4.0 
Summary17029: Slider for Multiple Numerical Input question type not displayed
Description

When a question is configured as Multiple Numerical Input and the slider is enabled, it is expected that the previewed question will display using sliders. It does not.

Steps To Reproduce
  1. Create a create of type Multiple Numerical Input
  2. Create some answers
  3. Configure to use the slider
  4. Save
  5. Preview
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.4.0-RC4+210120
I will donate to the project if issue is resolvedNo
Sync to Zoho ProjectYes
BrowserFirefox
Database & DB-VersionMySQL 5.7
Server OS (if known)?
Webserver software & version (if known)Apache
PHP Version7.4

Activities

pstelling

pstelling

2021-02-18 10:41

developer   ~62343

I tried to reproduce the bug. For me it's working as expected.
Could you please try again?
If it is still not working for you, could you please export the survey and attach it?

Maybe it's just a version conflict. In master branch (version 4.4.9) it works.

advancedsettings_slider.png (85,461 bytes)   
advancedsettings_slider.png (85,461 bytes)   
jcarberry

jcarberry

2021-02-18 11:57

reporter   ~62348

Still doesn't work. Export of survey attached. The question concerned is test1.

pstelling

pstelling

2021-02-19 09:20

developer   ~62386

Thanks for attaching the survey. I checked the survey. The problem is the following:
If you want to use the slider, you have to turn "Use slider layout" to "on" and save the question again. Afterwards please try again. The slider should be visible.

Please let us know if this helped you out.

Greetings
Patricia

turn_sliders_on.png (61,519 bytes)   
turn_sliders_on.png (61,519 bytes)   
sliders_working.png (16,079 bytes)   
sliders_working.png (16,079 bytes)   
DenisChenu

DenisChenu

2021-02-19 09:31

developer   ~62389

Surely related to this fix : https://github.com/LimeSurvey/LimeSurvey/commit/1d7b620f7dca5b79171c9c5d844cffe2254ed9dd

jcarberry

jcarberry

2021-02-19 09:47

reporter   ~62390

The problem is certainly NOT that I have forgotten to set "Use slider layout" to On. See attached screenshot. However, if restoring a survey from the export shows that the setting is Off, that means that somehow the user interface is showing "On", whereas the setting is really "Off". Maybe there is also an issue regarding https://github.com/LimeSurvey/LimeSurvey/commit/1d7b620f7dca5b79171c9c5d844cffe2254ed9dd but that seems to be an entirely separate issue.

DenisChenu

DenisChenu

2021-02-19 09:53

developer   ~62391

but that seems to be an entirely separate issue.

Not it's THE issue : Save "Y" on database, show On with Y but check 1 when do survey …

Did you try with 4.4.8 version ?

jcarberry

jcarberry

2021-02-19 11:28

reporter   ~62403

Just to be clear, the instance in which the problem occurs was never created from any export. Let me say further that the original installation was done by someone else and I have no control over what was done and what errors might have been encountered. All I know is that given the fresh install presented to me, I created the survey from scratch and the slider does not appear.

For this and other reasons, I have reverted to a stable version of LimeSurvey ( 3.25.10+210128). So, if I am the only one who has this problem in an unstable version that is already out of date, perhaps there is little point in pursuing the issue. But that's up to the maintainers.

Issue History

Date Modified Username Field Change
2021-01-29 16:24 jcarberry New Issue
2021-01-29 17:20 cdorin Priority none => high
2021-01-29 17:20 cdorin Status new => confirmed
2021-01-29 17:20 cdorin Sync to Zoho Project => Yes
2021-02-18 10:31 pstelling Assigned To => pstelling
2021-02-18 10:31 pstelling Status confirmed => assigned
2021-02-18 10:41 pstelling Note Added: 62343
2021-02-18 10:41 pstelling File Added: slider_in_preview_multipe_numeric.png
2021-02-18 10:41 pstelling File Added: advancedsettings_slider.png
2021-02-18 10:54 pstelling Status assigned => feedback
2021-02-18 11:57 jcarberry Note Added: 62348
2021-02-18 11:57 jcarberry File Added: limesurvey_survey_235541(1).lss
2021-02-18 11:57 jcarberry Status feedback => assigned
2021-02-19 09:20 pstelling Note Added: 62386
2021-02-19 09:20 pstelling File Added: turn_sliders_on.png
2021-02-19 09:20 pstelling File Added: sliders_working.png
2021-02-19 09:20 pstelling Status assigned => feedback
2021-02-19 09:31 DenisChenu Note Added: 62389
2021-02-19 09:47 jcarberry Note Added: 62390
2021-02-19 09:47 jcarberry File Added: Screenshot from 2021-02-19 09-44-17.png
2021-02-19 09:47 jcarberry Status feedback => assigned
2021-02-19 09:53 DenisChenu Note Added: 62391
2021-02-19 11:28 jcarberry Note Added: 62403