View Issue Details

This bug affects 2 person(s).
 18
IDProjectCategoryView StatusLast Update
16988Bug reportsConditionspublic2021-10-13 08:04
Reporterbocs2993 Assigned Tovharris  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.3.28 
Summary16988: Cannot Delete Questions where Conditions Existed on Deleted Questions
DescriptionI have multiple questions that have conditions on other questions. (Where Question A is dependent on Question B)

I understand that conditions need to be removed before you can delete the question, and I thought that in deleting Question B I would be doing this. However, after deleting Question B, it still throws an error when I try to delete Question A, citing the condition.

However, I now have no way to remove the condition as the question that it was on is gone. Somehow, despite Question B being deleted, its condition on Question A is still persisting in the background.

Now these questions are stuck in my survey which makes it unusable. I am going to attempt to copy the survey and see if the questions can be deleted in that version, but that sort of workaround should not be mandatory.
Steps To ReproduceCreate two Questions: Question A and Question B

Make Question B dependent on the answer to Question A

Delete Question B

Attempt to delete Question A (to no avail)
TagsNo tags attached.
Bug heat18
Complete LimeSurvey version number (& build)Version 4.3.6+200727
I will donate to the project if issue is resolvedNo
Browser
Database type & versionMySQL Version 10.3.27-MariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4.14

Users monitoring this issue

User List bocs2993, sdsAdm1n

Activities

cdorin

cdorin

2021-01-18 17:49

manager   ~61588

Could you please try the latest master and see if the issue persists?
cdorin

cdorin

2021-01-30 18:01

manager   ~61825

@vharris, could you please try and see if you can reproduce it in latest master?
DenisChenu

DenisChenu

2021-01-31 10:54

developer   ~61826

Maybe with the original lss file ?
ollehar

ollehar

2021-03-10 17:46

administrator   ~63112

Hello bocs2993,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

ollehar
sdsAdm1n

sdsAdm1n

2021-09-28 08:28

reporter   ~66628

this is to confirm I was able to reproduce the issue following same steps described above using LS version 5.1.13+210923.
Will appreciate efforts to resolve it. attached is a screen shot of the message received upon trying to delete the main question (Question A).
Even though Question B has been deleted, records for the conditions linking it with Question A are still exists in the table named "ls_conditions".
questionCondition.png (50,481 bytes)   
questionCondition.png (50,481 bytes)   

Issue History

Date Modified Username Field Change
2021-01-18 15:38 bocs2993 New Issue
2021-01-18 15:47 bocs2993 Issue Monitored: bocs2993
2021-01-18 17:49 cdorin Status new => feedback
2021-01-18 17:49 cdorin Note Added: 61588
2021-01-22 12:37 ollehar Product Version => 4.3.28
2021-01-30 18:01 cdorin Assigned To => vharris
2021-01-30 18:01 cdorin Status feedback => assigned
2021-01-30 18:01 cdorin Note Added: 61825
2021-01-30 18:07 cdorin Status assigned => feedback
2021-01-31 10:54 DenisChenu Note Added: 61826
2021-03-10 17:46 ollehar Status feedback => closed
2021-03-10 17:46 ollehar Resolution open => fixed
2021-03-10 17:46 ollehar Note Added: 63112
2021-08-04 15:01 guest Bug heat 6 => 8
2021-09-28 08:28 sdsAdm1n Note Added: 66628
2021-09-28 08:28 sdsAdm1n File Added: questionCondition.png
2021-09-28 08:28 sdsAdm1n Bug heat 8 => 10
2021-10-13 08:04 sdsAdm1n Issue Monitored: sdsAdm1n
2021-10-13 08:04 sdsAdm1n Bug heat 10 => 12
2021-10-13 08:05 sdsAdm1n Bug heat 12 => 18