View Issue Details

This bug affects 1 person(s).
 10
IDProjectCategoryView StatusLast Update
16964Bug reportsSurvey editingpublic2021-04-01 10:25
Reportershipizhan Assigned Toc_schmitz  
PrioritynoneSeverityfeature 
Status reviewResolutionunable to reproduce 
Product Version4.3.33 
Summary16964: The survey settings are very slow to save, some even more than half a minute
DescriptionSometimes, some other languages will be added to the questionnaire to facilitate the survey. After adding, only the auxiliary data table related to the language is operated, but $this - > is executed later_ The resetem () method does not quite understand why, resulting in a very slow loading speed, which is basically more than 20 seconds

If there is something wrong, please understand

Steps To Reproduce1.Create a questionnaire

2.First add 3 to 5 groups, each group adds about 5 questions, single choice or multiple choice

3.Add another language or set some questionnaire properties, and click save

4.When using fixlanguageconsistency, I think it is necessary to determine whether there is any consistency in the language
TagsNo tags attached.
Bug heat10
Complete LimeSurvey version number (& build)4.3.33
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version5.6
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

shipizhan

shipizhan

2021-01-12 03:16

reporter  

shipizhan

shipizhan

2021-01-15 03:01

reporter   ~61555

I have a questionnaire with more than 70 questions and 200 quotas. When adding other languages or not, it's very slow to click save
DenisChenu

DenisChenu

2021-01-15 10:40

developer   ~61557

> I have a questionnaire with more than 70 questions and 200 quotas. When adding other languages or not, it's very slow to click save

Can you send the lss ? Then some dev can maybe check.

If you remove quota : it's best ?
ollehar

ollehar

2021-01-15 11:27

administrator   ~61558

Is this issue still present in 4.4?
shipizhan

shipizhan

2021-01-15 12:11

reporter   ~61559

It has nothing to do with quotas and languages. It's the same thing to make quotas and other languages clear,

The file application / Controllers / Admin was detected by interface call\ database.php

1990 line method "$this - >_ resetEM();" 80% of the time
shipizhan

shipizhan

2021-01-15 12:14

reporter   ~61560

The version I'm using is 4.33. I'll follow up on 4.4
cdorin

cdorin

2021-01-28 20:23

manager   ~61783

4.4.0 released. Please let us know if the issue is solved in there :)
c_schmitz

c_schmitz

2021-03-20 09:00

administrator   ~63494

Hello shipizhan,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

c_schmitz
c_schmitz

c_schmitz

2021-03-29 14:08

administrator   ~63701

https://github.com/LimeSurvey/LimeSurvey/pull/1716/files
shipizhan

shipizhan

2021-04-01 10:25

reporter   ~63778

I looked at the code logic of 4.4, which is exactly the same as that of 4.3。 SetVariableAndTokenMappingsForExpressionManager Method is repeatedly called, each time is the whole loop of field, some do not understand;
It's rooted in use “$ this-> _ resetEM()”;

Issue History

Date Modified Username Field Change
2021-01-12 03:16 shipizhan New Issue
2021-01-12 03:16 shipizhan File Added: 企业微信截图_16104174117616.png
2021-01-12 03:16 shipizhan File Added: 企业微信截图_16104176227760.png
2021-01-15 03:01 shipizhan Note Added: 61555
2021-01-15 10:40 DenisChenu Note Added: 61557
2021-01-15 11:27 ollehar Note Added: 61558
2021-01-15 11:27 ollehar Status new => feedback
2021-01-15 12:11 shipizhan Note Added: 61559
2021-01-15 12:11 shipizhan Status feedback => new
2021-01-15 12:14 shipizhan Note Added: 61560
2021-01-28 20:23 cdorin Note Added: 61783
2021-01-28 20:23 cdorin Status new => feedback
2021-03-20 09:00 c_schmitz Assigned To => c_schmitz
2021-03-20 09:00 c_schmitz Status feedback => closed
2021-03-20 09:00 c_schmitz Resolution open => unable to reproduce
2021-03-20 09:00 c_schmitz Note Added: 63494
2021-03-29 14:08 c_schmitz Status closed => review
2021-03-29 14:08 c_schmitz Note Added: 63701
2021-04-01 10:25 shipizhan Note Added: 63778