View Issue Details

IDProjectCategoryView StatusLast Update
16962Bug reportsSurvey participants (Tokens)public2021-01-18 11:05
ReporterPPRI Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.25.6 
Summary16962: sent is not recorded when validuntil is set
Description

After an invitation email, 'sent' value is changed from 'N' to the current date/time correctly when validform and validuntil is NULL. However, if validfrom and validuntil is set, 'sent' is not being changed.

Steps To Reproduce

Send an invitation email after setting validfrom or validuntil value.

Additional Information

I tested it on 3.25.4 and 3.25.6. It is fine on 3.25.4. but the problem is happening on 3.25.6

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.25.6+201229
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
BrowserGoogle Chrome
Database & DB-VersionMS SQL 12.00.6024
Server OS (if known)Windows NT 10.0 build 14393 (Windows Server 2016) AMD64
Webserver software & version (if known)Microsoft-IIS/10.0
PHP Version7.3.11

Activities

PPRI

PPRI

2021-01-12 23:36

reporter   ~61509

It is not only 'sent' column problem. If the validfrom/validuntil is set/used, any token information is not being updated on any actions. I set the validuntil. Then, 'completed' and 'useleft' is not changed when a participant submits the survey.

DenisChenu

DenisChenu

2021-01-13 07:50

developer   ~61510

You mean via GUI, right ?

Surely due to a date format issue :), maybe there are a related report.

c_schmitz

c_schmitz

2021-01-13 10:25

administrator   ~61519

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30840

c_schmitz

c_schmitz

2021-01-13 10:25

administrator   ~61520

MSSQL always being the special child in the kindergarden.

c_schmitz

c_schmitz

2021-01-13 10:27

administrator   ~61521

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30841

lime_release_bot

lime_release_bot

2021-01-18 11:05

administrator   ~61576

Fixed in Release 3.25.8+210118

Related Changesets

LimeSurvey: 3.x-LTS f70e1c92

2021-01-13 10:25:06

c_schmitz

Details Diff
Fixed issue 16962: Sent is not recorded when validuntil is set and using MSSQL Affected Issues
16962
mod - application/models/Token.php Diff File

LimeSurvey: master 141f644e

2021-01-13 10:25:06

c_schmitz

Details Diff
Fixed issue 16962: Sent is not recorded when validuntil is set and using MSSQL Affected Issues
16962
mod - application/models/Token.php Diff File

Issue History

Date Modified Username Field Change
2021-01-08 17:00 PPRI New Issue
2021-01-12 23:36 PPRI Note Added: 61509
2021-01-13 07:50 DenisChenu Note Added: 61510
2021-01-13 09:51 c_schmitz Assigned To => c_schmitz
2021-01-13 09:51 c_schmitz Status new => assigned
2021-01-13 10:25 c_schmitz Changeset attached => LimeSurvey 3.x-LTS f70e1c92
2021-01-13 10:25 c_schmitz Note Added: 61519
2021-01-13 10:25 c_schmitz Resolution open => fixed
2021-01-13 10:25 c_schmitz Status assigned => resolved
2021-01-13 10:25 c_schmitz Note Added: 61520
2021-01-13 10:27 c_schmitz Changeset attached => LimeSurvey master 141f644e
2021-01-13 10:27 c_schmitz Note Added: 61521
2021-01-18 11:05 lime_release_bot Note Added: 61576
2021-01-18 11:05 lime_release_bot Status resolved => closed