View Issue Details

IDProjectCategoryView StatusLast Update
16814Bug reportsEncryptionpublic2021-01-14 18:55
ReporterDenisChenu Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status assignedResolutionreopened 
Product Version4.x.0-dev 
Summary16814: Default Boxes list surey goes to a 404 when update
Description

When update from master : we have «List available surveys» in boxes
When update : this was not fixed

Additional Information

Muts fix only the link, maybe user have update rights or string.

TagsNo tags attached.
Complete LimeSurvey version number (& build) 4.4.0-alpha
I will donate to the project if issue is resolved
Sync to Zoho ProjectYes
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant ?

Activities

DenisChenu

DenisChenu

2020-11-03 17:01

developer  

DenisChenu

DenisChenu

2020-11-03 17:01

developer   ~60517

Same for surveyAdministration/newSurvey

DenisChenu

DenisChenu

2020-11-03 17:04

developer   ~60518

Last edited: 2020-12-10 08:42

I have same issue with survey menu …

DB update happen, i need to reset

DenisChenu

DenisChenu

2020-11-03 17:37

developer   ~60519

Last edited: 2020-12-10 08:42

You can check when update to update default link ?

pstelling

pstelling

2020-11-04 10:20

developer   ~60532

Last edited: 2020-12-10 08:42

Some ideas (thoughts):
Info:

The boxes at first page can be customized by the user himself. If he had set some "wrong" (old) url, it should be changed by the user. Go to the "configuration->Home page settings" and change the url.

It's a huge amount of work to write a script changing all custom-edited urls and will most probably lead to even more bugs/problems.

Check if for a new installation the path is correct (because the box is a default box (as i remember)).

The "default" values (urls in table boxes) should be updated...

Solution could be:

Compare "old" urls with new urls and resett the urls

Thanks for report this bug @DenisChenu

DenisChenu

DenisChenu

2020-11-04 10:57

developer   ~60533

Last edited: 2020-12-10 08:42

It's a huge amount of work to write a script changing all custom-edited urls and will most probably lead to even more bugs/problems.

Yes, but here : i just use the default one :)

The "default" values (urls in table boxes) should be updated...

Yes : only default value with exactly the default url

Compare "old" urls with new urls and resett the urls

A clear replace in SQL maybe fort Boxes

  • admin/survey/sa/newsurvey
  • admin/survey/sa/listsurveys

For surveymenuentrie … must check … one by one https://github.com/LimeSurvey/LimeSurvey/blob/70f326fc531004d046a434b953d3040dc0f67a20/application/core/LsDefaultDataSets.php#L15-L40

gabrieljenik

gabrieljenik

2020-12-09 14:05

developer   ~60875

Last edited: 2020-12-10 08:42

We will increment the version file and add some SQL query to be run, as a minor update.
The SQL will treat the links in those boxes, if they are available with the same title and the old route

DenisChenu

DenisChenu

2020-12-09 17:18

developer   ~60886

Last edited: 2020-12-10 08:42

f they are available with the same title and the old route

Same id and old route maybe ?

Or : only route ? Plugin can not really add a new controller …

gabrieljenik

gabrieljenik

2020-12-09 21:29

developer   ~60894

Last edited: 2020-12-10 08:42

When updating from v3 to master this doesn;t happen.

This only happens if you going from develop to master.
How are we suppose to trap that situation. ideas?

cdorin

cdorin

2020-12-09 22:42

manager   ~60895

Last edited: 2020-12-10 08:42

Shouldn't be necessary to find a solution in that regard imo. We usually have 2-3 installations running at the same time, trying not to mix master with develop and vice versa.

DenisChenu

DenisChenu

2020-12-10 08:42

developer   ~60899

Last edited: 2020-12-10 08:42

When updating from v3 to master this doesn;t happen.

OK, sorry :)

Can close then .

DenisChenu

DenisChenu

2020-12-10 09:07

developer   ~60900

Sorry :

How are we suppose to trap that situation. ideas?

When someone goes from current master to 4.4.X … currently in alpah, but be fixed before last release :)

DenisChenu

DenisChenu

2020-12-10 09:08

developer   ~60901

This morning :

Git clone
Install : link in Boxed is there
Git checkout develop
Link still there

DenisChenu

DenisChenu

2020-12-10 10:39

developer   ~60908

You work on 4.4.0-alpha ?

cdorin

cdorin

2020-12-10 11:52

manager   ~60909

@DenisChenu - now working only on develop branch.
Do you have issues switching from one branch to another via the checkout command? (assuming both branches contain the "fix")

DenisChenu

DenisChenu

2020-12-10 13:55

developer   ~60910

Last edited: 2020-12-10 13:56

View 2 revisions

Do you have issues switching from one branch to another via the checkout command? (assuming both branches contain the "fix")

See 16814:60901

  1. I clone master
  2. I install on a new DB
  3. I checkout develop
  4. I go on develop admin page : old links still there

Then when user update from 4.3.30 to 4.4.0 : they have the issue :)

gabrieljenik

gabrieljenik

2020-12-10 14:43

developer   ~60911

The issue is that the link on the DB is not updated when swithcing from master to develop.
It shouldn't. I mean I couldn't reproduce it?

Are you running any install script after checkout?

DenisChenu

DenisChenu

2021-01-13 08:55

developer   ~61516

Are you running any install script after checkout?

No i install master and update to develop

The issue is that the link on the DB is not updated when swithcing from master to develop.

The default link must be updated , no ?

gabrieljenik

gabrieljenik

2021-01-14 17:35

developer   ~61544

The default link must be updated , no ?
When switching? How? Swithcing is a git operation and the link is on the DB

DenisChenu

DenisChenu

2021-01-14 17:43

developer   ~61547

Last edited: 2021-01-14 17:43

View 2 revisions

No i install master and update to develop

  1. Install 4.3
  2. Download 4.4
  3. Update your 4.3 to 4.4
DenisChenu

DenisChenu

2021-01-14 17:44

developer   ~61548

I fix the number :)

gabrieljenik

gabrieljenik

2021-01-14 18:55

developer   ~61549

OK, will review with that procedure

Issue History

Date Modified Username Field Change
2020-11-03 17:01 DenisChenu New Issue
2020-11-03 17:01 DenisChenu File Added: Capture d’écran du 2020-11-03 17-00-54.png
2020-11-03 17:01 DenisChenu Note Added: 60517
2020-11-03 17:04 DenisChenu Note Added: 60518
2020-11-03 17:04 DenisChenu File Added: Capture d’écran du 2020-11-03 17-03-15.png
2020-11-03 17:04 DenisChenu Project Development => Bug reports
2020-11-03 17:04 DenisChenu Category ComfortUpdate => Other issues
2020-11-03 17:05 DenisChenu Category Other issues => Encryption
2020-11-03 17:05 DenisChenu Product Version => 4.0.0dev
2020-11-03 17:05 DenisChenu Complete LimeSurvey version number (& build) => 4.4.0-alpha
2020-11-03 17:05 DenisChenu Browser => not relevant
2020-11-03 17:05 DenisChenu Database & DB-Version => not relevant
2020-11-03 17:05 DenisChenu Server OS (if known) => not relevant
2020-11-03 17:05 DenisChenu Webserver software & version (if known) => not relevant
2020-11-03 17:05 DenisChenu PHP Version => not relevant ?
2020-11-03 17:37 DenisChenu Assigned To => pstelling
2020-11-03 17:37 DenisChenu Status new => assigned
2020-11-03 17:37 DenisChenu Note Added: 60519
2020-11-03 18:15 DenisChenu Assigned To pstelling => cdorin
2020-11-03 19:09 cdorin Sync to Zoho Project => Yes
2020-11-04 10:20 pstelling Note Added: 60532
2020-11-04 10:57 DenisChenu Note Added: 60533
2020-12-09 14:05 gabrieljenik Note Added: 60875
2020-12-09 17:18 DenisChenu Note Added: 60886
2020-12-09 21:29 gabrieljenik Note Added: 60894
2020-12-09 22:42 cdorin Note Added: 60895
2020-12-10 08:42 DenisChenu Note Added: 60899
2020-12-10 08:42 DenisChenu Status assigned => closed
2020-12-10 08:42 DenisChenu Resolution open => no change required
2020-12-10 09:07 DenisChenu Status closed => new
2020-12-10 09:07 DenisChenu Resolution no change required => reopened
2020-12-10 09:07 DenisChenu Note Added: 60900
2020-12-10 09:08 DenisChenu Note Added: 60901
2020-12-10 10:39 DenisChenu Assigned To cdorin => gabrieljenik
2020-12-10 10:39 DenisChenu Status new => feedback
2020-12-10 10:39 DenisChenu Note Added: 60908
2020-12-10 11:52 cdorin Note Added: 60909
2020-12-10 13:55 DenisChenu Note Added: 60910
2020-12-10 13:55 DenisChenu Status feedback => assigned
2020-12-10 13:56 DenisChenu Product Version 4.0.0dev => 4.x.0-dev
2020-12-10 13:56 DenisChenu Note Edited: 60910 View Revisions
2020-12-10 14:43 gabrieljenik Note Added: 60911
2021-01-13 08:55 DenisChenu Note Added: 61516
2021-01-14 17:35 gabrieljenik Note Added: 61544
2021-01-14 17:43 DenisChenu Note Added: 61547
2021-01-14 17:43 DenisChenu Note Edited: 61547 View Revisions
2021-01-14 17:44 DenisChenu Note Added: 61548
2021-01-14 18:55 gabrieljenik Note Added: 61549