View Issue Details

IDProjectCategoryView StatusLast Update
16789Bug reportsSurvey participants (Tokens)public2020-11-04 15:48
Reportergabrieljenik Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version4.3.23 
Summary16789: Token editor mixes up invitation sent / reminder sent when manually editing token / survey participant
Description

When editing a survey participant:

  1. If "invitation sent" is set to "yes", reminder set to "no"
  2. Setting "inviation sent" to "no" but leaving reminder set to "no"
  3. Save token
  4. View token - "invitation sent" is set to "no" but "reminder sent" is set to "yes"
Steps To Reproduce

Original ticket was for LTS. This is for master

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.23
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-VersionMaria Db 10
Server OS (if known)Debian
Webserver software & version (if known)
PHP Version7.4.8

Relationships

related to 16786 closedadamzammit Token editor mixes up invitation sent / reminder sent when manually editing token / survey participant 

Activities

gabrieljenik

gabrieljenik

2020-11-03 16:12

developer   ~60515

Non reproducible on master

adamzammit

adamzammit

2020-11-04 05:17

developer   ~60525

Was fixed here: https://github.com/LimeSurvey/LimeSurvey/commit/70507e27f6d1886bb50d52d3833284450639c684

Adam

DenisChenu

DenisChenu

2020-11-04 08:18

developer   ~60527

@adamzammit seem you have a dev account : maybe you can set it as fixed ?

gabrieljenik

gabrieljenik

2020-11-04 15:04

developer   ~60535

Original ticket was for LTS (16786). This is for master, where is not reproducible.

Issue History

Date Modified Username Field Change
2020-10-26 13:53 gabrieljenik New Issue
2020-10-26 13:53 gabrieljenik Status new => assigned
2020-10-26 13:53 gabrieljenik Assigned To => gabrieljenik
2020-10-26 13:53 gabrieljenik Issue generated from: 16786
2020-10-26 13:53 gabrieljenik Relationship added related to 16786
2020-10-26 13:54 gabrieljenik Steps to Reproduce Updated View Revisions
2020-11-03 16:12 gabrieljenik Note Added: 60515
2020-11-04 05:17 adamzammit Note Added: 60525
2020-11-04 08:18 DenisChenu Note Added: 60527
2020-11-04 15:04 gabrieljenik Note Added: 60535
2020-11-04 15:48 DenisChenu Status assigned => closed
2020-11-04 15:48 DenisChenu Resolution open => unable to reproduce