View Issue Details

IDProjectCategoryView StatusLast Update
16646Bug reportsTheme editorpublic2020-09-09 22:56
Reportergabrieljenik Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.23.3 
Target Version3.22.13 
Summary16646: Why does that CSS class get added at the one template but not at the other
Description

Question for the experts related to array filter: At https://ls3temp.my-survey.host/index.php/616365?newtest=Y&lang=en you see the question 2 container show up. At a copy with theme=vanilla the second question doesn't show up because "ls-hidden" got added to the question container.

Why does that CSS class get added at the one template but not at the other?
I couldn't find out where the difference is.

Not sure if that was introduced with this commit?
https://github.com/LimeSurvey/LimeSurvey/commit/57161904f271d7cbe3b53f346e651cfb1cecce71

Just a question why https://ls3temp.my-survey.host/index.php/616365?newtest=Y&lang=en looks different to https://ls3temp.my-survey.host/index.php/564148?newtest=Y&lang=en on page call.

Second question is hidden at the later link which is the intended behavior and caused by CSS class ls-hidden. But that doesn't get added at the other survey.
Question: Why...?

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.22.13
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql
Server OS (if known)
Webserver software & version (if known)
PHP Version7

Activities

Mazi

Mazi

2020-09-09 22:56

partner   ~59759

This one can be closed. It was related to the custom theme being based on an old version of vanilla which was missing this fix:
https://github.com/LimeSurvey/LimeSurvey/commit/d094d3e03fffa34cd5a095684619653b965a6253#diff-19d4681de23d55b0d46c92e4bc368e78R127

Issue History

Date Modified Username Field Change
2020-09-09 00:01 gabrieljenik New Issue
2020-09-09 00:01 gabrieljenik Status new => assigned
2020-09-09 00:01 gabrieljenik Assigned To => gabrieljenik
2020-09-09 18:36 gabrieljenik Status assigned => closed
2020-09-09 18:36 gabrieljenik Resolution open => fixed
2020-09-09 22:56 Mazi Note Added: 59759