View Issue Details

IDProjectCategoryView StatusLast Update
16503Bug reportsSurvey editingpublic2020-12-29 19:03
Reportertailcalled Assigned Tocdorin  
PrioritynormalSeverityblock 
Status closedResolutionfixed 
Product Version4.3.4 
Fixed in Version4.4.0-RC1 
Summary16503: Indefinitely loading question
DescriptionI have a survey containing a number of questions, but when I open them up to inspect them or edit them, they tend to get stuck loading indefinitely. Each individual question seems relatively consistent about which sections fail to load (whether it is the Subquestions/Display/etc section, or also the General settings section, or just the entire question.)
Steps To ReproduceI don't know.
Additional InformationI was originally on an older version of limesurvey, but tried to fix the problem by buying an update key and updating.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.3.4+200713
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome
Database & DB-Version427, MySQL I think? Can't find the place to check it
Server OS (if known)Debian I think
Webserver software & version (if known)NGinx
PHP Version7.3.14

Activities

tailcalled

tailcalled

2020-07-17 16:19

reporter  

problem.png (39,863 bytes)   
problem.png (39,863 bytes)   
tailcalled

tailcalled

2020-07-17 16:22

reporter   ~58990

I guess I should add, there have also been some other issues, including problems with saving changes to survey questions, problems with adding new response options, etc.. I don't know if these less-blocking problems have anything to do with this bigger one.

user225042

2020-07-17 16:22

  ~58991

For us to be able to investigate this issue please attach question sample survey demonstrating the issue, either as .lss file (survey structure) or (even better) as .lsa file (survey archive).

Just attach it to this issue, and we will have a look.
Thank you!
tailcalled

tailcalled

2020-07-17 16:38

reporter   ~58992

Here you go.
ollehar

ollehar

2020-07-17 17:14

administrator   ~58993

Can you please click F12 in the browser and give us a screenshot of any errors shown in the JavaScript console? Thank you.
tailcalled

tailcalled

2020-07-17 17:24

reporter   ~58994

Here you go.
console.png (61,054 bytes)   
console.png (61,054 bytes)   
tailcalled

tailcalled

2020-07-17 17:31

reporter   ~58995

It's apparently fixed if I clear the local storage. So I guess the problem is that LimeSurvey eventually exceeded the local storage limit and didn't reduce it? Either way this is no longer a blocking problem for me as I have just cleared the local storage.
tailcalled

tailcalled

2020-07-17 17:36

reporter   ~58996

I get this error when I open another question, I don't know if this is the reason it doesn't reduce its local storage use.
error.png (64,324 bytes)   
error.png (64,324 bytes)   
cdorin

cdorin

2020-12-29 19:03

manager   ~61305

Fixed in 4.4 RC1

Issue History

Date Modified Username Field Change
2020-07-17 16:19 tailcalled New Issue
2020-07-17 16:19 tailcalled File Added: problem.png
2020-07-17 16:22 tailcalled Note Added: 58990
2020-07-17 16:22 user225042 Note Added: 58991
2020-07-17 16:38 tailcalled Note Added: 58992
2020-07-17 16:38 tailcalled File Added: limesurvey_survey_429471.lss
2020-07-17 17:14 ollehar Note Added: 58993
2020-07-17 17:24 tailcalled Note Added: 58994
2020-07-17 17:24 tailcalled File Added: console.png
2020-07-17 17:31 tailcalled Note Added: 58995
2020-07-17 17:33 ollehar Priority none => normal
2020-07-17 17:33 ollehar Status new => confirmed
2020-07-17 17:36 tailcalled Note Added: 58996
2020-07-17 17:36 tailcalled File Added: error.png
2020-12-29 19:03 cdorin Assigned To => cdorin
2020-12-29 19:03 cdorin Status confirmed => closed
2020-12-29 19:03 cdorin Resolution open => fixed
2020-12-29 19:03 cdorin Fixed in Version => 4.4.0-RC1
2020-12-29 19:03 cdorin Note Added: 61305