View Issue Details

IDProjectCategoryView StatusLast Update
16475Bug reportsQuestion editorpublic2020-07-31 19:00
Reporterrjohnson84 Assigned To 
Status newResolutionopen 
Product Version4.3.0 
Summary16475: Answer Option Disappearing

Answer Options seem to disappear from survey when using the question editor. . Survey was imported with no errors from 2.58. The responses still show up in answer options but they are not on the survey itself.

Steps To Reproduce

Choose a question from a survey using the structure tab
Click Question Editor
Click Save
An orange-ish box (background-color: #be6665) Appears with no text and goes away
Viewing the question / question group will show that all but the first response is now missing however it still appears in the Answer options tab.

Additional Information

Even occurs when I re-input the response options. Changing any setting for a question or just clicking save in the editor seems to break it.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.0 | 200616
I will donate to the project if issue is resolvedNo
Database & DB-Versionpgsql - Database driver version 9.2.24 | Database server version 11.5
Server OS (if known)Linux Amazon
Webserver software & version (if known) Apache/2.4.41
PHP Version7.4.3




2020-07-08 21:07


OrangeBox.PNG (18,494 bytes)   
OrangeBox.PNG (18,494 bytes)   
Step1.PNG (16,902 bytes)   
Step1.PNG (16,902 bytes)   
Step2.PNG (16,991 bytes)   
Step2.PNG (16,991 bytes)   


2020-07-08 21:09

reporter   ~58813

MissingResponses.PNG (56,188 bytes)   
MissingResponses.PNG (56,188 bytes)   


2020-07-08 21:20

reporter   ~58814

Debug mode provides the following error in the otherwise empty oranage box.

Question has been stored, but an error happened: Answer option couldn't be saved. Error: Array ( [code] => Array ( [0] => Answer codes must be unique by question ) ) (/home/websurvey/limesurvey/application/controllers/QuestionEditorController.php:339)

#0 /home/websurvey/limesurvey/framework/base/CErrorHandler.php(131): CErrorHandler->handleException()
#1 /home/websurvey/limesurvey/framework/base/CApplication.php(750): CErrorHandler->handle()
#2 unknown(0): LSYii_Application->handleException()



2020-07-09 17:05

manager   ~58874

Hey, and thank you for your report.

Please update first to the latest release.

Second, could you please attach an .lss file? I think it's related to a specific question attribute but must double check if that is the case. A couple of weeks ago it was bcs of random_order



2020-07-10 17:42

reporter   ~58902

Updated to current version still exhibits same behavior. I have seen this since we first updated to 4 earlier this year. Attached lss of a few questions. You can see in the admin panel that there are responses however viewing the survey they are not there.



2020-07-17 15:00

manager   ~58986

I tried importing the survey and it worked for me there was no issue at all.
Please refer the screenshot for more details.

I was getting the same issue a few days ago but now I feel its fixed. Can you please confirm on this



2020-07-17 15:17

reporter   ~58987

Are you using postgres or mysql when testing this. I updated this morning to 4.3.4+200713 and still have the same behavior.

The answer code and options i attempted were. Does assessment value have to be unique?

01 - None
02 - some
03 - all

PHP Error [500]

Question has been stored, but an error happened: Answer option couldn't be saved. Error: Array ( [code] => Array ( [0] => Answer codes must be unique by question ) ) (/home/websurvey/limesurvey/application/controllers/QuestionEditorController.php:346)

#0 /home/websurvey/limesurvey/framework/base/CErrorHandler.php(131): CErrorHandler->handleException()
#1 /home/websurvey/limesurvey/framework/base/CApplication.php(750): CErrorHandler->handle()
#2 unknown(0): LSYii_Application->handleException()



2020-07-17 15:20

manager   ~58988

I use mysql. Ok let me try once more with these values
Thanks for the information.



2020-07-27 19:01

reporter   ~59107

Have there been any updates or movement on this issue? I am still experiencing the same behavior.



2020-07-30 18:22

reporter   ~59226

This still occurs on the latest release. Have you been able to replicate?



2020-07-30 18:35

manager   ~59227

Last edited: 2020-07-30 18:36

View 2 revisions

Perhaps related to 16550 - do you have conditions in there? Can you please send us an .lss file where the issue exists? Could also be a question attribute



2020-07-31 19:00

reporter   ~59239

Changing to MySQL database seems to have fixed any issues I have been having. Please check Postgres compatibility with Version 4.

Issue History

Date Modified Username Field Change
2020-07-08 21:07 rjohnson84 New Issue
2020-07-08 21:07 rjohnson84 File Added: MissingResponses.PNG
2020-07-08 21:07 rjohnson84 File Added: OrangeBox.PNG
2020-07-08 21:07 rjohnson84 File Added: Step1.PNG
2020-07-08 21:07 rjohnson84 File Added: Step2.PNG
2020-07-08 21:08 rjohnson84 File Deleted: MissingResponses.PNG
2020-07-08 21:09 rjohnson84 Note Added: 58813
2020-07-08 21:09 rjohnson84 File Added: MissingResponses.PNG
2020-07-08 21:20 rjohnson84 Note Added: 58814
2020-07-09 17:05 cdorin Status new => feedback
2020-07-09 17:05 cdorin Note Added: 58874
2020-07-10 17:42 rjohnson84 Note Added: 58902
2020-07-10 17:42 rjohnson84 File Added: limesurvey_survey_579721.lss
2020-07-10 17:42 rjohnson84 Status feedback => new
2020-07-17 15:00 sushmanadendla Note Added: 58986
2020-07-17 15:00 sushmanadendla File Added: 16475_Savedsuccessfully.png
2020-07-17 15:17 rjohnson84 Note Added: 58987
2020-07-17 15:20 sushmanadendla Note Added: 58988
2020-07-27 19:01 rjohnson84 Note Added: 59107
2020-07-30 18:22 rjohnson84 Note Added: 59226
2020-07-30 18:35 cdorin Note Added: 59227
2020-07-30 18:36 cdorin Note Edited: 59227 View Revisions
2020-07-31 19:00 rjohnson84 Note Added: 59239