View Issue Details

IDProjectCategoryView StatusLast Update
16444Bug reportsSurvey takingpublic2020-07-17 08:10
Reporterjucajuca Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionno change required 
Product Version3.22.23 
Summary16444: edge does not post all answers
Description

I am developing a survey and I tried it already in Chrome and Firefox and midory. In all browsers the POST request it is working good.

BUT:

in edge (and IE) the POST request only contains the answer to some of the answers. The survey will report that not every mandatory questions were answered and it will delete the answer to most of the questions. See the POST body and request in Additional Information

Steps To Reproduce

create a survey with more mandatory questions, test it in edge

Additional Information

https://pastebin.com/1BUCYPWB

/ Request Headers /

Accept: text/html, application/xhtml+xml, application/xml; q=0.9, /; q=0.8
Accept-Encoding: gzip, deflate, br
Accept-Language: en-GB, en; q=0.5
Cache-Control: max-age=0
Content-Length: 969
Content-Type: application/x-www-form-urlencoded
Cookie: __cfduid=d9f98bd4a0d516d9c48a7f598bf73efa11593528116; _pk_id.8.0422=fb0f1aa9744b1e31.1593528125.4.1593598569.1593598569.; _pk_ses.8.0422=1; PHPSESSID=otp0dcpi29m703lhqr3r2omkh3; YII_CSRF_TOKEN=MUlXMW91d2FXbjd6RTB4U0hVMVRSTGJkS3cwTGFMaDRbpBke4YWiPB70ndrJIys5kIPzE44k-mI_15E0-TVVLQ%3D%3D
Host: xxx.xxx.xxx
Referer: https://xxx.xxx.xxx/index.php/825553?newtest=Y&lang=de-informal
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.19041

/ request body /

825553X55X825: A3
825553X55X844: 0
825553X55X846: 0
ajax: off
fieldnames: 825553X55X837%7C825553X55X838%7C825553X55X908%7C825553X55X893%7C825553X55X848%7C825553X55X898%7C825553X55X823%7C825553X55X897%7C825553X55X835%7C825553X55X910%7C825553X55X895%7C825553X55X901%7C825553X55X907%7C825553X55X909%7C825553X55X902%7C825553X55X896%7C825553X55X894%7C825553X55X903%7C825553X55X824%7C825553X55X825%7C825553X55X844%7C825553X55X846
lastgroup: 825553X55
LEMpostKey: 247157811
move: movenext
relevance823: 1
relevance824: 1
relevance825: 1
relevance835: 1
relevance837: 1
relevance838: 1
relevance844: 1
relevance846: 1
relevance848: 1
relevance893: 1
relevance894: 1
relevance895: 1
relevance896: 1
relevance897: 1
relevance898: 1
relevance901: 1
relevance902: 1
relevance903: 1
relevance907: 1
relevance908: 1
relevance909: 1
relevance910: 1
relevanceG0: 1
sid: 825553
start_time: 1593594961
thisstep: 1
YII_CSRF_TOKEN: MUlXMW91d2FXbjd6RTB4U0hVMVRSTGJkS3cwTGFMaDRbpBke4YWiPB70ndrJIys5kIPzE44k-mI_15E0-TVVLQ%3D%3D

TagsNo tags attached.
Complete LimeSurvey version number (& build) LimeSurvey Version 3.22.23
I will donate to the project if issue is resolvedNo
BrowserEdge 44 EdgeHTML 18
Database & DB-VersionServer version: 10.1.37-MariaDB-0+deb9u1 - Debian 9.6
Server OS (if known)
Webserver software & version (if known)
PHP VersionPHP 5.5.9-1ubuntu4.29 (cli) (built: Apr 22 2019 18:33:52)

Activities

DenisChenu

DenisChenu

2020-07-01 14:48

developer   ~58615

Browser issue ?

create a survey with more mandatory questions, test it in edge

How many mandatory question ?

jucajuca

jucajuca

2020-07-01 17:32

reporter   ~58623

It happened already in two different machines only with IE explorer or Edge. I mean nobody really needs IE but Edge will likely be used by a whole bunch of people that are forced to use it.

The problem is that the answers to the questions are not uploaded correctly. The survey that I am working with has over 15 questions and as you can see the POST request only sends a max of 3 (but I think it sends only one)

This bit should be way longer:

825553X55X825: A3
825553X55X844: 0
825553X55X846: 0

DenisChenu

DenisChenu

2020-07-02 10:06

developer   ~58636

Checked with vanilla and Microsoft Edge 44.17763.1.0 + Microsoft EdgeHTML 18.17763

Surely a theme issue : please test with Vanilla template

cdorin

cdorin

2020-07-06 11:53

manager   ~58691

The support for old Edge will drop as far as I remember - or am I wrong ? No need to fix it imo.

DenisChenu

DenisChenu

2020-07-06 12:52

developer   ~58697

Edge 44 EdgeHTML 18 is the current version, not old.

And support for IE are always for public part (and older if we can).

Here it's Survey taking (if inundersta,d right) not Survey editing (admin)

cdorin

cdorin

2020-07-06 13:10

manager   ~58702

Windows is pushing for Chromium Edge. Current stable version on Windows is 83.0.478.58 as far as i can see: https://en.wikipedia.org/wiki/Microsoft_Edge (edge 44 is the latest non-chromium version).

For IE ,yes, it still needs to be supported for survey-taking.

jucajuca

jucajuca

2020-07-16 15:41

reporter   ~58976

@dennisChenu was right, it was a theme issue. I disabled the fields after the user provided input to avoid them changing their answers. IE / Edge did not submit the disabled fields.
bug can be closed

DenisChenu

DenisChenu

2020-07-17 08:09

developer   ~58982

IE / Edge did not submit the disabled fields.

Firefox and Chrome didn't submit disabled field too …

DenisChenu

DenisChenu

2020-07-17 08:10

developer   ~58983

Not a bug

Issue History

Date Modified Username Field Change
2020-07-01 11:46 jucajuca New Issue
2020-07-01 14:48 DenisChenu Note Added: 58615
2020-07-01 17:32 jucajuca Note Added: 58623
2020-07-01 17:32 jucajuca File Added: limesurvey_survey_825553.lss
2020-07-02 10:06 DenisChenu Note Added: 58636
2020-07-06 11:53 cdorin Note Added: 58691
2020-07-06 12:52 DenisChenu Note Added: 58697
2020-07-06 12:52 DenisChenu Severity partial_block => minor
2020-07-06 12:52 DenisChenu Reproducibility have not tried => unable to reproduce
2020-07-06 12:52 DenisChenu Category _ Unknown => Survey taking
2020-07-06 13:10 cdorin Note Added: 58702
2020-07-16 15:41 jucajuca Note Added: 58976
2020-07-17 08:09 DenisChenu Note Added: 58982
2020-07-17 08:10 DenisChenu Assigned To => DenisChenu
2020-07-17 08:10 DenisChenu Status new => closed
2020-07-17 08:10 DenisChenu Resolution open => no change required
2020-07-17 08:10 DenisChenu Note Added: 58983