View Issue Details

IDProjectCategoryView StatusLast Update
16415Bug reportsOtherpublic2020-06-26 13:23
Reportercriugmls Assigned To 
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version3.22.19 
Summary16415: can't upload files with Google Chrome
Description

Version 3.22.18+200603

Upload with Chrome was fixed in 3.22.18
But the problem is coming back.

Can upload with Edge or Firefox, but not with Google Chrome.

Chrome : Version 83.0.4103.116 (Build officiel) (64 bits)

Steps To Reproduce

You can test it here :
https://limesurvey.criugm.qc.ca/index.php/356217

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.22.18+200603
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql Ver 14.14 Distrib 5.7.30, for Linux (x86_64)
Server OS (if known) Ubuntu 16.04.6 LTS
Webserver software & version (if known)
PHP VersionPHP Version 7.0.33-0ubuntu0.16.04.14

Relationships

related to 16395 confirmed file upload crash randomly 
related to 16346 assignedp_teichmann File Upload modal not working correctly in Chromium 83.0.x (LS3) 

Activities

criugmls

criugmls

2020-06-22 19:29

reporter  

upload.png (30,924 bytes)   
upload.png (30,924 bytes)   
criugmls

criugmls

2020-06-22 20:08

reporter   ~58382

I just tested it with Chrome Version 83.0.4103.97 (build official) (64 bits) amn it worked.

I updated Chrome on the same machine to 83.0.4103.116 (official build) (64 bits) and it stopped working.

So, I presume Google Chrome 83.0.4103.116 is the trouble maker.

criugmls

criugmls

2020-06-22 21:10

reporter   ~58383

Last edited: 2020-06-23 12:04

Seem to work one time, then it stop working.
I made this test form, I was able to upload a file at first attempt, but not working second and third try.
https://limesurvey.criugm.qc.ca/index.php/662578?lang=fr

cdorin

cdorin

2020-06-22 23:06

manager   ~58386

Last edited: 2020-06-23 12:04

View 2 revisions

Do not have any issues - cannot reproduce (played with your installation)

I will ask my colleagues for further testing.

LE: Meanwhile, can you please upgrade to the latest LTS release and try again?

criugmls

criugmls

2020-06-22 23:18

reporter   ~58387

Last edited: 2020-06-23 12:04

I will update to limesurvey3.22.21+200622 tonight, and let you know.

I can easily reproduce the error:
Windows 10
Update your Chrome Browser to the latest Version 83.0.4103.116 and restart Chrome
Open : https://limesurvey.criugm.qc.ca/index.php/662578?lang=fr
Try upload any pdf file.
Sometimes it work the first time, but not on the second or third attempt.

cdorin

cdorin

2020-06-22 23:25

manager   ~58388

Last edited: 2020-06-23 12:04

Ok, so I cannot reproduce it on the latest Chrome (83.0.4103.116) - I use Ubuntu 20.04.
Will wait for one of my Windows colleagues to check the issue.
The ticket is marked as private -> can i take the "private" status out?

criugmls

criugmls

2020-06-22 23:27

reporter   ~58389

Last edited: 2020-06-23 12:04

Yes, you take the "private" status out.
tx

criugmls

criugmls

2020-06-22 23:48

reporter   ~58391

Last edited: 2020-06-23 12:04

I cannot reproduce the problem either on ubuntu 18 (Chrome 83.0.4103.116).
But I have the same problem on Android 9 (Chrome 83.0.4103.106).
It works well on Firefox (Windows, Ubuntu and Android).

criugmls

criugmls

2020-06-23 04:51

reporter   ~58392

Last edited: 2020-06-23 12:04

I just updated to LimeSurvey Version 3.22.21+200622
Problem is still present.

sushmanadendla

sushmanadendla

2020-06-23 10:26

manager   ~58394

Last edited: 2020-06-23 12:04

Tested the issue on the latest chrome (Version 83.0.4103.116 (Official Build) (64-bit)), i am not able to upload the file anyways.
Please refer the attachement for more details

FIleUpload_Notworking.gif (1,202,990 bytes)
DenisChenu

DenisChenu

2020-06-23 11:16

developer   ~58395

Last edited: 2020-06-23 12:04

Related ?
https://bugs.limesurvey.org/view.php?id=16395

DenisChenu

DenisChenu

2020-06-23 11:17

developer   ~58396

Last edited: 2020-06-23 12:04

Sometimes it work the first time, but not on the second or third attempt.

https://bugs.limesurvey.org/view.php?id=16395#c58366

sushmanadendla

sushmanadendla

2020-06-23 12:04

manager   ~58398

Last edited: 2020-06-23 12:04

Issue moved to confirmed

DenisChenu

DenisChenu

2020-06-23 13:32

developer   ~58401

For information :
Fedora/Linux
Version 83.0.4103.116 (Build officiel) (64 bits)

It's OK.

Related to operating system.

gabrieljenik

gabrieljenik

2020-06-23 21:12

partner   ~58418

From what I was able to see (and understand), the issue happens because of some false positive load events of the iframe.
I mean some load events are triggered for the iframe (example for the about:blank doc) while they should be ignored.

There are already some filters, so I am adding a new one.

https://github.com/LimeSurvey/LimeSurvey/pull/1445

gabrieljenik

gabrieljenik

2020-06-23 21:29

partner   ~58419

We could be checking the src of the iframe as an extra filtering layer.

DenisChenu

DenisChenu

2020-06-24 07:04

developer   ~58422

Last edited: 2020-06-24 07:07

View 2 revisions

We could be checking the src of the iframe as an extra filtering layer.

We must move to something without iframe ;) : https://bugs.limesurvey.org/view.php?id=14664

But take more time.

And : use jquery ajax too, not own functionnality … real XHR …

criugmls

criugmls

2020-06-24 18:23

reporter   ~58428

@gabrieljenik
The fix proposed break the upload on all browser.
https://forums.limesurvey.org/forum/can-i-do-this-with-limesurvey/121410-upload-turn-blank-with-google-chrome?start=15#201825

criugmls

criugmls

2020-06-24 19:20

reporter   ~58429

Commenting this line make it work again.
// iframe.setAttribute('srcdoc', this._settings.action);

DenisChenu

DenisChenu

2020-06-24 19:21

developer   ~58430

Last edited: 2020-06-24 19:21

View 2 revisions

iframe.setAttribute('srcdoc', this._settings.action); == $(iframe).attr('src',this._settings.action) ?

criugmls

criugmls

2020-06-24 19:25

reporter   ~58431

I just followed the gabrieljenik github fix.
https://github.com/LimeSurvey/LimeSurvey/pull/1445
I cannot argue about what this code does.

gabrieljenik

gabrieljenik

2020-06-25 13:27

partner   ~58451

Hi All,

That was a WIP which still needed testing.
It worked for me and as it was late and urgent, I sent it for testing.

I see that fix wasn't good enough and then suggested rolling back and removing the srcdoc line.
I want to review the prior upload file bug as to see why that line was introduced.

cdorin

cdorin

2020-06-25 13:52

manager   ~58452

Sure, gabriel. Thanks for help! :)

If you need help with testing, can jump in anytime.

criugmls

criugmls

2020-06-25 15:17

reporter   ~58457

This modification in on my server since yesterday (commenting the srcdoc line).
The upload works again. TX!

If you need help for further testing, let me know.

gabrieljenik

gabrieljenik

2020-06-25 17:31

partner   ~58486

OK, this could be a possible explanation for what happened:
https://stackoverflow.com/questions/62022757/ajaxfileupload-is-not-woking-in-latest-version-of-chrome-version-83-0-4103-61/62183097#62183097

From my understanding:
0 - LS upload is working
1 - Chrom applied a fix
2 - LS got broken, as well as many platforms using ajax upload mechanisms (I have read Drupla got the hit too).
3 - LS applies a fix.
4 - Chrome rollsback part of the fix or applies a new one (irrelevant).
Now, the code at "3" doesn't work and code status at "0" works
5 - We rollback to "0" status

sushmanadendla

sushmanadendla

2020-06-25 18:03

manager   ~58489

Last edited: 2020-06-25 18:09

View 2 revisions

I tested by going back to Release 3.22.17+200525(Step 0 in above comment), i was able to successfully do the file upload and than i checked out to latest PR(Step 5 in above comment) and tested seems to work fine there as well.
Please refer the attachment for more details.
@criugmls : Can you also check with the latest PR once
Thank You

DenisChenu

DenisChenu

2020-06-25 18:12

developer   ~58493

I tested by going back to Release 3.22.17+200525(Step 0 in above comment), i was able to successfully do the file

Then the issue are added between 22.17 and current ?

Because we add a workaround for a chrome bug ?

sushmanadendla

sushmanadendla

2020-06-25 18:17

manager   ~58496

Yes, it seems so

criugmls

criugmls

2020-06-25 18:59

reporter   ~58500

@sushmanadendla ,Im sorry but what is "the latest PR"?

cdorin

cdorin

2020-06-25 21:58

manager   ~58502

Hey @criugmls - please see: https://github.com/LimeSurvey/LimeSurvey/pull/1445 . Gabriel deleted the fix provided some time ago by Patrick. Have time to test it? If everything ok, we will release LTS tomorrow once again.

criugmls

criugmls

2020-06-25 22:16

reporter   ~58505

I commented the line yesterday. No problem since.
// iframe.setAttribute('srcdoc', this._settings.action);

I just deleted it completly today and the upload question is still OK.
Thanks a lot! You are a great team!

You can test it here:
https://limesurvey.criugm.qc.ca/index.php/662578?lang=fr

cdorin

cdorin

2020-06-25 22:16

manager   ~58506

Last edited: 2020-06-25 22:17

View 2 revisions

great, then a new release will come tmrw. Thanks for quick update. (saw too late which lines were commented out, basically those were deleted)

guest

guest

2020-06-26 12:23

viewer   ~58521

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30220

lime_release_bot

lime_release_bot

2020-06-26 13:23

administrator   ~58522

Fixed in Release 3.22.23+200626

Related Changesets

LimeSurvey: 3.x-LTS b8ff095f

2020-06-26 12:23:39

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16415: Can't upload files with Google Chrome (#1445) Affected Issues
16415
mod - assets/scripts/ajaxupload.js Diff File

Issue History

Date Modified Username Field Change
2020-06-22 19:29 criugmls New Issue
2020-06-22 19:29 criugmls File Added: upload.png
2020-06-22 20:08 criugmls Note Added: 58382
2020-06-22 21:10 criugmls Note Added: 58383
2020-06-22 23:06 cdorin Note Added: 58386
2020-06-22 23:08 cdorin Note Edited: 58386 View Revisions
2020-06-22 23:18 criugmls Note Added: 58387
2020-06-22 23:25 cdorin Note Added: 58388
2020-06-22 23:27 criugmls Note Added: 58389
2020-06-22 23:35 cdorin View Status private => public
2020-06-22 23:35 cdorin Description Updated View Revisions
2020-06-22 23:35 cdorin Steps to Reproduce Updated View Revisions
2020-06-22 23:48 criugmls Note Added: 58391
2020-06-23 04:51 criugmls Note Added: 58392
2020-06-23 10:26 sushmanadendla Note Added: 58394
2020-06-23 10:26 sushmanadendla File Added: FIleUpload_Notworking.gif
2020-06-23 11:16 DenisChenu Note Added: 58395
2020-06-23 11:17 DenisChenu Note Added: 58396
2020-06-23 11:18 DenisChenu Relationship added related to 16395
2020-06-23 12:04 sushmanadendla Reproducibility have not tried => always
2020-06-23 12:04 sushmanadendla Status new => confirmed
2020-06-23 12:04 sushmanadendla Note Added: 58398
2020-06-23 13:32 DenisChenu Note Added: 58401
2020-06-23 13:32 DenisChenu File Added: Capture d’écran du 2020-06-23 13-31-04.png
2020-06-23 21:12 gabrieljenik Note Added: 58418
2020-06-23 21:29 gabrieljenik Note Added: 58419
2020-06-24 07:04 DenisChenu Note Added: 58422
2020-06-24 07:07 DenisChenu Note Edited: 58422 View Revisions
2020-06-24 18:23 criugmls Note Added: 58428
2020-06-24 19:20 criugmls Note Added: 58429
2020-06-24 19:21 DenisChenu Note Added: 58430
2020-06-24 19:21 DenisChenu Note Edited: 58430 View Revisions
2020-06-24 19:25 criugmls Note Added: 58431
2020-06-25 13:27 gabrieljenik Note Added: 58451
2020-06-25 13:52 cdorin Note Added: 58452
2020-06-25 15:17 criugmls Note Added: 58457
2020-06-25 17:27 gabrieljenik Relationship added related to 16346
2020-06-25 17:31 gabrieljenik Note Added: 58486
2020-06-25 18:03 sushmanadendla Note Added: 58489
2020-06-25 18:03 sushmanadendla File Added: 16415_FileUpload_LTS3X.png
2020-06-25 18:09 sushmanadendla Note Edited: 58489 View Revisions
2020-06-25 18:12 DenisChenu Note Added: 58493
2020-06-25 18:17 sushmanadendla Note Added: 58496
2020-06-25 18:59 criugmls Note Added: 58500
2020-06-25 21:58 cdorin Note Added: 58502
2020-06-25 22:16 criugmls Note Added: 58505
2020-06-25 22:16 cdorin Note Added: 58506
2020-06-25 22:17 cdorin Note Edited: 58506 View Revisions
2020-06-26 12:23 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS b8ff095f
2020-06-26 12:23 guest Note Added: 58521
2020-06-26 13:23 lime_release_bot Note Added: 58522
2020-06-26 13:23 lime_release_bot Status confirmed => closed
2020-06-26 13:23 lime_release_bot Resolution open => fixed