View Issue Details

IDProjectCategoryView StatusLast Update
16379Bug reportsUser / Groups / Rolespublic2020-07-06 13:21
Reporteruser225042Assigned To 
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.2.8 
Summary16379: When debug mode is set , there is an error message displayed on clicking on User Roles Page
Description

Error Message is displayed on clicking on save in edit permissions popup from user roles page
When debug mode is set , there is an error message displayed on clicking on User Roles Page

Steps To Reproduce

Steps to reproduce:
1.Login as admin.
2.Click on Configuration from the top menu.
3.Navigate to User Roles Page.
4.Click on edit permissions icon from the list .

  1. A pop up to edit permissions is displayed.
    6.Now Click on Save button.

When debug mode is set , there is an error message displayed on clicking on User Roles Page

Additional Information

Please refer the screenshots for more details

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.2.8
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Version426
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4.6

Activities

user225042

2020-06-11 15:00

 

DebugMode_UserManagement.png (86,956 bytes)   
DebugMode_UserManagement.png (86,956 bytes)   
UserRole_EditPermissions.png (99,799 bytes)   
UserRole_EditPermissions.png (99,799 bytes)   
gabrieljenik

gabrieljenik

2020-06-26 16:47

developer   ~58526

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1450

The error message on the first picture, I wasn't able to reproduce it.

The error message on the second picture was generated because of a missing view.
Path to view was fixed.
Path to view was also fixed for the batchdelete operation, which was failing too

user225042

2020-06-29 11:16

  ~58537

Last edited: 2020-07-02 14:47

When batchdelete operation performed,nbelow error was shown

16379_BatchDelete.png (89,279 bytes)   
16379_BatchDelete.png (89,279 bytes)   

user225042

2020-06-29 11:32

  ~58538

Last edited: 2020-07-02 14:47

Tested below scenario's by pulling PR:
1.Edit Permissions
Actual result: was able to save the updates successfully
2.Batch Delete operation
Actual result: Was able to navigate to delete pop up on clicking on Yes was successfully able to delete the user role
please refer the screenshot for more details

guest

guest

2020-07-02 14:40

viewer   ~58651

Last edited: 2020-07-02 14:47

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30242

lime_release_bot

lime_release_bot

2020-07-06 13:21

administrator   ~58712

Fixed in Release 4.3.3+200707

Related Changesets

LimeSurvey: master 776a5ca6

2020-07-02 14:40:46

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16379: When debug mode is set, there is an error message displayed on User Roles Page (#1450) Affected Issues
16379
mod - application/controllers/admin/PermissiontemplatesController.php Diff File

Issue History

Date Modified Username Field Change
2020-06-11 15:00 user225042 New Issue
2020-06-11 15:00 user225042 File Added: DebugMode_UserManagement.png
2020-06-11 15:00 user225042 File Added: UserRole_EditPermissions.png
2020-06-11 15:00 user225042 Priority none => normal
2020-06-11 15:00 user225042 Description Updated View Revisions
2020-06-11 15:00 user225042 Steps to Reproduce Updated View Revisions
2020-06-11 15:00 user225042 Zoho Sprints => |Yes|
2020-06-11 15:00 swendrich Zoho Sprints ID => 14469000000124001
2020-06-11 15:00 user225042 Status new => confirmed
2020-06-11 15:00 user225042 Zoho Sprints Yes => |Yes|
2020-06-11 15:05 user225042 Zoho Sprints Yes => |Yes|
2020-06-11 15:05 user225042 Database & DB-Version 5.7.30-0ubuntu0.18.04.1 => 426
2020-06-12 11:39 ollehar Product Version => 4.2.8
2020-06-12 11:39 ollehar Zoho Sprints Yes => |Yes|
2020-06-26 16:47 gabrieljenik Note Added: 58526
2020-06-29 11:16 user225042 Note Added: 58537
2020-06-29 11:16 user225042 File Added: 16379_BatchDelete.png
2020-06-29 11:32 user225042 Note Added: 58538
2020-06-29 11:32 user225042 File Added: 16379_DebugModeUserRole_Issues.png
2020-07-02 14:40 gabrieljenik Changeset attached => LimeSurvey master 776a5ca6
2020-07-02 14:40 guest Note Added: 58651
2020-07-02 14:47 swendrich Zoho Sprints Yes => |Yes|
2020-07-02 14:47 swendrich Status confirmed => resolved
2020-07-06 13:21 lime_release_bot Zoho Sprints Yes => |Yes|
2020-07-06 13:21 lime_release_bot Note Added: 58712
2020-07-06 13:21 lime_release_bot Status resolved => closed
2020-07-06 13:21 lime_release_bot Resolution open => fixed