View Issue Details

IDProjectCategoryView StatusLast Update
16354Bug reportsSurvey participants (Tokens)public2020-06-15 06:03
Reporterblocka Assigned ToDenisChenu  
PriorityhighSeverityblock 
Status resolvedResolutionfixed 
Product Version3.22.17 
Fixed in Version3.22.19 
Summary16354: Token based persistence not working in LTS Version 3.22.17+200525
Description

Participant beings survey with token, navigates few a question groups, and then closes web browser.
When they return, token based persistence isn't recognized, and they start new survey response, instead of survey being populated with existing response data.

Steps To Reproduce
  1. Create a survey with more than one question group, set to display by group, activate with with participant table
  2. Set Enable token-based response persistence: On
  3. Set Allow multiple responses or update responses with one token: On
  4. Begin survey, complete a few pages.
  5. Close browser
  6. Return to survey with same token
  7. Responses are not reloaded (although they are saved in database).

A short movie providing the test scenario on both LimeQuery and my local install with latest build:

https://www.dropbox.com/s/6z12im58r3m9lor/LS%20Bug%202020-06-01_14-03-04.MP4?dl=0

Additional Information

I notice that Version 3.22.17 on LimeQuery.com doesn't manifest this problem, but my local instance of 3.22.17+200525 does have this issue.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.22.17+200525
I will donate to the project if issue is resolvedNo
BrowserAny
Database & DB-VersionmySQL 5.6
Server OS (if known)CentOS
Webserver software & version (if known)
PHP Version7.x

Activities

blocka

blocka

2020-06-01 22:19

reporter   ~58129

I rolled back my code base to Version 3.22.16+200519 and token persistence works correctly -- appears a bug was introduced in 200525. To confirm, I updated back to 200525 after rolling back, and token persistence fails again.

blocka

blocka

2020-06-01 22:34

reporter   ~58130

Last edited: 2020-06-01 22:39

And it is changes to application/controllers/index.php between 200519 and 200525 that causes token persistence to fail.

cdorin

cdorin

2020-06-01 22:41

manager   ~58131

Thanks for report. It will be part of the next round of bug fixing :)

DenisChenu

DenisChenu

2020-06-02 08:12

developer   ~58134

Fixed in https://github.com/LimeSurvey/LimeSurvey/commit/7c39509fe77ebd742a9381514f8c67febfb289f7

Christin8

Christin8

2020-06-12 09:57

reporter   ~58261

Can anyone please tell me when this bug fix will be incorporated in an update? We have major issues with our current survey due to that bug. Thanks!

DenisChenu

DenisChenu

2020-06-12 10:05

developer   ~58262

It was in 3.22.19 and 2.22.18

If you still reproduce : please repprt another issue with sample lss

Christin8

Christin8

2020-06-12 10:48

reporter   ~58267

I searched for this issue (16354) on both GitHub and the release details/changelog for limesurvey3.22.19+200605 and I found nothing. Are you sure it is fixed and included? Where can I find the details for it?

Or was this issue (16354) implicitly fixed by https://github.com/LimeSurvey/LimeSurvey/commit/7c39509fe77ebd742a9381514f8c67febfb289f7 and not mentioned as fix again because it was a double recored issue for the same problem?

DenisChenu

DenisChenu

2020-06-12 10:50

developer   ~58268

Yes, it was : i introduce the bug some hour after release is done , i don't see release done , then don't create a mantis issue …
If i remind i merge in LTS some hour before release done …

Christin8

Christin8

2020-06-15 06:03

reporter   ~58275

Unfortunately, we still have issues. I opened another issue https://bugs.limesurvey.org/view.php?id=16386

Issue History

Date Modified Username Field Change
2020-06-01 20:04 blocka New Issue
2020-06-01 22:19 blocka Note Added: 58129
2020-06-01 22:34 blocka Note Added: 58130
2020-06-01 22:39 cdorin Priority none => high
2020-06-01 22:39 cdorin Status new => confirmed
2020-06-01 22:41 cdorin Note Added: 58131
2020-06-02 08:12 DenisChenu Note Added: 58134
2020-06-12 09:57 Christin8 Note Added: 58261
2020-06-12 10:05 DenisChenu Note Added: 58262
2020-06-12 10:05 DenisChenu File Added: Capture d’écran du 2020-06-12 10-04-48.png
2020-06-12 10:05 DenisChenu Assigned To => DenisChenu
2020-06-12 10:05 DenisChenu Status confirmed => resolved
2020-06-12 10:05 DenisChenu Resolution open => fixed
2020-06-12 10:05 DenisChenu Fixed in Version => 3.22.19
2020-06-12 10:48 Christin8 Note Added: 58267
2020-06-12 10:50 DenisChenu Note Added: 58268
2020-06-15 06:03 Christin8 Note Added: 58275