View Issue Details

IDProjectCategoryView StatusLast Update
16160Bug reportsOtherpublic2020-04-28 10:12
ReporterJmantysalo Assigned Topstelling  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.1.16 
Fixed in Version4.1.18 
Summary16160: Email to user group does not work
Description

Mail to all members -button gives

Email to xx- <xx@tuni.fi> failed. Error Message : Message body empty

It seems that application/controllers/admin/usergroups.php has code

$mailer->Body = $body;
foreach ($eguresult as $egurow) {
$mailer = \LimeMailer::getInstance(); // To reset error
$mailer->setTo($egurow->users->email, $egurow->users->users_name);
if ($mailer->sendMessage()) . . .

and this error disappears if I but the $mailer->Body = $body -line inside the loop, but this seems wrong way to solve problem.

Additional Information

Seems to be already confirmed, https://www.limesurvey.org/forum/development/120892-does-email-to-user-group-work/197417

TagsNo tags attached.
Complete LimeSurvey version number (& build)Versio 4.1.17+200414
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

DenisChenu

DenisChenu

2020-04-20 14:47

developer   ~57273

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=29847

DenisChenu

DenisChenu

2020-04-20 14:52

developer   ~57274

Thanks :)

Jmantysalo

Jmantysalo

2020-04-20 20:19

reporter   ~57279

Tested, seems to work. (The error message went away. Did not test on a machine that could actually send the mail.)

DenisChenu

DenisChenu

2020-04-21 09:08

developer   ~57280

I test on a machine allowed to send email

ollehar

ollehar

2020-04-22 11:47

administrator   ~57310

This fix was not possible to merge.

ollehar

ollehar

2020-04-22 11:48

administrator   ~57311

Please review re-applied fix: https://github.com/LimeSurvey/LimeSurvey/commit/756eb45a60541dbb3d0da7a54bf1ec88c78e9d6d

DenisChenu

DenisChenu

2020-04-22 12:13

developer   ~57313

@ollehar : dodn't understand ?

No need to merge : https://github.com/LimeSurvey/LimeSurvey/commit/08e7a4c78762e7580d8a92442830ccce781ef71b

It was done in master , usergroups file disappear ? I don't know what file replace it.

ollehar

ollehar

2020-04-22 12:15

administrator   ~57314

Yes, the file was moved during refactor of controllers. Please review Patricia's fix linked above.

pstelling

pstelling

2020-04-22 15:19

developer   ~57317

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=29928

ollehar

ollehar

2020-04-22 15:29

administrator   ~57318

Merged

lime_release_bot

lime_release_bot

2020-04-28 10:12

administrator   ~57417

Fixed in Release 4.2.1+200428

Related Changesets

LimeSurvey: master 08e7a4c7

2020-04-20 14:46:58

DenisChenu

Details Diff
Fixed issue 16160: Email to user group does not work
Dev: set ErrorInfo to empty string after senbd email
Affected Issues
16160
mod - application/controllers/admin/usergroups.php Diff File

LimeSurvey: master 756eb45a

2020-04-22 09:38:10

pstelling

Details Diff
Fixed issue 16160: (Email to user group does not work)fix has been done already in master. Since develop differs from master, fix has to be done again at this point. Affected Issues
16160
mod - application/models/UserGroup.php Diff File

Issue History

Date Modified Username Field Change
2020-04-20 12:56 Jmantysalo New Issue
2020-04-20 13:41 DenisChenu Assigned To => DenisChenu
2020-04-20 13:41 DenisChenu Status new => assigned
2020-04-20 14:47 DenisChenu Changeset attached => LimeSurvey master 08e7a4c7
2020-04-20 14:47 DenisChenu Note Added: 57273
2020-04-20 14:47 DenisChenu Resolution open => fixed
2020-04-20 14:52 DenisChenu Status assigned => resolved
2020-04-20 14:52 DenisChenu Fixed in Version => 4.1.18
2020-04-20 14:52 DenisChenu Note Added: 57274
2020-04-20 20:19 Jmantysalo Note Added: 57279
2020-04-21 09:08 DenisChenu Note Added: 57280
2020-04-22 11:47 ollehar Note Added: 57310
2020-04-22 11:48 ollehar Note Added: 57311
2020-04-22 11:48 ollehar Status resolved => feedback
2020-04-22 11:48 ollehar Resolution fixed => reopened
2020-04-22 12:13 DenisChenu Note Added: 57313
2020-04-22 12:15 ollehar Note Added: 57314
2020-04-22 15:19 pstelling Changeset attached => LimeSurvey master 756eb45a
2020-04-22 15:19 pstelling Note Added: 57317
2020-04-22 15:19 pstelling Assigned To DenisChenu => pstelling
2020-04-22 15:19 pstelling Resolution reopened => fixed
2020-04-22 15:29 ollehar Status feedback => resolved
2020-04-22 15:29 ollehar Note Added: 57318
2020-04-28 10:12 lime_release_bot Note Added: 57417
2020-04-28 10:12 lime_release_bot Status resolved => closed