View Issue Details

IDProjectCategoryView StatusLast Update
16149Bug reportsUser / Groups / Rolespublic2020-07-27 21:48
Reportercdorin Assigned To 
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.18 
Summary16149: See survey list - owner column is not correct
Description

The owner column should list the name of the survey owner, not "Administrator". Not sure why that is the case

Steps To Reproduce
  1. Create survey A.
  2. Create user X, provide him the necessary permissions (super admin in my example), and tell him to create survey B.
  3. Owner is "Administrator"

Even if you are the only admin, your username should be displayed there (as in LS3).

TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

related to 15904 assignedgabrieljenik Default survey admin & admin email not copied from user profile 
related to 16529 closedgabrieljenik After deleting a user who owned a survey, the survey list generates a dump 

Activities

cdorin

cdorin

2020-04-17 18:54

manager  

Selection_022.png (57,896 bytes)   
Selection_022.png (57,896 bytes)   
ricardoalmeida

ricardoalmeida

2020-05-27 22:11

reporter   ~58061

Hi, I am facing the same problem. I think it is related to the issue 15904.
Limesurvey version 4.2.4+200520 upgraded from 2.72.2+171017 using LDAP authentication.

gabrieljenik

gabrieljenik

2020-07-21 00:06

developer   ~59004

Last edited: 2020-07-24 10:19

Showing owner's full name

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1491

user225042

2020-07-21 13:34

  ~59017

Last edited: 2020-07-24 10:19

Tested the issue before pulling the PR, Issue exist. Tested the issue after pulling the PR, but the column is blank. I tried clearing application cache and closing the tab and coming back but it still remains same. Please refer the attachment for more details

16149_OwnerName_Surveylist.png (82,029 bytes)   
16149_OwnerName_Surveylist.png (82,029 bytes)   
gabrieljenik

gabrieljenik

2020-07-21 20:50

developer   ~59027

Last edited: 2020-07-24 10:19

Can I aks you to double check?
I have tried it again and seems to work fine.

image.png (19,117 bytes)   
image.png (19,117 bytes)   

user225042

2020-07-22 11:02

  ~59037

Last edited: 2020-07-24 10:19

I don't know what is the reason but I still see the column blank.

OwnerName_Blank.png (54,592 bytes)   
OwnerName_Blank.png (54,592 bytes)   
gabrieljenik

gabrieljenik

2020-07-22 15:35

developer   ~59041

Last edited: 2020-07-24 10:19

Showing owenr's users_name to match sorting criteria, survey details screen and avoid confusions if full name is not set

gabrieljenik

gabrieljenik

2020-07-22 20:45

developer   ~59052

Last edited: 2020-07-24 10:19

Also, users_name is what is being displayed on LS3

user225042

2020-07-23 14:47

  ~59058

Last edited: 2020-07-24 10:19

Tested the issue before pulling the PR, Issue exist. Tested the issue after pulling the PR, working as expected. Please refer the attachment for more details

user225042

2020-07-23 15:15

  ~59059

Last edited: 2020-07-24 10:19

What should it display when user logs in as admin. As I notice here as of now it shows the admin name. Is it the right behavior @gabrieljenik ?
Please refer the screenshot for details.

gabrieljenik

gabrieljenik

2020-07-23 18:45

developer   ~59061

Last edited: 2020-07-24 10:19

Hi,

No matter which user is logged in, the column should show user_names, not full names.
On the latest, full_names are being shown. Are you sure the latest patch was applied at that time?

Thanks

gabrieljenik

gabrieljenik

2020-07-23 18:53

developer   ~59062

Last edited: 2020-07-24 10:19

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30301

user225042

2020-07-24 10:16

  ~59072

Last edited: 2020-07-24 10:19

Yeah rechecked it, When logged in as admin also the username is displayed.
Thanks for Confirmation @gabrieljenik
Please refer the attachment

OwnerColumn_AdminLogin.png (91,425 bytes)   
OwnerColumn_AdminLogin.png (91,425 bytes)   
lime_release_bot

lime_release_bot

2020-07-27 10:52

administrator   ~59093

Fixed in Release 4.3.6+200727

Related Changesets

LimeSurvey: master 252b1f7a

2020-07-21 00:04:57

gabrieljenik

Details Diff
Fixed issue 16149: See survey list - owner column is not correct

Showing owenr's full name
Affected Issues
16149
mod - application/extensions/admin/survey/ListSurveysWidget/views/listSurveys.php Diff File

LimeSurvey: master 193616bb

2020-07-22 15:34:39

gabrieljenik

Details Diff
Fixed issue 16149: See survey list - owner column is not correct

Showing owenr's users_name to match sorting criteria, survey details screen and avoid confusions
Affected Issues
16149
mod - application/extensions/admin/survey/ListSurveysWidget/views/listSurveys.php Diff File

LimeSurvey: master 9df4af01

2020-07-23 18:53:07

eddylackmann


Committer: GitHub Details Diff
Merge pull request #1491 from gabrieljenik/bug/16149-See-survey-list-owner-column-is-not-correct

Fixed issue 16149: See survey list - owner column is not correct
Affected Issues
16149
mod - application/extensions/admin/survey/ListSurveysWidget/views/listSurveys.php Diff File

Issue History

Date Modified Username Field Change
2020-04-17 18:54 cdorin New Issue
2020-04-17 18:54 cdorin File Added: Selection_022.png
2020-04-17 18:54 cdorin Status new => confirmed
2020-04-17 18:54 cdorin Steps to Reproduce Updated View Revisions
2020-04-17 18:54 cdorin Zoho Sprints => |Yes|
2020-04-17 18:54 swendrich Zoho Sprints ID => 14469000000051001
2020-05-27 22:11 ricardoalmeida Note Added: 58061
2020-05-28 08:04 DenisChenu Relationship added related to 15904
2020-07-21 00:06 gabrieljenik Note Added: 59004
2020-07-21 13:34 user225042 Note Added: 59017
2020-07-21 13:34 user225042 File Added: 16149_OwnerName_Surveylist.png
2020-07-21 20:50 gabrieljenik Note Added: 59027
2020-07-21 20:50 gabrieljenik File Added: image.png
2020-07-22 11:02 user225042 Note Added: 59037
2020-07-22 11:02 user225042 File Added: OwnerName_Blank.png
2020-07-22 15:35 gabrieljenik Note Added: 59041
2020-07-22 20:45 gabrieljenik Note Added: 59052
2020-07-23 14:47 user225042 Note Added: 59058
2020-07-23 14:47 user225042 File Added: 16419_OwnerColumn_Username.png
2020-07-23 15:15 user225042 Note Added: 59059
2020-07-23 15:15 user225042 File Added: 16419_Username_Adminlogin.png
2020-07-23 18:45 gabrieljenik Note Added: 59061
2020-07-23 18:53 eddylackmann Changeset attached => LimeSurvey master 9df4af01
2020-07-23 18:53 gabrieljenik Changeset attached => LimeSurvey master 193616bb
2020-07-23 18:53 gabrieljenik Changeset attached => LimeSurvey master 252b1f7a
2020-07-23 18:53 gabrieljenik Note Added: 59062
2020-07-24 10:16 user225042 Note Added: 59072
2020-07-24 10:16 user225042 File Added: OwnerColumn_AdminLogin.png
2020-07-24 10:19 swendrich Zoho Sprints Yes => |Yes|
2020-07-24 10:19 swendrich Status confirmed => resolved
2020-07-27 10:52 lime_release_bot Zoho Sprints Yes => |Yes|
2020-07-27 10:52 lime_release_bot Note Added: 59093
2020-07-27 10:52 lime_release_bot Status resolved => closed
2020-07-27 10:52 lime_release_bot Resolution open => fixed
2020-07-27 21:48 gabrieljenik Relationship added related to 16529